Register Login
FIAT Auto Specialist Team
Reply
 
Thread Tools
Old 09-02-2008   #1
Join Date: Feb 2008
Location: Oldham, manchester
Posts: 356
Thanks: 6
Trader Rating: 0
Brooksy has donated!
United Kingdom 
Bad Earth

I just picked up a car i bought a fiat bravo 1.6 16valve 100sx i wired my sub up yesterday and the sub only works now and again, wondering if it was a bad earth cos it worked fine in my other car, i currently have it earthed to one of the nuts on the rear lights, is there a better place to earth it and where do other people earth theirs to?

thanks in advance

Brooksy
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Brooksy is offline Reply With Quote Quote 
Old 09-02-2008   #2
retro all the way!
Join Date: Jan 2008
Location: mirfield
Posts: 541
Thanks: 4
Trader Rating: 0
jonboy739 has donated!
United Kingdom 
Re: Bad Earth

Quote Originally Posted by Brooksy View Post
I just picked up a car i bought a fiat bravo 1.6 16valve 100sx i wired my sub up yesterday and the sub only works now and again, wondering if it was a bad earth cos it worked fine in my other car, i currently have it earthed to one of the nuts on the rear lights, is there a better place to earth it and where do other people earth theirs to?

thanks in advance

Brooksy
it might be if its painted were you are putting it on and its not making a good contact with the bodywork
__________________
TIPO SEDICIVALVOLE
I'VE GOT A BIGGER ONE THAN
YOU UNO DRIVERS!!
TRANSPORTING CARS NOW
SO KEEP ME IN MIND
jonboy739 is offline Reply With Quote Quote 
Old 09-02-2008   #3
Outsider.
 
MattMk1's Avatar
Join Date: Sep 2005
Location: Bradford/Cov
Posts: 757
Thanks: 27
Trader Rating: 0
MattMk1 has donated!
United Kingdom 
Re: Bad Earth

loose remote wire?
__________________
MattMk1 is offline Reply With Quote Quote 
Old 09-02-2008   #4
Join Date: Feb 2008
Location: Oldham, manchester
Posts: 356
Thanks: 6
Trader Rating: 0
Brooksy has donated!
United Kingdom 
Re: Bad Earth

hi thanks for the advice i will check both wires,will the earth wire actually work atall if it was connected to a painted part?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Brooksy is offline Reply With Quote Quote 
Old 09-02-2008   #5
Join Date: Feb 2008
Posts: 17
Thanks: 2
Trader Rating: 0
Re: Bad Earth

its a bad earth, if u attached your earth to a painted part, then no it should theoretically not work. Where are you earthing from? There should be earthing points under your carpet in the boot, failing that just grind an area of paint away and you will be in business.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

RITCHIE_GT is offline Reply With Quote Quote 
Old 10-02-2008   #6
Join Date: Feb 2008
Location: Oldham, manchester
Posts: 356
Thanks: 6
Trader Rating: 0
Brooksy has donated!
United Kingdom 
Re: Bad Earth

yeah you were correct lol it was a bad earth now i can annoy the neighbours with the bass
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Brooksy is offline Reply With Quote Quote 
Old 10-02-2008   #7
Join Date: Feb 2008
Posts: 17
Thanks: 2
Trader Rating: 0
Re: Bad Earth

rock on lol
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

RITCHIE_GT is offline Reply With Quote Quote 
Old 12-02-2008   #8
Join Date: Jan 2008
Posts: 70
Thanks: 1
Trader Rating: 0
Re: Bad Earth

Iv got both my earth in the same place and they work fine, you might wana try the amp?
__________________
IF ITS TO LOUD,YOUR TO OLD!
16" O-Z Gran Touring Wheels, 4" Magnex Japcan
Twin Air Filter Conversian, Custom CamShaft,
2 x 12" Jl Subs, 2 x 800w Alpine Amps,
k8rl is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
websites with BAD reviews on new renault clio??? plz help me!! beau Leisure Lounge 11 05-02-2006 20:31
Good or Bad???? charmed103 Leisure Lounge 21 14-01-2006 23:36
Bad reputation....???? chrisunoman Site Ideas 2 25-12-2004 16:33
(T) Windows misting really bad pcoltas Punto (Mk2/2b) 9 05-12-2004 03:03