Register Login
Shop4Parts - UK's largest online superstore for FIAT and Alfa Romeo parts
Reply
 
Thread Tools Search this Thread
Old 23-08-2021   #16
Join Date: Aug 2017
Location: Timisoara
Posts: 272
Thanks: 17
Trader Rating: 0
Romania 
Re: Random cutting out. Grande Punto 1.4 Dynamic

Quote Originally Posted by mikehopper View Post
Crank sensor?

It only really happens when the car is upto temp
Yes, it could totally be the crankshaft sensor. You can test it to make sure it is. Get it down of the car and mesure voltage with a multimetre between it's pins. And get a wrench (or any other magnetic metal) to the top of the sensor. If you get voltage and it changes in real time as you put the metal next to it it works fine on cold. Then get the sensor hot with a hair dryer or so and mesure the voltage again. If when you put the metal next to it and the voltage is down to 0 (and while cold was not 0) it is a bad sensor and you should replace it. If not, replacing it won't fix the problom.

About the alternator 13.8V is good voltage, you should worry when it drops under that. It could be higher is true, but 13.8 is a working value.

Another possible cause for your problem could be the manifold gaskets, the ones between the manifold and the head, there are one for each cylinder. If those are worn they can make such trouble like the one you are having.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by Mike1alike; 23-08-2021 at 22:16.
Mike1alike is offline Reply With Quote Quote 
Old 23-08-2021   #17
Join Date: Feb 2016
Posts: 486
Thanks: 27
Trader Rating: 0
United Kingdom 
Re: Random cutting out. Grande Punto 1.4 Dynamic

Hi Guys.

Ive read through all the notes and i would also look at the crank sensor, heat does cause them to change and they are often a culprit, they also dont trigger any EML lights when they dont work.

they are often in exposed areas so the wiring to them is exposed so this needs to be checked too.

Tim
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

timmycm850 is offline Reply With Quote Quote 
Old 24-08-2021   #18
Join Date: Jan 2011
Location: tamworth
Posts: 266
Thanks: 2
Trader Rating: 0
United Kingdom 
Quote Originally Posted by eeeno View Post
I've been there doing the same thing: Replacing parts by symptom and never fixed the real problem. It's going to be very expensive and of course if you ask here you get the list of most obvious causes but only one is a match. Lots of could bes. Usually ECU will set a code if a sensor is misbehaving.

Crankshaft position sensor should be the first one to suspect when car stalls when warm and only starts when cold.

If you keep foot on the accelerator , it doesn't stall, right? Then somehow it may have something to do with the throttle body. It needs a reset. Dont buy a new tb thought.

Edit: How about engine coolant temperature sensor? Have you checked its readings when warm? If it's just wrong, like never showing engine operating temperature no matter how far u drove, then cooling system may need to be refilled and bled. Check readings again, if no change , replace ect sensor. Ecu may think engine is colder than it is and keep enriching the fuel.
OK
So engine temp is showing...
I checked the conductivity of the crank sensor. Got a reading of between 0.2 to 0 while moving a spanner to it. If I tapped the sensor it would Spike to 2.4 ish.

So as I had a spare in the spares draw put it on and touch wood it's not stalled yet... I always thought when they failed o a warm/ hot engine it would need to cool down to restart, but not in this case..

I'll keep you updated in a few days , to see if it'll happen again. But usually it's pretty much as it got upto te.p and a few mins driving.
Likes Mike1alike liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

mikehopper is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Advice pls:- Random Beep when driving my 2003 punto 16 value Dynamic just wondering Punto (Mk2/2b) 5 05-08-2014 19:05
(T) 2001 Punto ELX JTD random cutting out Tipojay Punto (Mk2/2b) 4 04-04-2011 16:13
(T) Punto Dynamic cutting out when Braking Lxx Punto (Mk2/2b) 4 24-05-2009 18:22