Register Login
FIAT Auto Specialist Team
Reply
 
Thread Tools Search this Thread
Old 20-07-2019   #1
Join Date: Feb 2015
Posts: 160
Thanks: 1
Trader Rating: 0
United Kingdom 
Cruise control

i have a cruise control unit on my car that i have installed i have activated it on the multiecuscan but its still not working any idea why ?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

alexwr92 is offline Reply With Quote Quote 
Old 20-07-2019   #2
Join Date: May 2011
Location: Norfolk UK
Posts: 10,491
Thanks: 488
Blog Entries: 8
Trader Rating: 0
United Kingdom 
Re: Cruise control

Most likely the wiring isn’t there for it
__________________
Maker and voice behind the YouTube channel PuntoHowTo 10k subscribers canít be wrong

And now the owner of a shiny new PuntoHowTo Drivetribe
AndyRKett is offline Reply With Quote Quote 
Old 20-07-2019   #3
Join Date: Jan 2017
Posts: 2,990
Thanks: 407
Trader Rating: 0
Belgium 
Re: Cruise control

You need to activate it in two places: ECU and steering wheel ... or as Andy said the wiring isn't there :-(

BRs, Bernie

If someone here helped You fix -or better, understand- your issue, hit the thanks icon @ bottom right corner, it's free and makes us feel helpy ;-)
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Bernievarian is offline Reply With Quote Quote 
Old 20-07-2019   #4
Join Date: Apr 2011
Location: Near the M4
Posts: 23,026
Thanks: 810
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Quote Originally Posted by alexwr92 View Post
i have a cruise control unit on my car that i have installed i have activated it on the multiecuscan but its still not working any idea why ?
Need more info..

What kit.. what work have you done?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is online now Reply With Quote Quote 
Old 20-07-2019   #5
Join Date: Feb 2015
Posts: 160
Thanks: 1
Trader Rating: 0
United Kingdom 
Re: Cruise control

In what way do you mean ? Kit ? I have a payed for version of the multiecuscan ecu scan i have activated it on the ecu but still no luck my car is a 1.9 130hp multijet i can see the symbol but it just not light up or work for that matter
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

alexwr92 is offline Reply With Quote Quote 
Old 20-07-2019   #6
Join Date: Apr 2011
Location: Near the M4
Posts: 23,026
Thanks: 810
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Re: Cruise control

Just a stalk.. needing more wiring?

So MES cannot light the dash icon?

Did you perform a relearn?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is online now Reply With Quote Quote 
Old 20-07-2019   #7
Join Date: Feb 2015
Posts: 160
Thanks: 1
Trader Rating: 0
United Kingdom 
Re: Cruise control

No where to plug any other wires in mate


no mes not light the icon on the dash but says its activated on the ecu

Could you tell me what you mean by relearn i have only really used the mes to sort power steering n my airbag light out
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

alexwr92 is offline Reply With Quote Quote 
Old 20-07-2019   #8
Join Date: May 2011
Location: Norfolk UK
Posts: 10,491
Thanks: 488
Blog Entries: 8
Trader Rating: 0
United Kingdom 
Re: Cruise control

Wiring looms in cars are funny things, depending on the build can mean a different loom is fitted for seemingly the same job.

The switch on the steering column connects to the dashboard wiring loom, for cruise control to work the wiring has to be in the loom to carry the signals.

There may be no extra plugs on the switch when you connected it, you connected all the multiplugs there but were there any gaps or holes in the multi plug. I,e the plug has 10 places for a wire but only 9 of them are used.

Then the wiring has to join up with the wiring in the engine bay, this is not one full loom it’s bits that all clip together to carry the signals where they need to go.
Again if the wiring is not on the engine bay loom it won’t work.

I also remember from my old punto HGT, which had cruise control, there was a plug under the fuse box which was causing the cruise control to work intermittently, if there are extra wires that carry power from somewhere else under the bonnet, and these are missing the cruise control won’t worked.

The wiring issue is that, is the wiring from the column stitch to the engine ecu, complete and uninterrupted. If the wiring is not there 100% it won’t work.

Even if the wires seem to be there both ends, at the switch and at the ecu that doesn’t mean there isn’t still a gap in the middle somewhere.

If mes won’t allow you to test the cruise control light on the dash you have to wonder why, lack of bulb or lack of software in the body and dash computers to allow it to work.
Likes varesecrazy liked this post
__________________
Maker and voice behind the YouTube channel PuntoHowTo 10k subscribers canít be wrong

And now the owner of a shiny new PuntoHowTo Drivetribe

Last edited by AndyRKett; 20-07-2019 at 13:40.
AndyRKett is offline Reply With Quote Quote 
Old 20-07-2019   #9
Join Date: Feb 2015
Posts: 160
Thanks: 1
Trader Rating: 0
United Kingdom 
Re: Cruise control

Bin havein a look n the wires are there its wire 8 on the stalk plug n 40 some thing on the bcu in the dashboard but still no luck
Quote Originally Posted by AndyRKett View Post
Wiring looms in cars are funny things, depending on the build can mean a different loom is fitted for seemingly the same job.

The switch on the steering column connects to the dashboard wiring loom, for cruise control to work the wiring has to be in the loom to carry the signals.

There may be no extra plugs on the switch when you connected it, you connected all the multiplugs there but were there any gaps or holes in the multi plug. I,e the plug has 10 places for a wire but only 9 of them are used.

Then the wiring has to join up with the wiring in the engine bay, this is not one full loom itís bits that all clip together to carry the signals where they need to go.
Again if the wiring is not on the engine bay loom it wonít work.

I also remember from my old punto HGT, which had cruise control, there was a plug under the fuse box which was causing the cruise control to work intermittently, if there are extra wires that carry power from somewhere else under the bonnet, and these are missing the cruise control wonít worked.

The wiring issue is that, is the wiring from the column stitch to the engine ecu, complete and uninterrupted. If the wiring is not there 100% it wonít work.

Even if the wires seem to be there both ends, at the switch and at the ecu that doesnít mean there isnít still a gap in the middle somewhere.

If mes wonít allow you to test the cruise control light on the dash you have to wonder why, lack of bulb or lack of software in the body and dash computers to allow it to work.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

alexwr92 is offline Reply With Quote Quote 
Old 20-07-2019   #10
Join Date: Jan 2019
Location: Glasgow
Posts: 56
Thanks: 2
Trader Rating: 0
United Kingdom 
Re: Cruise control

Have you changed the brake switch and the clutch switch? These are both different in cruise control models. Also what year is your car? Grande Puntos come in two series and the wiring is slightly different in little place between the two models, for example the headlight connectors
__________________
Punto Eleganza Linea Edition
Teirminator is offline Reply With Quote Quote 
Old 20-07-2019   #11
Join Date: Feb 2015
Posts: 160
Thanks: 1
Trader Rating: 0
United Kingdom 
Re: Cruise control

Thats one thing i haven't changed come to think of it
Year of car if 2006
Quote Originally Posted by Teirminator View Post
Have you changed the brake switch and the clutch switch? These are both different in cruise control models. Also what year is your car? Grande Puntos come in two series and the wiring is slightly different in little place between the two models, for example the headlight connectors
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

alexwr92 is offline Reply With Quote Quote 
Old 20-07-2019   #12
Join Date: Jan 2019
Location: Glasgow
Posts: 56
Thanks: 2
Trader Rating: 0
United Kingdom 
Re: Cruise control

Mine is a 2006 as well and i'm going to be brutally honest, you'll be lucky if you can get it to work.

In your case with the stalk not doing anything, that's because the switches haven't been changed under the pedals, you wouldn't be able to turn it off so the system will never engage cruise control.
__________________
Punto Eleganza Linea Edition
Teirminator is offline Reply With Quote Quote 
Old 20-07-2019   #13
Join Date: Apr 2011
Location: Near the M4
Posts: 23,026
Thanks: 810
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Re: Cruise control

Both my 2007 model mjs fail to support cruise..

Same with my old jtd.

Often 2XECU specs one not supporting cruise.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is online now Reply With Quote Quote 
Old 06-04-2020   #14
Join Date: Apr 2020
Posts: 2
Thanks: 0
Trader Rating: 0
Croatia 
Re: Cruise control

Hi, i have really strange problem with my Grande Punto 1.9 multijet cruise control.

Car has Emotion pack, with oem cruise control, and alot of equipment. Last owner had problem with M32 gearbox. And he changed it with another M32 but in good condition (i think it's from OPEL/Vauxhall 1.9 cdti model).

I bought car and didn't notice that cruise control doesn't work in 5th and 6th gear. CC works in 3,4 gear but not 5,6. I didn't find solution in my region of balkans for this problem. So i saw this forum and i hope that someone knows what is problem.

Looks like my grande punto cannot recognize 5 and 6 gear ratio. My CC light works, everything works except 5 and 6th gear. I am desperate with this problem, i don't know how to resolve it. Can i learn ecu with multiecuscan to adjust or it is problem for some other measures ?

Please help. Thank you.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Jinx12 is offline Reply With Quote Quote 
Old 06-04-2020   #15
Join Date: Apr 2018
Posts: 216
Thanks: 42
Trader Rating: 0
Vatican City 
Post Re: Cruise control

"Strange" problem? Not at all.
Your suspicion is correct. Different gear ratios (so car doesn't know which gear this is - engine rpm doesn't match car speed).
MES will not fix this probably (>90% sure - I wish I'm wrong about this). This is ECU/BodyComputer (or some other module) software issue. You need some "hacker" (real-deal, not script kiddie) to modify this (tweak "memory dump").
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by GrandePunto PL; 06-04-2020 at 21:38. Reason: Nothing "strange". Normal behavior.
GrandePunto PL is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) cruise control fiat346 Stilo 16 04-01-2015 20:21
(T) Retrofit Cruise control in my stilo WITH cruise control light Daveystrings Stilo 30 25-09-2013 21:05
(T) Cruise Control Cloverleaf145 Croma 13 08-05-2013 16:11
(T) GP Cruise Control Old-Boy racer Grande Punto 7 28-01-2012 23:44
Cruise Control Ph1l FIAT Boo Archives 4 23-08-2002 14:45