Register Login
Mr FIAT - Your #1 source for vintage car parts
Reply
 
Thread Tools
Old 4 Weeks Ago   #1
Join Date: Dec 2014
Posts: 255
Thanks: 7
Trader Rating: 0
nikrox has donated!
United Kingdom 
The saga coninues...

After getting the earth strap 'sorted' the car is continuing to throw up a power steering fault code and is now sounding like a bag of spanners. My daughter tried to drive it over to mine today but she described the steering as being clunky and spinning..nothing like she was used to previously.
Any positive suggestions as where to start?..
I have suggested she contact the garage whio 'fixed' the faults originally.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

nikrox is offline Reply With Quote Quote 
Old 4 Weeks Ago   #2
Join Date: May 2018
Location: East Midlands
Posts: 55
Thanks: 3
Trader Rating: 0
United Kingdom 
Re: The saga coninues...

Quote Originally Posted by nikrox View Post
she described the steering as being clunky and spinning..nothing like she was used to previously.
I know it sounds obvious, but have you checked that City drive is turned off? My power steering goes super lightweight and clunky when city drive is turned on.

I know you mention a code, but this could be part of the issue
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

The Imaginative Lad is offline Reply With Quote Quote 
Old 4 Weeks Ago   #3
Join Date: Dec 2014
Posts: 255
Thanks: 7
Trader Rating: 0
nikrox has donated!
United Kingdom 
Re: The saga coninues...

I did ask that question,thanks.She cant remember so I guess I'll find out when I go and collect it..
Likes varesecrazy liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

nikrox is offline Reply With Quote Quote 
Old 3 Weeks Ago   #4
Join Date: Apr 2011
Location: Near the M4
Posts: 17,631
Thanks: 620
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Re: The saga coninues...

Always worth removing battery power for a few hours.

Might clear some weird stored junk.

The FAQs should have good info to point you towards a fix.

Charlie
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Old 3 Weeks Ago   #5
Join Date: Dec 2014
Posts: 255
Thanks: 7
Trader Rating: 0
nikrox has donated!
United Kingdom 
Re: The saga coninues...

I picked the car up today...first few minutes of the journey were shall we say...interesting.
Wheels seemed to be spinning,power steering was intermitent and then absolutly no power steering at all.
Id forgotten how heavy the steering is without power steering.

I have just disconnected the battery and wil check over the other earth points as in the FAQ.

My cheap scanner showed no fault codes so I'll take it to my local garage and use thier snap on kit and see what shows up.

Any ideas?..pointers?..
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

nikrox is offline Reply With Quote Quote 
Old 3 Weeks Ago   #6
Join Date: Jan 2017
Posts: 1,868
Thanks: 227
Trader Rating: 0
Belgium 
Re: The saga coninues...

Hi (who BTW?),

I'd have a look a the wiring from the battery to the Electric Power Steering unit.
There is a dedicate 70A (huge) fuse on the battery itself OR in the distribution box (depending of building year I guess), check for corrosion / melted connector.

On the PSE You'll find three connectors: Mains for both positive and negative power, CAN communication and analog signals in and out.
Check them for loose connection / corrosion (not likely) and measure 14VDC(ish) is present on the mains when engine is running. Grounding point (C014) needs to be ok of course ...

An important signal is the D+ that tell the controller the engine is started (or not), it needs checking too, that's pin #3 on connector C.
IMPORTANT: Fiat PROHIBITS measuring signal with "standard" meters for signals coming from the built-in torsion sensor since doing so may destroy it !!

I have attached a few Drawings that might help you a bit …

BRs, Bernie

If someone here helped You fix -or better, understand- your issue, hit the thanks icon @ bottom right corner, it's free and makes us feel helpy ;-)
Attached Thumbnails
Click image for larger version

Name:	Electric Power Steering wiring.JPG
Views:	10
Size:	78.8 KB
ID:	195534   Click image for larger version

Name:	Electric Power Steering pinout.JPG
Views:	9
Size:	23.9 KB
ID:	195535  

Click image for larger version

Name:	Electric Power Steering signals .JPG
Views:	6
Size:	31.2 KB
ID:	195536   Click image for larger version

Name:	Electric Power Steering block diagram.JPG
Views:	8
Size:	62.3 KB
ID:	195537  

Click image for larger version

Name:	Electric Power Steering motor driver.JPG
Views:	8
Size:	75.2 KB
ID:	195538  
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by Bernievarian; 3 Weeks Ago at 08:32.
Bernievarian is offline Reply With Quote Quote 
Old 3 Weeks Ago   #7
Join Date: Dec 2014
Posts: 255
Thanks: 7
Trader Rating: 0
nikrox has donated!
United Kingdom 
Re: The saga coninues...

My name is Nik..
This morning I re-connected the battery..no change.
I then removed and cleaned up the two earthing points under the ABS unit,after diconnecting the battery again.
Couldnt find the third on the drivers side leg at all.
Copperslipped the earth points.
The gearbox one is new so left alone.
No change.
No big 70 amp fuse by the battery or in the fusebox next to it. Biggest was a 60 amp and that looks ok.

Will try and find any other fuseboxes etc.

Thanks for the input Bernie ,was its the PSE?...
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by nikrox; 3 Weeks Ago at 12:54.
nikrox is offline Reply With Quote Quote 
Old 3 Weeks Ago   #8
Join Date: Jan 2017
Posts: 1,868
Thanks: 227
Trader Rating: 0
Belgium 
Re: The saga coninues...

Hi Nik,

Ooops, I meant EPS, Electric Power Supply … I you haven't that old fashioned fuse holder on the battery connector itself, then it's located in the distribution box, probably the large 60A, eventhough the EPS motor is said to draw as much as 80 amps in eLearn !!
Very first thing is to be sure you got all requested power(s) coming to the controler…

BRs, Bernie

If someone here helped You fix -or better, understand- your issue, hit the thanks icon @ bottom right corner, it's free and makes us feel helpy ;-)
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Bernievarian is offline Reply With Quote Quote 
Old 3 Weeks Ago   #9
Join Date: Dec 2014
Posts: 255
Thanks: 7
Trader Rating: 0
nikrox has donated!
United Kingdom 
Re: The saga coninues...

Hi Bernie,
I pulled the 60 amp fuse and the car was dead. I was thinking it may be the EPS fuse.
Do you know which one is ?...
When the cars turned on you can move to steering wheel freely,but this is accompanied by a chattering kinda noise. And more movement of the steering wheel than is reflected by tyre/wheel movement.
I will have to dig out my multimeter..my 'garage' is in two bedrooms and a shed whilst my new garage is being built..
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by nikrox; 3 Weeks Ago at 16:39.
nikrox is offline Reply With Quote Quote 
Old 3 Weeks Ago   #10
Join Date: Jan 2017
Posts: 1,868
Thanks: 227
Trader Rating: 0
Belgium 
Re: The saga coninues...

Hi Nik,

the 60A fuse sounds to be F2 in the drawing, which feeds the body computer (M001) with all the power it needs so it's normal the whole car died .

Do you mean the steering wheel just rotates a few degrees without action to the wheels and those would move only after that angle ? If so I'm afraid the torsion sensor (bad) or link to it (maybe a bit better) is the problem. No chance to tell without dismantling and this is not really recommended by Fiat as they claim it can't be rebuild with "factory accuracy".

So if you're pretty sure it's not an electrical issue (all powers OK) AND there is no other mechanical fault (have you tryed lifting the front wheels and check for free movement ?) it might be time to remove the EPS and inspect, either yourself or have it done by a specialist…

BRs, Bernie
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by Bernievarian; 3 Weeks Ago at 20:52.
Bernievarian is offline Reply With Quote Quote 
Old 3 Weeks Ago   #11
Join Date: Dec 2014
Posts: 255
Thanks: 7
Trader Rating: 0
nikrox has donated!
United Kingdom 
Re: The saga coninues...

Can anyone point me to the location of the fuse for the Eps?..The steering wheel moves around very easily almost like the wheels arent on the ground. It makes no difference when the city button is on either..
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

nikrox is offline Reply With Quote Quote 
Old 3 Weeks Ago   #12
Join Date: Jan 2017
Posts: 1,868
Thanks: 227
Trader Rating: 0
Belgium 
Re: The saga coninues...

Hi Nik,

so the EPS works then ? I'm confused now ! Or is it just intermittent ??
You say it feels very light as if the wheels weren't on the ground and the city switch doesn't make any difference; how about the city light on the dash, does it lit Always aswell ?? If so the City mode activation buton (I090) may be at fault, or it's signal wire shirted to ground. You really have to inspect the EPS loom …

BRs, Bernie

If someone here helped You fix -or better, understand- your issue, hit the thanks icon @ bottom right corner, it's free and makes us feel helpy ;-)
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Bernievarian is offline Reply With Quote Quote 
Old 2 Weeks Ago   #13
Join Date: Dec 2014
Posts: 255
Thanks: 7
Trader Rating: 0
nikrox has donated!
United Kingdom 
Re: The saga coninues...

Sorry..I'll try and be clear. When the engines first started the steering wheel has very little resistance when turning. Its not smooth though and you can hear a slight 'grrrrr' type noise.Also when you turn the wheel to either side and let it go it tries to move ,kinda judders and does not remain in the position it was initially left in.
After a few minutes,less than a mile, the steering goes very heavy and its obvious theres no power steering.
The city button does light up but theres no noticable difference.
I was hoping there was a fuse or relay that I could check.
Its a massive coincidence that this only happened when the non starting/earth issue happened.
I will look into the wiring etc when its not cold and raining like it is in Derby atm..
The car's not needed so theres no rush to sort.
But would like to sort ..
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

nikrox is offline Reply With Quote Quote 
Old 2 Weeks Ago   #14
Join Date: Feb 2012
Posts: 71
Thanks: 9
Trader Rating: 0
South Africa 
Re: The saga coninues...

Having exactly the same issue as you describe a while back I would really check the power connector and signal connectors going into the EPS located around knee height under the steering wheel. After driving through severe depression in the road at speed I had this happen briefly but got worse over a couple of weeks. When starting the car the steering was so light I initially thought a ball joint or rack link had broken. This was followed by first failing to assist turning to one side then steering itself to the other..Cleaning the contacts carefully sorted all the issues. Hope you get lucky with a simple fix
Thanks nikrox thanked for this post
Likes Bernievarian liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Frosty1961 is offline Reply With Quote Quote 
Old 2 Weeks Ago   #15
Join Date: Dec 2014
Posts: 255
Thanks: 7
Trader Rating: 0
nikrox has donated!
United Kingdom 
Re: The saga coninues...

Thanks for the reply...I shall go and buy some contact cleaner in the morning in preperation ..fingers crossed..
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

nikrox is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
saga saga Newbie Central 1 29-11-2011 20:01
(T) Brava heating saga over; new saga begins! melaskalany Bravo / Brava 2 21-04-2009 16:48
the saga continues Smee FIAT Boo Archives 11 22-06-2005 10:28
(T) A Stilo Saga... Ian_C Stilo 8 19-05-2005 17:18
The Saga Continues... thomas FIAT Boo Archives 7 16-08-2004 18:10