Register Login
The UK's No.1 Chrysler Owners Forum
Reply
 
Thread Tools Search this Thread
Old 25-04-2018   #1
Join Date: Jul 2017
Posts: 1
Thanks: 0
Trader Rating: 0
United Kingdom 
Check engine P0171

Hello guys,

I am a new driver and new to messing around under the bonnet. I have done a few things to my Fiat Grande Punto, 1.4 56 plate. Including replacing the rear breaks, front suspension, and exhaust. More than anything I am enjoying taking it to pieces and putting it back together. However I have come a little unstuck with the latest problem.

The check engine light came on and is reporting the error P0171 (Running Lean in Bank 1). I checked for leaks and could see / hear any. A friend told me it was one of the 02 sensors on the cat so I have replaced the pair.

Recently I have replaced the MAP sensor and disconnect the battery for an hour. When I start the car the check engine light is still on and it now stalls while driving. E.G driving a 35 in 4th gear and the engine stalls.

Staring to think I have bit off a little more than I can chew.

If anyone could offer a little insight I would be really grateful.

Kind regards,
Chros
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

cjones108 is offline Reply With Quote Quote 
Old 26-04-2018   #2
Join Date: Jan 2017
Posts: 2,990
Thanks: 407
Trader Rating: 0
Belgium 
Re: Check engine P0171

Hi Chris,

How was the P0171 after you replaced the lambda sensors ?
How was the MIL ?
Why have you replaced the MAP ?
Is it a genuine part ?
What are the revs @ 35 in 4th gear ?
Any particular condition for the engine to stall ?

BRs, Bernie

If someone here helped You fix -or better, understand- your issue, hit the thanks icon @ bottom right corner, it's free and makes us feel helpy ;-)
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Bernievarian is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Check Engine light, ESP & Hill Hold Not Available, Lumpy Engine. :( jrwilshire2003 500 7 08-09-2016 11:25
(T) error codes P1221 P0171 no use of throttle? Sir16v Stilo 1 05-05-2016 22:55
(T) Stilo 1.6 P0171 running lean. coolman61 Stilo 9 21-02-2012 11:17
(T) P0138 and P0171 Crossfordkid Grande Punto 1 30-09-2010 16:07