Register Login
The UK's No.1 Chrysler Owners Forum
Reply
 
Thread Tools
Old 20-03-2014   #1
Join Date: Mar 2014
Posts: 1
Thanks: 0
Trader Rating: 0
United Kingdom 
Electrical Issue

HI There

New to the forum but have had a good look around to see if my problem has come up before. Apologies if it has and I have missed it.
I have a 56 plate GP, 1.2. About a year ago the passenger electric front window stopped, no noise etc just wouldn't work from either switches. Decided this summer to get it fixed. However today I get in and my window has stopped working but low and behold the passenger side has now come back to life, from either switch.
Also, don't know if it is connected, I am getting the warning light for bulb replacement etc coming on and when it does the rear passenger side indicator stops working. I have changed the bulb here, there was nothing wrong with the old one. The only thing I have done recently is replace the passenger side front side light bulb that was failing.
Any advice would be good.

Many thanks
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

cardiffphil is offline Reply With Quote Quote 
Old 20-03-2014   #2
PANDA!!
 
Freebo's Avatar
Join Date: Aug 2010
Location: Selby
Posts: 4,057
Thanks: 151
Trader Rating: 0
Freebo is part of the official FF Events Team :)
Freebo has donated!
Ghost Ball Champion
United Kingdom 
Re: Electrical Issue

Could be a bad earth?
__________________
Freebo is offline Reply With Quote Quote 
Old 20-03-2014   #3
Join Date: Jan 2012
Location: Birkenhead
Posts: 695
Thanks: 23
Trader Rating: 0
United Kingdom 
Re: Electrical Issue

hi there try taking apart your window switch and cleaniing all the contacts inside, that may be the problem

the light issue might be bad contacts or as mentioned bad earth
__________________
http://bravo.fiatforum.com/
1.4 8v gp
1.9 td 306
1.2 corsa (x2)
1l micra.
lou5590 is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Electrical issue lights Simmo72 Bravo 3 21-10-2013 11:28
(T) New here and got an electrical issue! Pilp X1/9 6 07-01-2011 18:47
(G) Strange Electrical Issue ??? Shepherd Multipla 0 26-08-2010 17:37
(T) Electrical issue brown bear Punto (Mk2/2b) 0 21-05-2009 17:52
(T) Weird electrical issue Vectrolosys Barchetta 6 30-01-2009 19:29