Register Login
Shop4Parts - UK's largest online superstore for FIAT and Alfa Romeo parts
Reply
 
Thread Tools
Old 25-04-2013   #1
Join Date: Mar 2013
Posts: 8
Thanks: 0
Trader Rating: 0
United Kingdom 
Break / Parking Break Cable squeek

I have been ignoring a squeak for a few days but today I finally snapped.


There is a squeak coming from my drivers side rear drum.


I have whipped off the Wheel and drum cover and applied copper grease to the rear of the shoes where they contact the back of the drum on the inside.

Still the squeak lives, the squeak happens when you use the parking break or the breaks on release.

I understand there might be an equalizer at some point under here ? could this be the issue or just a dry cable ?


any ideas ?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

HZD is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) I think I have had a break through but not really sure Chris017 Stilo 5 31-12-2011 12:41
(T) Break master cylinder replaced still break issues. Multiplapersonality Multipla 1 27-12-2011 17:46
(G) Dilemma, to break or not to break? Modette Stilo 14 27-10-2010 10:32
(T) did my clutch cable just break? jimbob2joe Cinquecento / Seicento 5 20-10-2005 21:33