Register Login
im Axle Specialists
Reply
 
Thread Tools
Old 13-10-2012   #1
Join Date: Sep 2012
Posts: 5
Thanks: 0
Trader Rating: 0
United Kingdom 
Exclamation '06 Grande Punto Interior heater fan not working...

Hi,

I jumped into my '06 Grande Punto this morning to find that the heater fans are not working what so ever. I'm no mechanic so I do not have a clue why they would just stop working all of a sudden, they were working fine when driving home yesterday. Whatever setting I turn the switch to (1-4) there seems to be no noise coming from the heaters at all, therefore non of the fans are operating when I turn the switch so my first guess would be that the fuse has gone... maybe?

I've consulted my manual to find out about every fuse other than the interior fan heaters as there is nothing stated about them anywhere.

Could anyone here tell me what fuse I'd need to look up for the interior heater fans so I can locate the fuse to see if this is the problem.

Thanks.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

stiener is offline Reply With Quote Quote 
Old 13-10-2012   #2
puntopower!
 
matty seasider's Avatar
Join Date: May 2003
Location: northwest
Posts: 1,219
Thanks: 99
Trader Rating: 6
matty seasider has donated!
United Kingdom 
Re: '06 Grande Punto Interior heater fan not working...

Likes stiener liked this post
__________________
PUNTO GRANDE SPORTING MJET :
RED-DOT REMAP RUNNING 194.8Bhp 328.8 ft-lb torque

Last edited by matty seasider; 13-10-2012 at 19:58.
matty seasider is offline Reply With Quote Quote 
Old 13-10-2012   #3
Join Date: Sep 2012
Posts: 5
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: '06 Grande Punto Interior heater fan not working...

Thanks so much for your response Matty the first link you sent came in so handy I've fixed it already... for now anyways, it seem'd it was just a dodgy connection a quick reconnect of the block connector and its back up and running again. I should really use the search button more often.

Thanks again!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

stiener is offline Reply With Quote Quote 
Old 13-10-2012   #4
puntopower!
 
matty seasider's Avatar
Join Date: May 2003
Location: northwest
Posts: 1,219
Thanks: 99
Trader Rating: 6
matty seasider has donated!
United Kingdom 
Re: '06 Grande Punto Interior heater fan not working...

Quote Originally Posted by stiener View Post
Thanks so much for your response Matty the first link you sent came in so handy I've fixed it already... for now anyways, it seem'd it was just a dodgy connection a quick reconnect of the block connector and its back up and running again. I should really use the search button more often.

Thanks again!
Gladtohelp, amazing what that search button can do, if you go to advanced search, you can select to search just in grande Punto section which narrows results down considerably!
__________________
PUNTO GRANDE SPORTING MJET :
RED-DOT REMAP RUNNING 194.8Bhp 328.8 ft-lb torque
matty seasider is offline Reply With Quote Quote 
Old 13-10-2012   #5
Saving up for parts :(
 
ianal09's Avatar
Join Date: Jun 2012
Location: Belfast, Northern Ireland
Posts: 148
Thanks: 0
Trader Rating: 0
ianal09 has donated!
United Kingdom 
Re: '06 Grande Punto Interior heater fan not working...

had this problem before but luckily it was on the warranty period and they've change the loom that were totally busted
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

ianal09 is offline Reply With Quote Quote 
Old 11-09-2016   #6
Join Date: Apr 2013
Posts: 50
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: '06 Grande Punto Interior heater fan not working...

I had the same problem so replaced the resistor as that had burnt out. Now I am having trouble with the wiring that goes to the motor which I close to the resistor. I have to pull the wires up hard to get the motor to work. When I let this go the fan speed seems to slow down until it stops. Not good this time of year when I need to Dr mist the Windows. Any ideashow to solve this problem with the loose connections?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

welshy0007 is offline Reply With Quote Quote 
Old 12-09-2016   #7
Join Date: Nov 2014
Posts: 12
Thanks: 0
Trader Rating: 0
United Kingdom 
Quote Originally Posted by welshy0007 View Post
I had the same problem so replaced the resistor as that had burnt out. Now I am having trouble with the wiring that goes to the motor which I close to the resistor. I have to pull the wires up hard to get the motor to work. When I let this go the fan speed seems to slow down until it stops. Not good this time of year when I need to Dr mist the Windows. Any ideashow to solve this problem with the loose connections?
I'm having the same issues as you described, my wire keeps coming lose from the motor and I can't figure out how to keep it in place. I'm not sure why it keeps coming lose but Im guessing the clips have worn out and are no longer holding the wire in place. A new unit and connector would most likely fix it, unless anyone has another way around it.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

AshMobes is offline Reply With Quote Quote 
Old 26-09-2016   #8
Join Date: Sep 2016
Posts: 6
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: '06 Grande Punto Interior heater fan not working...

Having the same issues as the above 2 posts and kinda glad its not just me , my fan can go off wen going over a speed bump and back on going ovee another. My fan never lasts more than 2 mins wen on and stationary. But the weird thing is that it doesnt jus cut off , u can hear the gradual slowing down off the fan with the odd n random speed UP ? Before mine cuts off completly it kinda rattles a tad then goes off , if i push the connecter that goes into the fan it will start and stay on for aslong as its pushed up ... ive changed the resistor pack and had the fan out and connected to a seperate battery pack andnit spins like new . My nxt step is to check the voltage coming out from the connector to the fan . Will keep posted
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Leeharden is offline Reply With Quote Quote 
Old 26-09-2016   #9
Moderator
 
Andy Monty's Avatar
Join Date: Apr 2006
Location: East Yorkshire
Posts: 13,913
Thanks: 1166
Trader Rating: 0
Andy Monty has donated!
United Kingdom 
Re: '06 Grande Punto Interior heater fan not working...

Well you appear to have found the issue bet if you unplug the heater fan you will find the plug is all melted...

See the FAQ section at the top of the grande punto page
__________________
What Goes Up Must Come Down.....

Quote Originally Posted by Most Easterly Pandas View Post
Massive gash
Quote Originally Posted by EmmaM88 View Post
Just a little touch up
Andy Monty is offline Reply With Quote Quote 
Old 26-09-2016   #10
Join Date: Sep 2016
Posts: 6
Thanks: 0
Trader Rating: 0
United Kingdom 
Hey andy , yeah pretty clued up on it as ive scanned these forums for the past year or so regarding this is issue. Just need to fix it now with the cold mornings creeping in.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Leeharden is offline Reply With Quote Quote 
Old 26-09-2016   #11
Moderator
 
Andy Monty's Avatar
Join Date: Apr 2006
Location: East Yorkshire
Posts: 13,913
Thanks: 1166
Trader Rating: 0
Andy Monty has donated!
United Kingdom 
Re: '06 Grande Punto Interior heater fan not working...

Whilst it's bits might as well clean the motors slip ring


Appropriate size cable crimps and a pair of ratchet crimping pliers would probably be a half decent fix

A full new loom would be ideal


http://www.ebay.co.uk/itm/like/27220...D1100343996748
__________________
What Goes Up Must Come Down.....

Quote Originally Posted by Most Easterly Pandas View Post
Massive gash
Quote Originally Posted by EmmaM88 View Post
Just a little touch up
Andy Monty is offline Reply With Quote Quote 
Old 27-09-2016   #12
Join Date: Sep 2016
Posts: 6
Thanks: 0
Trader Rating: 0
United Kingdom 
Is the loom not a tricky fix or are they guides on here ?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Leeharden is offline Reply With Quote Quote 
Old 28-09-2016   #13
Join Date: Feb 2015
Posts: 40
Thanks: 1
Trader Rating: 0
United Kingdom 
Re: '06 Grande Punto Interior heater fan not working...

A while ago I posted something on this subject, using the search should throw something up. When I had this problem I came across a post on a Corsa forum which showed how to join the fastest fan speed wire with the resistor pack output wire. They way they designed the circuit means that both wires can be made to carry the load from the resistor pack instead of one wire, it also means you may get away without changing the loom. I did this on mine and it's been fine for over a year.
Likes Leeharden liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

cancunia is offline Reply With Quote Quote 
Old 28-09-2016   #14
Join Date: Sep 2016
Posts: 6
Thanks: 0
Trader Rating: 0
United Kingdom 
Quote Originally Posted by cancunia View Post
A while ago I posted something on this subject, using the search should throw something up. When I had this problem I came across a post on a Corsa forum which showed how to join the fastest fan speed wire with the resistor pack output wire. They way they designed the circuit means that both wires can be made to carry the load from the resistor pack instead of one wire, it also means you may get away without changing the loom. I did this on mine and it's been fine for over a year.
So what have u done to fix it , change the resistor pack ?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Leeharden is offline Reply With Quote Quote 
Old 28-09-2016   #15
Join Date: Feb 2015
Posts: 40
Thanks: 1
Trader Rating: 0
United Kingdom 
Re: '06 Grande Punto Interior heater fan not working...

No, the resistor pack was new on mine. It had been replaced to fix the heater not working problem which it did for about a week after I bought the car. The problem was also in the connector to the loom. You can also replace that connector and cut / crimp the loom.
I needed the car for work so had no time to wait for an over priced connector and so joined the fan high speed wire on the loom to the heater feed wire, but leaving them all connected at the resistor pack allows 2 pins to carry the load. Here's my earlier post, it's the very last one in the thread.

https://www.fiatforum.com/grande-pun...-heater-3.html
Thanks Leeharden thanked for this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

cancunia is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) Interior heater/fan not working!!! niamhh Punto (Mk1) 14 22-12-2012 19:46
(T) Heater fan stopped working on 2007 grande punto Samski21 Abarth Grande Punto 1 18-04-2012 09:51
(T) Grande Punto Heater Fan Not working petercd Grande Punto 2 29-03-2012 23:10
(T) Heater fan suddenly stopped working (1.2 56 Grande Punto) jamied92 Grande Punto 4 19-02-2012 00:41
(T) punto mk1 heater fan speed 1 not working? dark151 Punto (Mk1) 1 02-02-2009 20:03