Register Login
Mr FIAT - Your #1 source for vintage car parts
Comment
 
Guide Tools Search this Guide
Dualogic troubleshooting Guide
tonico77
05-06-2016
I decided to write this guide to help with Dualogic gearbox problems after seeing a Brazilian mechanic that has a youtube channel and deals with Dualogic gearbox repairs. He channel is very popular (<i>search Motortech dualogic</i>) and has even had clients transport their cars from Sao Paulo all
Old 04-07-2019   #30
Join Date: Apr 2011
Location: Near the M4
Posts: 24,258
Thanks: 906
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Quote Originally Posted by Paulpunto12 View Post
Can anybody please help me iam looking for replacement seals for punto dualogic robot can anybody help please where can I get some
Do you have the FIAT part numbers ?

Or is that your question..??
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Old 05-07-2019   #31
Join Date: Jun 2019
Location: Scottish Highlands
Posts: 7
Thanks: 0
Trader Rating: 0
United Kingdom 
I think it's the clutch position rod oil seal or o ring
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Paulpunto12 is offline Reply With Quote Quote 
Old 22-07-2019   #32
Join Date: Oct 2018
Posts: 8
Thanks: 0
Trader Rating: 0
United Kingdom 
Hi I have a fiat panda 2004 dynamic 1.2 automatic, had robot recently done by this guy as you can see his link on ebay+ kit clucth done. After 3 days it is stuttering on 1st gear and reverse.. Sometimes while on 3rd and 5th gear goes back straight to N, Not always though.
Could anyone help me please?
It is hard to find people to fix as well.

I follow Motortech chanell on YouTube as I am Brazilian living in UK, and I have spent already 600 o this panda to fix this
Could you please give me your opinion? I thought after watching videos it could be the clucth index degradation?
Attached Thumbnails
Click image for larger version

Name:	Screenshot_20190720-114254_eBay.jpg
Views:	84
Size:	707.3 KB
ID:	201605  
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

LeoPanda2004 is offline Reply With Quote Quote 
Old 13-11-2019   #33
Join Date: Nov 2019
Posts: 1
Thanks: 0
Trader Rating: 0
Croatia 
Re: Dualogic troubleshooting Guide

I have problem with Fiat Idea 1.3D with dualogic speed shifter, when ignition is on and engine off I can shift in all gears I can hear shifter works. When I start engine I can not shift in 1st gear only Revers but not every time.
I have diagnostic tool Bosch KTS 540, I have error 1773 Hydraulic pressure..., I read Hydraulic pressure 50 bar and is falling to 40 and pump kick on to 50 and cycle like that.
I read clutch value 5000, i tried to adjust screw lever for clutch adjusting sensor but nothing change.
sims to me everything is working fine all shiftngs are correct when with ignition on and engine off, once I start engine I can not shift I put in 1st and and shifter kicks back in N.
Vehicle have 157 000 km. Oil in actuator is Tutela CS speed.

Around me is very hard to find any help about dualogic actuator, a help will be very nice from you.
Please give me any idea what could be.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Croat is offline Reply With Quote Quote 
Old 13-11-2019   #34
Join Date: Apr 2011
Location: Near the M4
Posts: 24,258
Thanks: 906
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Quote Originally Posted by Croat View Post
I have problem with Fiat Idea 1.3D with dualogic speed shifter, when ignition is on and engine off I can shift in all gears I can hear shifter works. When I start engine I can not shift in 1st gear only Revers but not every time.
I have diagnostic tool Bosch KTS 540, I have error 1773 Hydraulic pressure..., I read Hydraulic pressure 50 bar and is falling to 40 and pump kick on to 50 and cycle like that.
I read clutch value 5000, i tried to adjust screw lever for clutch adjusting sensor but nothing change.
sims to me everything is working fine all shiftngs are correct when with ignition on and engine off, once I start engine I can not shift I put in 1st and and shifter kicks back in N.
Vehicle have 157 000 km. Oil in actuator is Tutela CS speed.

Around me is very hard to find any help about dualogic actuator, a help will be very nice from you.
Please give me any idea what could be.
Hi.

Member @mikehopper had a similar issue..also with an Idea.. maybe he can confirm the pressures his system had.

Charlie
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Old 30-12-2019   #35
Join Date: Dec 2019
Posts: 2
Thanks: 0
Trader Rating: 0
Iran 
Re: Dualogic troubleshooting Guide

Hello and thanks for your perfect post.
Actually I have an Alfa romeo Giulietta with TCT gearbox and I was googling about my car gearbox fault that I fund this very interesting forum.
Bravo!
As I guess, TCT gearbox of Alfa Romeo is same as what you're negotiating. this type of GearBoxes are fixed on Alfa, Fiat, Ferrari, Mazzerati and Lancia (or even American cars that I'm not sure!) that's why I'm asking for help here because I could not fine any useful information on Alfa romeo forums.
and my problem: My car has "Gear Not Available" fault and Alfa dealer told me it's Actuator problem and you should change it totally, but I did not trust them (because car was out of guaranty) and in my searches in Internet most of the comments was Battery problem.
so, battery changed by new one, and nothing changed! again errors and errors, specially in mountain roads or heavy city traffics!
again search and people told battery should be AGM battery but the battery that I was purchased was poor non AGM battery. so battery changed with brand new VARTA AGM battery, and wow! problem solved... during last week every thing was perfect with no errors!
so, I have to share my experience, you have to care about battery type too! Ah is not the only matter! battery type in modern cars should be same as original and in y case, should be AGM battery!
Hint: when the actuator pump is working (when you open the driver door) if you check with an ammeter (Clamp ampere meter) you can see it drains around 30 amps from battery, so every time that pump is running, this energy will drain from your battery (as I know alternator can not make this huge current, or maybe I'm wrong!)
and where is my problem? here:
Yesterday I bought an ELM327 with alfaobd android software.
I checked all the values of gearbox and clear all faults (it was remained from old battery disconnections) and then.... i go to "Active Diagnostics" and then "End of line/Service self-calibration"
during this procedure, new error came! and i can not clear fault! error code is "P290D", car and gearbox is working but gearbox check is ON and "Transmission error" in on the panel.
It's really appreciated if you help me to solve this problem.
Note: I'm living in Iran and due to US sanctions, there is no official alfa romeo dealer in y country!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

kazemiprince is offline Reply With Quote Quote 
Old 01-01-2020   #36
Join Date: Dec 2019
Posts: 2
Thanks: 0
Trader Rating: 0
Iran 
Re: Dualogic troubleshooting Guide

[SOLVED]:
I followed this procedure and problem solved:
1 - Disconnect gearbox pump power connector from it's unit. (in Giulietta unit is behind of head light driver side {left side driver side such as USA})
2- connect via alfaobd (or multiECUscan) and in active diagnostic choose "Accumulator depressurization" and start
3 - fill the gearbox hydraulic oil tank (Top of gearbox)
4 - connect pump power cord to unit
5 - alfaobd / Active Diagnostic / "clutch bleed"
6- alfaobd / Active Diagnostic / "End of line/service self-calibration"
wow.... finished.
Note: be sure car battery is full, I recommend to before starting the steps, turn on the engine and wait 5 minutes to be sure battery is full
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

kazemiprince is offline Reply With Quote Quote 
Old 25-02-2020   #37
Join Date: Feb 2020
Posts: 1
Thanks: 0
Trader Rating: 0
Dominican Republic 
Hey guys I have a Fiat punto, either grande or Evo. Not sure. But I've been having the "Check Transmission issue". The car goes on "N" while I'm driving. Usually when I'm slowing down and the car is shifting gears down. I took it to the Fiat in my country and they "fixed it" by "recalibrating it". I've gone like 3 times and they've never fixed it. So I've been doing my research, bought an OBD that would read the ECU of my car and with the help of a friend I found out the error. It is P1773-7B (attached).

I found a technician who works for Fiat in my country and told me it is probably missing a bit of Selespeed fluid...I wanna check but I dunno where to check. Any help?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

abepaniagua is offline Reply With Quote Quote 
Comment
Currently Active Users Viewing This Guide: 1 (0 members and 1 guests)
 
Guide Tools Search this Guide
Search this Guide:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Guide Guide Starter Category Comments Last Post
(G) braking imbalance troubleshooting microphonehead Panda (Classic) 8 26-02-2014 18:11
(T) Alternator troubleshooting? Tex Gore Punto (Mk2/2b) 4 07-01-2010 23:38
(T) Once again clunking front end, troubleshooting inflightfeather Marea 4 14-06-2006 16:59
Electrical troubleshooting polecat Lets Talk FIAT 0 29-04-2006 23:16
wipers troubleshooting adi FIAT Boo Archives 0 06-05-2002 10:16