Register Login
im Axle Specialists
Reply
 
Thread Tools
Old 18-05-2014   #1
Join Date: Mar 2011
Location: Rossendale
Posts: 465
Thanks: 0
Trader Rating: 0
saw has donated!
United Kingdom 
loose connection warning

had this come up on dash at the same time engine cuts out. disconnecting + from battery and refit it works any ideas?
__________________
mk1 punto now
saw is offline Reply With Quote Quote 
Old 18-05-2014   #2
Join Date: Jul 2008
Posts: 3,273
Thanks: 0
Trader Rating: 0
United Kingdom 
I would just wiggle looms and see if it happens again, then once you have the right loom, go wire by wire.. narrow it down.
Stuart is offline Reply With Quote Quote 
Old 18-05-2014   #3
Stick your own title
 
mrcinquecento's Avatar
Join Date: Apr 2008
Location: Dundee
Posts: 1,598
Thanks: 78
Trader Rating: 0
mrcinquecento has donated!
United Kingdom 
Do you lose all electrics when it cuts out?

If so it sounds like the problem is perhaps the positive battery terminal itself, either the terminal or the wire to it.

If not.... I'm Currently doing the wiring loom on the cinq so i'll assume it's a similar setup power/ignition wise. If so there's also an ignition trigger wire connected to a bullet type terminal, which "should" be connected to a fuse (Maxi?), so it could be traced back from that to the connector to check that's secure, the fuse too, check that's not wiggling about.
__________________
www.fiat-scotland.com,the home of all things both scottish and italian. it's a bit like having an irn bru with your pizza, only much tastier

98 Fiat Cinquecento Sporting 16v, 94 Land Rover Discovery 300tdi
mrcinquecento is offline Reply With Quote Quote 
Old 21-05-2014   #4
Join Date: Mar 2011
Location: Rossendale
Posts: 465
Thanks: 0
Trader Rating: 0
saw has donated!
United Kingdom 
no electric loss just engine cut out recovery said alternator faulty but i dont think it is, some think crank sensor but car runs locally fine. im not happy with terminal connection so i will look at that at weekend, MES has been mentioned also but as it needs windows 8 to run software i need to change pc soo im also thinking for £20 ish for crank sensor replacement would be easier and as i have nfi how to use mes anyway... Thanks Stuart & Mark
__________________
mk1 punto now
saw is offline Reply With Quote Quote 
Old 24-05-2014   #5
Join Date: Mar 2011
Location: Rossendale
Posts: 465
Thanks: 0
Trader Rating: 0
saw has donated!
United Kingdom 
have new crankshaft sensor just need it to be dry to change it over, no happy about + terminal on battery still so ill look at that as well
__________________
mk1 punto now
saw is offline Reply With Quote Quote 
Old 18-10-2014   #6
Join Date: Mar 2011
Location: Rossendale
Posts: 465
Thanks: 0
Trader Rating: 0
saw has donated!
United Kingdom 
replaced crankshaft sensor (just above starter motor) all fine since replaced
__________________
mk1 punto now
saw is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump