Register Login
Save up to 15% with Adrian Flux insurance!
 
 
Thread Tools
Old 12-06-2008   #1
Dave
Guest
Electrical Issue

Hi all,

First of all I would like to say hello.

I have recently bought a Brava 1.6 sx and really like the car think it drives well but I have 2 major issues with it and wondered if you guys could possibly help me.

The first issue is the fact that all the ignition fed electrics have stopped working, by what I mean front/rear wipers, dipped headlights, main beam, temperature blower, cig lighter etc etc. They stopped working Friday and then came on randomly but now they have stopped all together now. I was told it was the fuse box so I replaced that and still have the same problem.

My other issue is how much fuel it goes through, Im getting about 17mpg at the moment which cant be right. The engine starts ok and ticks over ok.

Sorry for the long post.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Old 12-06-2008   #2
Ed
Guest
Re: Electrical Issue

First port of call for the MPG issue would be to change all of the service items (oil, oil filter, air filter, sparks and ht leads)
The ignition electrics issue does outwardly sound like a fuse problem. When you say you've replaced the fuse box, do you mean you've replaced the whole lot? Beyond that i'd check that all the earth wires are properly connected.

Ed
__________________________________________________ __________
1.2 Bravo 80 SX
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Old 13-06-2008   #3
Dave
Guest
Re: Electrical Issue

With regards to the fuse box, Yes I did replace the whole unit.

When you say check its earthed correctly. I checked the earths under the dash board on the left and right of the car and they are ok, should I check the earths under the bonnet aswell??
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Old 13-06-2008   #4
Anonymous
Guest
Re: Electrical Issue

it looks like an ignition switch issue or the switch fuse/wire. 40 amp fuse, Obviously not blown or the units would not work. Look for corrosion and tightnes in the fuse holder
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Old 13-06-2008   #5
Anonymous
Guest
Re: Electrical Issue

Also check block connections, spray with switch cleaner,(from maplins)
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Old 14-06-2008   #6
Von
Guest
Electrical Issue


Hi, I had similar electrical issues when I got my HGT (petrol consumption was better though). My other half sprayed everything with contact cleaner and checked all fuses (hundreds of the buggers) and, touch wood, seems to have sorted it out.

Von
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Old 14-06-2008   #7
Joske
Guest
Re: Electrical Issue

It definately sounds to me like your stalks have gone faulty which is a very common thing. They can take out the heater and cig lighter out at the same time. So i'm betting on it that its this. New ones can be had from the scrapyard for about 5-10. Ebay has some too.

A good service should see the car return better fuel economy, also check your tyre pressures are correct.



Items For Sale:
Fiat Bravo/a Passenger Airbag Covers to suit MK1 & MK2, Foglight Switch Panel for MK1 & MK2, Fiat Bravo/a Headlamp Washer Jets, Bravo & Marea Workshop Manuals, Fiat Bravo Haynes Manual &, Fiat Bravo Owners Manual on CD etc...

Contact Me for more details.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

 
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump