Register Login
Save up to 15% with Adrian Flux insurance!
 
 
Thread Tools
Old 19-05-2008   #1
Dan
Guest
HGT, suddenly over heating and blowing dust?

Hey,
Just this morning half way through my standard 2 hour journey the temperature soared.
Having only corrected the oil and water yesterday i found strange, stopped, and found the water coolant to be boiling over and steaming. I waited for it to cool, before adding a further 5 litres untill correct and continuing.
For a while, on the motorway at least, the temperature was fine, but the second i touched off the motorway the temp soared again.
It seems to have burnt off a couple of litres of oil in the process too.

This also seemed to conicide with the in car heating turning funny too. On cold the air flow is clear, but with the slightest temperature added the fans start to blow out a thick whitish dust/smoke.
Any ideas? could it be the air filter?

Any suggestions would be greatly appreciated.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Old 19-05-2008   #2
Ozric-Al
Guest
Re: HGT, suddenly over heating and blowing dust?

Sounds like head gasket.



"Doctor said to give up Keee-Babs. I said 'No, no-no'"
My Members Page
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Old 20-05-2008   #3
Carroll
Guest
Re: HGT, suddenly over heating and blowing dust?

It don't sound too clever, I'm afraid. Which model are we talking - is your's a turbo diesel?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Old 20-05-2008   #4
Carroll
Guest
Re: HGT, suddenly over heating and blowing dust?

Scrap that - I've just re-read the title properly, it says HGT. I'm with Ozric-Al on this one
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Old 20-05-2008   #5
Dan
Guest
Heater Matrix Anyone?

Thanks for the advice....

Its definatly the Heater Matrix, its peeing out into both foot wells.
I have managed to get a good look at it, and found a missing screw (God knows).
But after replacing all i found was a slight stem in the flow, so basically i can now get to work providing i have a bottle with me.

Looking at the matrix, the pipes and flange/gasket seem to be in good condition, so i am now assuming that the Heater Matrix is faulty.

Does anybody know of one going?

Cheers

Dan
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

 
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump