Register Login
im Axle Specialists
 
 
Thread Tools
Old 28-01-2006   #1
Gav
Guest
Electrical problems - help !

Right, I'm having few problems with my electrics - a shock to all bravo owners I'm sure !
I keep getting an odd ticking noise that sounds like its coming from the steering column and at times when i flick the main beam on the power flicks off for a split second and then back on again. also on the odd occasion when i switch the ignition off the power just goes off completely so i cant operate the alarm. it then stays off for a random amount of time and then comes back on when it fancies.
In addition the front wipers only work on the fastest setting and none of the others.
Does anyone have any idea what the cause of this may be ?
Could it be a faulty stalk assembly ?

Thanks in advance

Gav
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Old 28-01-2006   #2
Sabre 23
Guest
Re: Electrical problems - help !

Stalks? Almost certainly, IMO.

Mark.
Council estate lad.
And proud of it!

Member of the Guild of Experienced Motorists.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Old 29-01-2006   #3
david
Guest
Re: Electrical problems - help !

yup i would go for the stalk as well m8
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

 
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump