Register Login
The UK's No.1 Chrysler Owners Forum
Reply
 
Thread Tools
Old 24-01-2018   #1
Join Date: Jan 2018
Posts: 19
Thanks: 1
Trader Rating: 0
United Kingdom 
Unplugged MAF but no EML on???

Hi all,

Im trying to diagnos a fault i have with juddering on light acceleration between 1600rpm and 2000rpm so i have disconnected the MAF sensor and ran for about 20 miles with atleast 5 stops within those miles and still no engine management light coming on, is this right?

Im led to believe unplugging the MAF sensor i should have the EML light on almost instantly?

Also doing this does not stop my judder.

Cheers 😎
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Trickymicky85 is offline Reply With Quote Quote 
Old 24-01-2018   #2
Became old and sensible
 
MrDerv's Avatar
Join Date: Aug 2003
Location: Durham
Posts: 2,664
Thanks: 21
Trader Rating: 0
MrDerv has donated!
United Kingdom 
Re: Unplugged MAF but no EML on???

A light will appear if you have disconnected it while the engine is running (and engine will subsequently cut out).

If you've disconnected it before turning the ignition on, then no EML, but will run on a different fuelling strategy for the lack of MAF reading
__________________
Current Garage
Mine: 2013 VW Passat Sport BlueMotion Tech 2.0 TDI Stage 2 Mapped
Hers: 2007 Renault Megane 1.6 VVT Auto Dynamique

MrDerv is offline Reply With Quote Quote 
Old 24-01-2018   #3
Join Date: Jan 2018
Posts: 19
Thanks: 1
Trader Rating: 0
United Kingdom 
Re: Unplugged MAF but no EML on???

Ah thanks, i did disconnect before running the van.

Would that be the same for the EGR valve? I also disconnected that before running and drove for 20 miles (ish) and no EML light for this either 😬
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Trickymicky85 is offline Reply With Quote Quote 
Old 24-01-2018   #4
Moderator
 
g8rpi's Avatar
Join Date: Nov 2013
Location: Cambridge
Posts: 3,929
Thanks: 393
Trader Rating: 0
g8rpi has donated!
United Kingdom 
Re: Unplugged MAF but no EML on???

The EGR failure detection (if implemented) uses the MAF signal so with no MAF you won't get an EGR failure warning.

Robert G8RPI.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

g8rpi is offline Reply With Quote Quote 
Old 24-01-2018   #5
Join Date: Jan 2018
Posts: 19
Thanks: 1
Trader Rating: 0
United Kingdom 
Re: Unplugged MAF but no EML on???

All makes sense now, thanks for your help 😎
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Trickymicky85 is offline Reply With Quote Quote 
Old 31-01-2018   #6
Join Date: Jan 2017
Posts: 38
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Unplugged MAF but no EML on???

Did running the van with egr blanked off fix the judder? Mine is getting on my nerves now doesn’t seem as often or as noticeable if I put an additive such as wynns goldtreatment or redex in and run it. Very confusing lol
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Saturdaynightbeaver31 is offline Reply With Quote Quote 
Old 02-02-2018   #7
Join Date: Jan 2018
Posts: 19
Thanks: 1
Trader Rating: 0
United Kingdom 
Re: Unplugged MAF but no EML on???

No judder still here, iv literally done everything i can think of too even down to change the dual mass and clutch. I have another thread on it with all the stuff iv done and still a judder 🙈
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Trickymicky85 is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Running fault cured when EGR unplugged. ToeKneeG Stilo 2 06-05-2016 18:13
(T) Mysterious wire unplugged in multijet? MountainRunner Panda 4 19-08-2014 17:16
(T) Found unplugged jack in the engine bay notorious Croma 5 16-08-2010 18:24
(T) Driving with MAP sensor unplugged? tomandsophie Cinquecento / Seicento 3 17-06-2005 00:10
Ok to drive JTD with maf sensor unplugged? Chris FIAT Boo Archives 1 15-05-2005 23:44