Register Login
Shop4Parts - UK's largest online superstore for FIAT and Alfa Romeo parts
Reply
 
Thread Tools
Old 01-10-2016   #1
Join Date: Jul 2014
Posts: 8
Thanks: 0
Trader Rating: 0
United Kingdom 
Strange Horn Problem

My 52 plate Doblo 1.9 diesel has developed a strange horn problem.

One minute the horn will work fine, then it wont, then half an hour later it will work.
It's really weird, last week it worked all week, then it stopped working, then it started working again ten minutes later when I tried it, and so on.

It's currently working, but I need it sorted properly for the M.O.T.

Last week I changed the rotary squib thingy and the indicator/wiper stalk unit, but that never sorted it.

Could the horn relay be on it's way out ? Anyone know where it is on this model ? I haven't got a clue.

Has anyone got any suggestions? It's doing my head in
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

spooncoot is offline Reply With Quote Quote 
Old 05-10-2016   #2
Join Date: May 2009
Location: Southampton, England
Posts: 455
Thanks: 17
Trader Rating: 0
United Kingdom 
Re: Strange Horn Problem

It probably a dodgy earth at the horn side, take the horn off, clean up the contacts, make sure the wire to earth is sound. Check impedance to earth.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

johnhififan is offline Reply With Quote Quote 
Old 05-10-2016   #3
Join Date: Apr 2011
Location: Near the M4
Posts: 21,137
Thanks: 744
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Re: Strange Horn Problem

Quote Originally Posted by spooncoot View Post
My 52 plate Doblo 1.9 diesel has developed a strange horn problem.

One minute the horn will work fine, then it wont, then half an hour later it will work.

Last week I changed the rotary squib thingy and the indicator/wiper stalk unit, but that never sorted it.

Could the horn relay be on it's way out ? Anyone know where it is on this model ? I haven't got a clue.

Has anyone got any suggestions? It's doing my head in

so it's NOT dependant on the position of the steering wheel..??
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Old 05-10-2016   #4
Join Date: Jul 2014
Posts: 8
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Strange Horn Problem

Quote Originally Posted by johnhififan View Post
It probably a dodgy earth at the horn side, take the horn off, clean up the contacts, make sure the wire to earth is sound. Check impedance to earth.
Thanks for that, I'll give it a go at the weekend
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

spooncoot is offline Reply With Quote Quote 
Old 05-10-2016   #5
Join Date: Jul 2014
Posts: 8
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Strange Horn Problem

Quote Originally Posted by varesecrazy View Post
so it's NOT dependant on the position of the steering wheel..??
I don't know to be honest. It might be, that's why I'm asking if anyone has any ideas
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

spooncoot is offline Reply With Quote Quote 
Old 06-10-2016   #6
Join Date: Apr 2011
Location: Near the M4
Posts: 21,137
Thanks: 744
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Re: Strange Horn Problem

years ago I had a car that failed MOT on horn, then realised it was only dead with wheels
" straight ahead" ,
it had worn a dead-spot in the wheels contactor "slip-ring" ,
I turned the wheel upside down - so when on the MOT ramp it always worked perfectly..
Likes johnhififan liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Old 18-10-2016   #7
Join Date: May 2009
Location: Southampton, England
Posts: 455
Thanks: 17
Trader Rating: 0
United Kingdom 
Re: Strange Horn Problem

My old mirafiori 131 had twin horns at the front, which didn't work initially due to bad earth but once I had sorted that, and tweeked the adjustment screw out a bit, they were the loudest horns ever, made me jump every time just bipping it.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

johnhififan is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) Strange horn scenario! drumdmc Bravo / Brava 2 24-07-2012 19:03
(T) Problem with the horn... itiejim Multipla 0 13-06-2010 12:07
(T) Horn not working. Anyone else had this problem and what was the problem? Rick01 Bravo / Brava 1 02-10-2009 08:20
(T) Horn Problem - Need help hands226 Punto (Mk2/2b) 13 26-07-2008 01:45
(T) horn problem cm246 Uno 8 24-08-2005 18:01