Register Login
Save up to 15% with Adrian Flux insurance!
Reply
 
Thread Tools
Old 13-06-2012   #1
Join Date: Jan 2012
Location: Dublin
Posts: 3
Thanks: 0
Trader Rating: 0
Ireland 
Camshaft position sensor, MAF & Engine speed sensor

Hi everybody, I've been a member of the forum for a while but this is my first post. So thanks for all the info so far.
Fiat Doblo Cargo (223) 1.3 JTD, year 2005.
ECU Marelli 6F3 EOBD
1 - problem with power, no/flat acceleration. Same as in the posts for EGR,
MAF & hose damage.
2 - Checked MAF by disconnection, slight increase in acceleration but still not right.
3 - Cleaned MAF, ran rough. Disconnected while running - idle normal. Still no/flat acceleration. Shut engine off, refused to start.
4 - Got fiat scan. Results, camshaft position sensor - high signal, Glow plug sensor - no signal. I also got an error message for the MAF but I replaced it with a new Bosch unit.
5 - I've checked the continuity of the CPS to the ECU, its fine (which means my multimeter is giving a constance beep on the continuity test). The voltage readings I'm getting from the CPS sensor are pink 4.99 v, pink black 4.99v, and earth/purple .003 (taken from back of sensor - sensor plugged in). I also got a new CPS sensor, now I've got two.
6 - I've also checked my MAF sensor for continuity, again its fine. The voltage reading I'm getting from that are, blue .99v, light blue green 4.99 v,light blue black .280/.005/.001 v, yellow grey 12.40 v, brown 2.77 v.
7 - After repeatedly trying to start the van, I got a engine speed sensor - no signal error from fiat scan, this warning is intermittent. I've only gotten it twice.
So my question, are these the right voltages that I'm getting from the MAF & CPS sensor and any other ideas .
What about the earth signal I'm getting are these within normal range.
I'm also going to check the Engine speed sensor/crank sensor for continuity with ECU & Voltage but I need values for voltage from ECU.
Any ideas, please
Thanks
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Cathalo is offline Reply With Quote Quote 
Old 15-06-2012   #2
Join Date: Jan 2012
Location: Dublin
Posts: 3
Thanks: 0
Trader Rating: 0
Ireland 
Re: Camshaft position sensor, MAF & Engine speed sensor

Hi, its me again. After taking a look at the Technical specifications for the MAF & CPS, I'm happy that the readings I'm getting are right(normal), If not please let me know.
I've taking readings from the Engine speed sensor/crank sensor from the ECU and have done a continuity test. The voltages I was getting from the sensor plug (not connected to the sensor itself) where 2.53v & 1.50v, these where verified at the ECU. I couldn't find any values on elearn for this sensor, just how it works (which I wouldn't call detailed info on the subject).
I want to check the sensor itself, what the resistance should I get from it?.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Cathalo is offline Reply With Quote Quote 
Old 15-06-2012   #3
Join Date: Jan 2012
Location: Dublin
Posts: 3
Thanks: 0
Trader Rating: 0
Ireland 
Re: Camshaft position sensor, MAF & Engine speed sensor

So, I've gotten a reading of between 760 to 774 Ohm's from the sensor (engine speed sensor/crank sensor), I'm getting a different reading at different times, when I take them they settle and remain constant, i.e a constant 760 Ohm the first reading.
I found a replacement sensor online which they stated 780 Ohm for that replacement.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Cathalo is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) camshaft position sensor stallpaul Ulysse 2 13-05-2014 10:45
(G) PROBLEM!!! my mk2 punto engine doesnt have a camshaft position sensor!! corky Punto (Mk2/2b) 13 03-05-2010 23:00
(T) camshaft position sensor sporting_adz Punto (Mk2/2b) 13 10-11-2009 21:57
(T) Camshaft Position Sensor ? SwissTony Stilo 13 07-07-2007 21:26