Register Login
Save up to 15% with Adrian Flux insurance!
Reply
 
Thread Tools
Old 19-02-2012   #1
Join Date: Jan 2012
Posts: 7
Thanks: 0
Trader Rating: 0
United Kingdom 
Poor acceleration at low revs

Hi, I have a frustrating problem with my 2006, 1.3 mjt Dobbie. If I change up a gear and the revs are not high enough in the new gear, she tends to bog down as if being stiffled and I have to wait a quite a while for her to catch up, or, change back down and get the revs quite high before changing up again. Its as if there is a power band, or terrible turbo lag.
Any ideas please.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

onlymee is offline Reply With Quote Quote 
Old 20-02-2012   #2
Join Date: May 2009
Location: Southampton, England
Posts: 455
Thanks: 17
Trader Rating: 0
United Kingdom 
Re: Poor acceleration at low revs

Without knowing what revs its doing before and after you change I dont think anyone could answer this. You probably want to ask at what revs the turbo comes in on other 1.3's. But generally most turbos need about 1,700 rpm to do any boosting so if when you change its doing less than that it will struggle a bit.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by johnhififan; 20-02-2012 at 17:14.
johnhififan is offline Reply With Quote Quote 
Old 21-02-2012   #3
Join Date: Jan 2012
Posts: 7
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Poor acceleration at low revs

Thanks johnhififan, yes I should have said, when I change up, if the new gear is less than 2000 revs it struggles, it seems to hesitate before it accelerates, if its 1500 or less, its impossible, it just boggs down, it dosn't matter how much I push the accelerator, it very rarely recovers and I have to change down again.
Please help.
Thanks.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

onlymee is offline Reply With Quote Quote 
Old 22-02-2012   #4
Now a SAAB owner
Join Date: Nov 2006
Posts: 407
Thanks: 10
Trader Rating: 0
TwyRob has donated!
Infinite Tower RPG Champion
United Kingdom 
Re: Poor acceleration at low revs

It could be an egr issue. There are cleaning instructions on the Stilo thread that others have used with success.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

TwyRob is offline Reply With Quote Quote 
Old 22-02-2012   #5
Join Date: Jan 2012
Posts: 7
Thanks: 0
Trader Rating: 0
United Kingdom 
Thumbs up Re: Poor acceleration at low revs

Thanks Robin, I will look in to that. .
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

onlymee is offline Reply With Quote Quote 
Old 24-02-2012   #6
Forum Moderator
 
T14086's Avatar
Join Date: Sep 2004
Location: Preston
Posts: 29,985
Thanks: 1064
Trader Rating: 0
T14086 has donated!
United Kingdom 
Re: Poor acceleration at low revs

did you get this sorted?
__________________
http://www.chryslerforum.co.uk//
T14086 is offline Reply With Quote Quote 
Old 25-02-2012   #7
Join Date: Jan 2012
Posts: 7
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Poor acceleration at low revs

Have not sorted yet, not had a lot of time. I had a quick look for EGR, but could not find it. I read on here somewhere that they are difficult to get to on a 1.3 MJT.

Can any one tell me where the valve is on this vehicle please.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

onlymee is offline Reply With Quote Quote 
Old 25-02-2012   #8
Forum Moderator
 
T14086's Avatar
Join Date: Sep 2004
Location: Preston
Posts: 29,985
Thanks: 1064
Trader Rating: 0
T14086 has donated!
United Kingdom 
Re: Poor acceleration at low revs

Not the easiest to get to but more room than the panda version!

It's at back right of engine.
__________________
http://www.chryslerforum.co.uk//
T14086 is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) A story on low power at low revs, smoke, stalling, low mpg / EGR MJET sporting steedy87 Grande Punto 7 15-04-2009 15:10
(T) Chugging in the low revs during acceleration Wallman Bravo / Brava 3 06-12-2008 10:32
(T) Multipla Jtd 110 High fuel consumption/ poor torque low revs windermere21 Multipla 3 26-06-2008 19:16
(T) 1.1 engine low power in low revs amitoha23 Cinquecento / Seicento 19 14-10-2007 19:15