Register Login
im Axle Specialists
Reply
 
Thread Tools Search this Thread
Old 16-04-2011   #1
Join Date: Apr 2011
Posts: 1
Thanks: 0
Trader Rating: 0
United Kingdom 
My power steering only works at high revs

Doblo 1.9 55 Plate

Hi there, When i am going really slow the power steering does not work at all, if i rev then engine higher or am travelling faster it works fine. It has lots of fluid in, and the belt is not sqeeking at all, Would it need a new pump? or could it be something else. Has anyone else had this problem?

Thanks for your time.

M
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by Jempop; 16-04-2011 at 08:12.
Jempop is offline Reply With Quote Quote 
Old 02-12-2011   #2
Join Date: Sep 2009
Location: mossley
Posts: 7
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: My power steering only works at high revs

having the
same problem with mine doblo 1.9 55 plate too

any one got any clue thanks in advance
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

superlegion is offline Reply With Quote Quote 
Old 02-12-2011   #3
Join Date: Apr 2010
Posts: 59
Thanks: 2
Trader Rating: 0
United Kingdom 
Re: My power steering only works at high revs

I'd do a quick search on here, it can be a number of things including a failed pully or a failing pump. But that said, if there can be a number of causes a garage is the only way of narrowing it down to one.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

duplo is offline Reply With Quote Quote 
Old 02-12-2011   #4
Now a SAAB owner
Join Date: Nov 2006
Posts: 407
Thanks: 10
Trader Rating: 0
TwyRob has donated!
Infinite Tower RPG Champion
United Kingdom 
Re: My power steering only works at high revs

I've had this on my last doblo in a cold snap. I bought a power steering fluid additive that seals small leaks and topped up the fluid. Might work for you.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

TwyRob is offline Reply With Quote Quote 
Old 05-12-2011   #5
Join Date: Sep 2009
Location: mossley
Posts: 7
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: My power steering only works at high revs

Quote Originally Posted by Robin_Whitby View Post
I've had this on my last doblo in a cold snap. I bought a power steering fluid additive that seals small leaks and topped up the fluid. Might work for you.
what did you use as mine went when icy
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

superlegion is offline Reply With Quote Quote 
Old 06-12-2011   #6
Now a SAAB owner
Join Date: Nov 2006
Posts: 407
Thanks: 10
Trader Rating: 0
TwyRob has donated!
Infinite Tower RPG Champion
United Kingdom 
Re: My power steering only works at high revs

got the additive from halfords. Can't remember what it was called, easy to find on the shelf though. It only does leaks, mine went clunk when I first turned the wheel that afternoon. Sound similar? The additive does nothing to freezing temp btw
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

TwyRob is offline Reply With Quote Quote 
Old 06-12-2011   #7
Join Date: Jan 2010
Location: Ireland
Posts: 49
Thanks: 1
Trader Rating: 0
Ireland 
Re: My power steering only works at high revs

Check for powersteering fluid in the gaiters at either end of the rack.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Davidireland is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Loosing power (misfire?) at high revs... Dodgy Geezer Punto (Mk2/2b) 26 25-01-2011 13:38
Lack of power at high revs buzzbee Newbie Central 1 27-01-2009 00:00
(G) HGT Power loss high revs rema-d Bravo / Brava 15 09-06-2008 09:55
(T) High revs but no power??? sptaylor75 Panda 6 26-02-2008 15:35
(T) high revs no power clare Punto (Mk2/2b) 18 09-12-2005 18:55