Register Login
FIAT Auto Specialist Team
Reply
 
Thread Tools
Old 4 Weeks Ago   #1
Join Date: Nov 2018
Posts: 2
Thanks: 0
Trader Rating: 0
Lithuania 
Fiat Croma doesn't start

Hi guys,

I have Fiat Croma '06 with 1.9 110kW Multijet engine with DPF. Everything was OK since recently time when the car started not to start from the first time. Sometimes it takes several cranking cycles to start, then engine running rough at low RPMs and after that everyhing's fine again. Sometimes it starts well. But recently depending on the phase of the moon the car started not to start at all. It has to be pushed from outside and then quickly turns on and runs smoothly. After starting the car, frequently I get some special smell smoke from that flexible joint coming from the engine collector. By the way, when it's really cold outside metal knocking noise was heard from the bottom of the engine (??) - but quite rarely. Sometimes it shows DPF filter clogged but don't know whether the car starts regeneration itself.

Maybe any ideas or suggestions to start looking for the problem from? Thanks in advance!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by XgN; 4 Weeks Ago at 22:00.
XgN is offline Reply With Quote Quote 
Old 4 Weeks Ago   #2
Join Date: Dec 2006
Location: Southampton, Hampshire
Posts: 3,492
Thanks: 249
Trader Rating: 0
s130 has donated!
United Kingdom 
Re: Fiat Croma doesn't start

Ignoring the metal knocking noise then the rest of your problems are mostly likely due to a clogged DPF filter.

Under normal circumstances then the car's engine management system will initiate a regeneration/cleaning when required AND ONLY when the engine conditions are correct.

Two items that determine correct conditions are:

1) Engine warm and up to temperature. If the car is used for short runs thi may never happen, or if the regen cycle is started during a short run then it is terminated before completion when you stop.

2) Engine oil quality. For engines with DPF filters then when the oil is changed then not only must the normal service interval be reset BUT ALSO THERE IS A SEPARATE OIL CHANGE reset that has to be done. Many garages are not aware of this and as a result the engine ECU thinks the oil is old and worn out so the ECU WILL NOT initiate a DPF regeneration cycle so as to protect then engine from damage. The DPF regen cycle is very stressful for the engine in terms of temperatures required.

You need to initially check when the last oil change was done and see if whoever did it was aware of the separate required oil reset AND they actually did it? If they are at all competent then it will take them only a few minutes to plug in and check.

On the Croma ECU there are a whole set of parameters that can be read (with MultiECUScan or similar quality diagnostic kit) which will tell you everything with regards to oil changes and DPF status. Here are some of them:

- Particulate Filter Status (Broken, Not Clogged, Normal clogging, clogged .... etc)
- Distance from last DPF regen
- Oil change counter
- Oil change degradation
- Odometer at last oil change
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

s130 is offline Reply With Quote Quote 
Old 1 Week Ago   #3
Join Date: Nov 2018
Posts: 2
Thanks: 0
Trader Rating: 0
Lithuania 
Re: Fiat Croma doesn't start

Quote Originally Posted by s130 View Post
Ignoring the metal knocking noise then the rest of your problems are mostly likely due to a clogged DPF filter.

Under normal circumstances then the car's engine management system will initiate a regeneration/cleaning when required AND ONLY when the engine conditions are correct.

Two items that determine correct conditions are:

1) Engine warm and up to temperature. If the car is used for short runs thi may never happen, or if the regen cycle is started during a short run then it is terminated before completion when you stop.

2) Engine oil quality. For engines with DPF filters then when the oil is changed then not only must the normal service interval be reset BUT ALSO THERE IS A SEPARATE OIL CHANGE reset that has to be done. Many garages are not aware of this and as a result the engine ECU thinks the oil is old and worn out so the ECU WILL NOT initiate a DPF regeneration cycle so as to protect then engine from damage. The DPF regen cycle is very stressful for the engine in terms of temperatures required.

You need to initially check when the last oil change was done and see if whoever did it was aware of the separate required oil reset AND they actually did it? If they are at all competent then it will take them only a few minutes to plug in and check.

On the Croma ECU there are a whole set of parameters that can be read (with MultiECUScan or similar quality diagnostic kit) which will tell you everything with regards to oil changes and DPF status. Here are some of them:

- Particulate Filter Status (Broken, Not Clogged, Normal clogging, clogged .... etc)
- Distance from last DPF regen
- Oil change counter
- Oil change degradation
- Odometer at last oil change
Thanks for informative reply.

I changed the oil myself about two months ago. Used special Castrol 5W-40 fully synthetic suitable for DPFs. Good point about oil service counter - haven't thought about it.. Last week the oil replacement warning lamp started to flash like for a coincidence. So I took my Delphi OBD system and reset it today.

Also checked Particulate filter clogging status parameter and it showed 68%. Distance since last regeneration: 200 km. Met all neccessary conditions and started regeneration manually. It was successful with high RPMs, a lot of smoke from the front passenger side (not the exhaust pipe!!!) but clogging status atfer is 70%... Why haven't regeneration worked properly..?

Got the battery checked, it was original one from 2006 till now.. There was only 220A of CCA left.. Inserted Varta Silver 85 Ah@800A. Going to monitor the car now. By the way, even with this new battery I noticed small all lights (headlights, interior lights) flickering (dimming) when starting and fast stopping the car (braking). What could cause the problem..? Battery contacts are good, refreshed with sand-paper and tighted well.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by XgN; 1 Week Ago at 22:44.
XgN is offline Reply With Quote Quote 
Old 1 Week Ago   #4
Moderator
 
g8rpi's Avatar
Join Date: Nov 2013
Location: Cambridge
Posts: 3,653
Thanks: 367
Trader Rating: 0
g8rpi has donated!
United Kingdom 
Re: Fiat Croma doesn't start

Hi,
The DPF clogging status could be the sensor or morelikey a leak in the flexible pipes to the sensor. Look at the indicated differential pressure and see how much it changes engine off / idle and 3000 rpm.

Flickering lights under braking could be a short circuit somewhere with the contact coming under g-force. Would have to be a high currnet connection like starter, alrternator or body computer fusebox feed. Might be a bad connection, check in fuse boxes on bater terminal and boy computer. could be a difficult one to find. ideally you would need a current clamp and recording oscilloscope on various leads.

Robert G8RPI.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

g8rpi is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) Fiat doblo doesn't start Marco Escobar Doblo 6 24-08-2017 16:54
(T) Sometimes it doesn't start... Help!!! Jacko310789 Punto (Mk2/2b) 7 07-10-2013 22:29
(G) Fiat 600 50th anniversary doesn't start.. baccinelli Cinquecento / Seicento 5 21-01-2010 00:01
(T) Seicento doesn't start looszgabor Cinquecento / Seicento 8 09-07-2006 13:48
(T) Help! 1995 M doesn't start! Martina Punto (Mk1) 18 16-11-2004 00:07