Register Login
endrop - for all your online needs
Reply
 
Thread Tools Search this Thread
Old 15-05-2011   #1
Join Date: Jul 2010
Posts: 107
Thanks: 0
Trader Rating: 0
United Kingdom 
Intercooler Hose

Here is a strange thing.

Has anyone had an intercooler hose blow off its housing.

I have it happen twice on my diesel Croma 1.9 8v this week. The first time I called the RAC out as it was virtually impossible to drive and I had no idea what the problem was. The RAC mechanic found the hose just hanging off its housing so he reconnected it using the same jubilee clip and everything seemed ok. The following morning going to work after about only 4 miles after the RAC man carried out the repair it happened again. Just managed to get to work, lifted the bonnet and sure enough the hose was off again. I fixed it back making sure the jubillee clip was holding tight and everything seems to be ok now with the exception that the car does not seem quite right in that I feel that should I accelerate with any aggression the hose will fly off again.

Anyone experienced this or have any ideas what could be happening.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Daveof49 is offline Reply With Quote Quote 
Old 16-05-2011   #2
the notorious one
 
notorious's Avatar
Join Date: Oct 2009
Location: Belgrade
Posts: 203
Thanks: 17
Trader Rating: 0
notorious has donated!
Serbia 
Re: Intercooler Hose

no, not heard of that, but these hoses tend to be full of oil so cleaning off slippery oil is a must, followed by replacing the jubilee clip with a new one. Do these two things as they are easy and try the car out, maybe it all that's needed and report back.
__________________
Serbia is not suburbia.
notorious is offline Reply With Quote Quote 
Old 16-05-2011   #3
Join Date: Jul 2010
Posts: 107
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Intercooler Hose

Thanks for your response Notorious.

So far so good. The hose is still on but there is a definite 'misfire' when under hard acceleration. Thought it could be a sticking EGR valve as these seems to be quite troublesome. I have access to Fiat Ecuscan and connected it with the Engine speed and EGR graphs running. At 850-880 rpm the valve runs at around 35-38% but drops dramatically to 4% then shoots back to 35-38%. Sometimes it stays at 4% until the accelerator is pressed.

Would you, or anyone else, know if this is the norm or do I need to strip and clean the valve?

Ecu scan has no other faults logged.

Does anyone know where you can get information on the normal operating parameters to compare with the data Fiat ECU-Scan gives?

I use a VAG-Com KKL lead to connect to the ECU.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Daveof49 is offline Reply With Quote Quote 
Old 16-05-2011   #4
the notorious one
 
notorious's Avatar
Join Date: Oct 2009
Location: Belgrade
Posts: 203
Thanks: 17
Trader Rating: 0
notorious has donated!
Serbia 
Re: Intercooler Hose

4% @ idle is normal, can't comment on the rest but sounds fine, you can clean it anyways if it's never been done it can't hurt only help. EGR doesn't really cause misfire, misfire can be fuel or air alteration of some kind. When were fuel and air filters changed last?
__________________
Serbia is not suburbia.
notorious is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Intercooler Hose Split (sounds like a hoover) bozzy Stilo 65 04-02-2013 16:16
(T) JTD Intercooler Hose wayne.barry83 Stilo 18 30-05-2012 19:49
(T) Intercooler hose wayne.barry83 Stilo 1 29-11-2010 16:09
(T) 1.9 and 1.3 intercooler hose size? Glenny22 Grande Punto 2 02-03-2010 15:04
(T) intercooler hose route p4k69 Punto (Mk2/2b) 2 01-05-2008 18:47