Register Login
endrop - for all your online needs
Reply
 
Thread Tools
Old 18-05-2019   #1
Join Date: Aug 2011
Posts: 47
Thanks: 0
Trader Rating: 0
United Kingdom 
Fiat Coupe 20vt wont start

Hi my 20vt wont start it did last week after 8 years off the road . The injector light keeps flashing when turning over also the oil light on the pressure gauge is on the whole time even with the keys out . I have the free version of ECU multiscan but it wont connect . Do i have to buy the 50 euro version to connect to my car
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

abarth130tc is offline Reply With Quote Quote 
Old 18-05-2019   #2
Join Date: Aug 2007
Location: Sevenoaks Kent
Posts: 996
Thanks: 22
Trader Rating: 0
CFREITAS has donated!
United Kingdom 
Re: Fiat Coupe 20vt wont start

Quote Originally Posted by abarth130tc View Post
Hi my 20vt wont start it did last week after 8 years off the road . The injector light keeps flashing when turning over also the oil light on the pressure gauge is on the whole time even with the keys out . I have the free version of ECU multiscan but it wont connect . Do i have to buy the 50 euro version to connect to my car
My free version wouldnt connect either i had to buy the full version ......
I know its sounds obvious but have you checked all the earth points ....make sure the battery is healthy
Look for any breaks in wires .....
Injector light would usually mean and electrical fault......
Likes varesecrazy liked this post
__________________

Fiat Bravo HGT 20v
Fiat Bravo HGTT 20vt
Fiat Bravo Trofeo
Fiat Marea HLX 20v
CFREITAS is offline Reply With Quote Quote 
Old 18-05-2019   #3
Join Date: Apr 2011
Location: Near the M4
Posts: 20,153
Thanks: 720
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Quote Originally Posted by abarth130tc View Post
Hi my 20vt wont start it did last week after 8 years off the road . The injector light keeps flashing when turning over also the oil light on the pressure gauge is on the whole time even with the keys out . I have the free version of ECU multiscan but it wont connect . Do i have to buy the 50 euro version to connect to my car
Where are you based?

Might be able to get access to z full version.

Worth checking connections anyway..

Whilst battery is disconnected fot a charge

Immob working properly?

Charlie
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Old 18-05-2019   #4
Join Date: Aug 2011
Posts: 47
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Fiat Coupe 20vt wont start

Based in Ilford east london . The car had not been started in 8 years so when it was delivered last week i put a battery in it and it stated after 10 seconds . Tried again and it was turning over but no spark . The oil light is a back earth i think . I also bypassed the laserline alarm and no joy .I have paid for the basic ecu multiscan back in 2012 and got in touch with them to see if i could get a replacementand they said yes . The only problem is my laptop has windows 7 which i bought off ebay and its counterfit i am told The code light goes out and i have the three keys
Likes varesecrazy liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by abarth130tc; 18-05-2019 at 17:13.
abarth130tc is offline Reply With Quote Quote 
Old 25-05-2019   #5
Join Date: Aug 2011
Posts: 47
Thanks: 0
Trader Rating: 0
United Kingdom 
Thumbs down Re: Fiat Coupe 20vt wont start

It was the cam sensor code 08 I got my lincense for multiecuscan as i bought it back in 2012 Did the job
Likes varesecrazy liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

abarth130tc is offline Reply With Quote Quote 
Old 03-06-2019   #6
Join Date: Jan 2011
Location: Going North on the A9...
Posts: 299
Thanks: 12
Trader Rating: 0
United Kingdom 
Re: Fiat Coupe 20vt wont start

sorry 130- I could have told you that if I'd seen your thread a week ago;

only two things will cause the engine not to fire;

The fuel pump (or inertia switch)

or the cam sensor.

Incidentally; the low oil-pressure light permanently lit; is indicative of diode-pack failure on the rear of the alternator.
Likes varesecrazy liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

dante giacosa is offline Reply With Quote Quote 
Old 19-08-2019   #7
Join Date: Aug 2011
Posts: 47
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Fiat Coupe 20vt wont start

UPDATE .Although when i plugged the car into ECU multiscan it came up with the cam phase sensor code 08 . But the timing belt had slipped three teeth so it put the phase sensor and the crank sensor out of alignment .This will trigger the 08 code I reset the OLD timing belt and it started straight away . I then changed the water pump,timing belt kit and the phase sensor and its fine Did a compression test All above 150psi Very lucky . So if your car has been laid up for a long period be carefull . The old timing belt tensioner had gotten a bit stiff and under loaded the belt when i went to start it
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

abarth130tc is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) 96 Coupe that wont start kiwi tony Coupe 5 25-05-2018 13:24
(T) Coupe wont start Jamie Marquiss Coupe 13 02-09-2010 23:42