Register Login
FIAT Auto Specialist Team
Reply
 
Thread Tools
Old 30-01-2007   #1
Join Date: Mar 2005
Location: Leicester
Posts: 2,199
Thanks: 29
Trader Rating: 3
gazzaman2k has donated!
United Kingdom 
Question MOT failed :( High Edmissions :( Help needed

took the turbo for a MOT today after finding my MOT certificate yesterday whilst cleaning my room and it ran out today.

failed on 5 things but 4 are easily sorted

my main one that buggin me is that it failed the Edmissions test

guy at garage says it could be the lamba sensor.

im not sure if its the CAT or the lamba?

anyone able to figure this out pic of the test sheet below:
Attached Thumbnails
Click image for larger version

Name:	Camera0001.jpg
Views:	50
Size:	204.0 KB
ID:	23515  
__________________
Project Seicento
gazzaman2k is offline Reply With Quote Quote 
Old 30-01-2007   #2
RIP L181 VBB
 
AppleSei's Avatar
Join Date: Feb 2005
Location: West Yorks
Posts: 11,518
Thanks: 195
Trader Rating: 4
AppleSei has donated!
Cricket Craziness Champion
United Kingdom 
Re: MOT failed :( High Edmissions :( Help needed

It says on that attachment that the lambda passed on both runs?
__________________
2001 Modded Sei Sporting - GONE!!
MY ACCIDENT THREAD - BE CAREFUL OUT THERE! - http://www.fiatforum.com/leisure-lou...cky-alive.html
AppleSei is offline Reply With Quote Quote 
Old 30-01-2007   #3
Join Date: Mar 2005
Location: Leicester
Posts: 2,199
Thanks: 29
Trader Rating: 3
gazzaman2k has donated!
United Kingdom 
Re: MOT failed :( High Edmissions :( Help needed

oxygen sensor is that not the lamba? isnt the lamba test for the closed loop thing?
__________________
Project Seicento
gazzaman2k is offline Reply With Quote Quote 
Old 30-01-2007   #4
RIP L181 VBB
 
AppleSei's Avatar
Join Date: Feb 2005
Location: West Yorks
Posts: 11,518
Thanks: 195
Trader Rating: 4
AppleSei has donated!
Cricket Craziness Champion
United Kingdom 
Re: MOT failed :( High Edmissions :( Help needed

Actually IIRC when i had a diagnostic done it was the oxygen sensor at fault on mine as well, and the lambda sensor was messed with so you may be right.

Back to the ford forum i go .....
__________________
2001 Modded Sei Sporting - GONE!!
MY ACCIDENT THREAD - BE CAREFUL OUT THERE! - http://www.fiatforum.com/leisure-lou...cky-alive.html
AppleSei is offline Reply With Quote Quote 
Old 30-01-2007   #5
Join Date: Aug 2006
Location: SE
Posts: 781
Thanks: 43
Trader Rating: 0
Renegade_8 has donated!
United Kingdom 
Re: MOT failed :( High Edmissions :( Help needed

Too much CO and hydrocarbons, air filter OK?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Renegade_8 is offline Reply With Quote Quote 
Old 30-01-2007   #6
Join Date: Mar 2005
Location: Leicester
Posts: 2,199
Thanks: 29
Trader Rating: 3
gazzaman2k has donated!
United Kingdom 
Re: MOT failed :( High Edmissions :( Help needed

air filters should be ok lol its a brand new piperX for a uno turbo only been on the car for 2 months
__________________
Project Seicento
gazzaman2k is offline Reply With Quote Quote 
Old 30-01-2007   #7
Join Date: Mar 2006
Location: Liverpool
Posts: 27,676
Thanks: 1227
Blog Entries: 3
Trader Rating: 5
fingers99 has donated!
United Kingdom 
Re: MOT failed :( High Edmissions :( Help needed

How old are the plugs?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

fingers99 is offline Reply With Quote Quote 
Old 30-01-2007   #8
Scandinavian Passion....
 
StoneNewt's Avatar
Join Date: Jun 2006
Location: Cambridgeshire
Posts: 2,088
Thanks: 47
Trader Rating: 0
StoneNewt has donated!
United Kingdom 
Re: MOT failed :( High Edmissions :( Help needed

I read the fails two CO emissions (0.53, under 0.3 req) for both Fast idle tests
__________________

Seicento Sporting, 1.1 8v N/A, Dark grey
Seicento Sporting, 1.2 8v turbo, Yellow
Volvo V70 D5 Sport, 2.4 20v twin-turbo, Black
StoneNewt is offline Reply With Quote Quote 
Old 30-01-2007   #9
Join Date: Oct 2004
Location: Towcester, Northants
Posts: 4,299
Thanks: 151
Trader Rating: 0
J333EVO has donated!
United Kingdom 
Re: MOT failed :( High Edmissions :( Help needed

Quote Originally Posted by StoneNewt View Post
I read the fails two CO emissions (0.53, under 0.3 req) for both Fast idle tests
Quote Originally Posted by StoneNewt View Post
I read the fails two CO emissions (0.53, under 0.3 req) for both Fast idle tests
Thats oil minimum temp for the test

With CO being to high, means rich, so points to lambda to me.

On my good old grale i'm allowed CO upto 3.5 but of course as my car has already been built its still greener than a new one now as the carbon footprint it makes is bigger than mine as its already been made, so I say stop buying new cars and keep old ones on the road as overall the carbon footprint they will leave is smaller

But does seem pretty hi to me, IIRC blue's MOT pass was CO 0.1 HC 25ppm lambda 1.00.
__________________

Cinquecento Abarth 1.4 16V 6speed track toy
Lancia integrale EVO1 Homologation model
MINI Clubman Hampton Edition Cooper SD
VW MK5 Golf R32
J333EVO is offline Reply With Quote Quote 
Old 30-01-2007   #10
Scandinavian Passion....
 
StoneNewt's Avatar
Join Date: Jun 2006
Location: Cambridgeshire
Posts: 2,088
Thanks: 47
Trader Rating: 0
StoneNewt has donated!
United Kingdom 
Re: MOT failed :( High Edmissions :( Help needed

Quote Originally Posted by J333EVO View Post
Thats oil minimum temp for the test
Yeah I know was just checking the figures for the post then put it in
__________________

Seicento Sporting, 1.1 8v N/A, Dark grey
Seicento Sporting, 1.2 8v turbo, Yellow
Volvo V70 D5 Sport, 2.4 20v twin-turbo, Black
StoneNewt is offline Reply With Quote Quote 
Old 30-01-2007   #11
Join Date: Mar 2005
Location: Leicester
Posts: 2,199
Thanks: 29
Trader Rating: 3
gazzaman2k has donated!
United Kingdom 
Re: MOT failed :( High Edmissions :( Help needed

plugs, filter, oil, everything is new on the car except the lamba :\ hmmm i think ill buy one of them.

anyone know where to buy one from?
__________________
Project Seicento
gazzaman2k is offline Reply With Quote Quote 
Old 30-01-2007   #12
WHY DO I LOVE THEM SO?
 
ryan_dobson's Avatar
Join Date: Oct 2006
Location: Plymouth
Posts: 142
Thanks: 0
Trader Rating: 0
ryan_dobson has donated!
United Kingdom 
Re: MOT failed :( High Edmissions :( Help needed

Go to www.shop4parts.co.uk

They do them at a fairly reasonable price and their delivery service is very good. I've used them for a couple of bits recently.
__________________

Fix it now and You WILL fix it again

Checkout the Progess Here
http://www.fiatforum.com/gallery/sho...&sl=r:worship:
ryan_dobson is offline Reply With Quote Quote 
Old 31-01-2007   #13
Join Date: Oct 2006
Location: Glasgow
Posts: 8,120
Thanks: 308
Trader Rating: 3
ycming has donated!
United Kingdom 
Re: MOT failed :( High Edmissions :( Help needed

i had the exact same problem when i put my cinq through , and by looking at your sheet, it looks identical .

What i did was, brought some ait intake cleaner , give it a clean, then a new lambda sensor, also an oil change b4 the retest.

For lambda sensor wise ... just check how many wires your car have, is usually 4, then just get one on e-bay for around 20.

If u don't want a new one u can try this:

Take ur lambda sensor out, get some paint thinner, and put the head of the lambda sensor in the paint thinner and leave it over night, then next day take it out wait till it drys put it in again. This should work.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

ycming is offline Reply With Quote Quote 
Old 03-02-2007   #14
Join Date: Jan 2007
Location: bradford,west yorkshire
Posts: 21
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: MOT failed :( High Edmissions :( Help needed

mine did the same as yours,removed my rage back box,fit new exhaust from centre to rear changed lambda sensor,did everything i could think off went on for 3 weeks back and forth to garage plenty spent on re-tests took to different garage for a full test guess what a hair line crack in cat converter , any way i blagged it through and replaced it when funds were healthier
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

BROCST@r is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) Failed MOT Cinq_Sport_BiG_DaVE Cinquecento / Seicento 16 09-12-2004 11:23
(T) Failed MOT cscotson Bravo / Brava 3 29-11-2004 22:59
(T) MOT Retest Results........FAILED! mdsremos Cinquecento / Seicento 15 25-06-2004 23:10
MOT time help needed! jonnyyeah Lets Talk FIAT 15 22-03-2004 03:47
MOT FAILED whitewabbit2001 Lets Talk FIAT 15 17-03-2004 06:37