Register Login
The UK's No.1 Chrysler Owners Forum
Reply
 
Thread Tools Search this Thread
Old 13-01-2020   #1
Join Date: Jan 2014
Posts: 60
Thanks: 0
Trader Rating: 0
United Kingdom 
Screen washer Pump

My Seicento (899cc - 2001) screen washer pump has stopped working. I got to it and made sure that it wasn't blocked up with sludge, and cleaned the contacts with wire wool, but it still won't work. The wiring looks okay.

Can anyone tell me how to get it out? Is it just a matter of wiggling it out of the reservoir or is is fixed on somewhere at the back (see image)?

I was going to test it using a 12v battery.
Thanks,
Andrew
Attached Thumbnails
Click image for larger version

Name:	Washer pump.JPG
Views:	7
Size:	196.7 KB
ID:	205683  
Likes varesecrazy liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

CasLad is offline Reply With Quote Quote 
Old 13-01-2020   #2
No strings on me
 
Eklipze3k's Avatar
Join Date: Nov 2007
Location: Huddersfield
Posts: 15,200
Thanks: 683
Trader Rating: 0
Eklipze3k has donated!
United Kingdom 
Re: Screen washer Pump

It's just held in place with the rubber grommet IIRC
Likes varesecrazy liked this post
__________________
Eklipze3k is offline Reply With Quote Quote 
Old 13-01-2020   #3
Join Date: Dec 2003
Location: The land that time forgot
Posts: 3,244
Thanks: 249
Trader Rating: 0
United Kingdom 
Re: Screen washer Pump

Yes.. push-fit into the rubber grommet.

Do you have two pumps (one for the rear) or just the one (which would do the front and rear)? If you have two pumps you can swap the wiring to check whether pulling the lever makes the rear washer work (since the leccy is operating on the other pump now).

That will eliminate a wiring or other issue and prove it's the pump that's the problem.

If you have just one pump, plug a voltmeter (or a bulb, if you have some electrical wire and a bulb holder handy) into the connectors and see that it lights up/12v when you pull the lever... that will prove the connector has juice at it (so would prove the pump must be faulty).


Ralf S.
Likes varesecrazy liked this post
__________________
No bullets for chaingun
Ralf S. is offline Reply With Quote Quote 
Old 13-01-2020   #4
Join Date: Apr 2011
Location: Near the M4
Posts: 25,670
Thanks: 969
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Re: Screen washer Pump

Check the GUIDES.. I did a basic how to..on a focus
Likes Ralf S. liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Old 14-01-2020   #5
Join Date: Jan 2014
Posts: 60
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Screen washer Pump

Thank you.
I didn't want to force it out in case it was affixed at the back. But, I got it out.
12v is going from the battery circuit to the unit. The unit is badly corroded, showing ohmic resistance, but not operating. I'll be ordering a new part today.
Cheers
Likes Ralf S. liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

CasLad is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) 1.9 jtd ugly bug screen washer pump and relay unclepops Multipla 3 21-05-2015 06:41
(T) Screen Washer Pump richardllew Panda 6 01-03-2015 11:25
Astra screen washer pump pooroldcodger Non-FIAT 9 28-03-2013 18:25
Problems with front screen washer pump Alexey FIAT Boo Archives 2 06-09-2011 08:40
(T) Punto Mk1 screen washer pump KeithT Punto (Mk1) 1 05-07-2006 20:20