Register Login
Shop4Parts - UK's largest online superstore for FIAT and Alfa Romeo parts
Reply
 
Thread Tools
Old 23-12-2018   #16
Join Date: Oct 2015
Posts: 38
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Rough Running

Quote Originally Posted by dac69er View Post
What fuel pressure do you have when the car is running? Have you changed the fuel filter in the line, not just the fuel pick up on the pump.
What voltage do you have at the pump when it is running?
I disconnected the fuel line at the rail and turned over the car for 30 seconds and there was 750cc of fuel.


I have traced the fuel line from tank to rail and there is no inline filter, I have posed the question and been told there is no inline filter. I have been told they stopped fitting them in 98.

https://www.fiatforum.com/cinquecent...nto-1-1-a.html


12v
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

nrw1950 is offline Reply With Quote Quote 
Old 24-12-2018   #17
Join Date: Nov 2014
Location: suffolk
Posts: 625
Thanks: 22
Trader Rating: 0
United Kingdom 
Re: Rough Running

Quote Originally Posted by nrw1950 View Post
I disconnected the fuel line at the rail and turned over the car for 30 seconds and there was 750cc of fuel.
that does not test fuel pressure. you need a gauge.


if you have only 12v, that may be an issue. when running the electrical system should be sitting closer to 14v.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by dac69er; 24-12-2018 at 10:28.
dac69er is offline Reply With Quote Quote 
Old 24-12-2018   #18
Join Date: Feb 2012
Posts: 74
Thanks: 10
Trader Rating: 0
South Africa 
Re: Rough Running

Agreed...cant guess fuel pressure. In my experience the pump filter has to be absolutely clean. Can be cleaned using good carb cleaner blown through from the outlet end. Injector spray pattern is all important not just quantity of fuel. Needs to be atomized properly. 12 volts sounds low but remember voltage can drop down a lot during cranking and engine must fire and run correctly with this demanding condition. In my experience fuel flow issues are worse when the engine is hot and not when cold which seems counterintuitive as fuel demand is higher when cold. But when hot the engine should be in a closed loop managed largely by the lambda sensors which are not used when cold..
Thanks varesecrazy thanked for this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Frosty1961 is offline Reply With Quote Quote 
Old 24-12-2018   #19
Join Date: Apr 2011
Location: Near the M4
Posts: 19,172
Thanks: 688
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Re: Rough Running

Ok.. reading between the lines here:

Car starts.. fires.. ok.. but runs ROUGH

Can be coaxed to build revs.. but struggles.

Sounding like timing..
Or incorrect temp readings adversely effecting fuelling.

Have you checked what temps the ECU Is seeing?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Old 24-12-2018   #20
Join Date: Oct 2015
Posts: 38
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Rough Running

Quote Originally Posted by Frosty1961 View Post
Agreed...cant guess fuel pressure. In my experience the pump filter has to be absolutely clean. Can be cleaned using good carb cleaner blown through from the outlet end. Injector spray pattern is all important not just quantity of fuel. Needs to be atomized properly. 12 volts sounds low but remember voltage can drop down a lot during cranking and engine must fire and run correctly with this demanding condition. In my experience fuel flow issues are worse when the engine is hot and not when cold which seems counterintuitive as fuel demand is higher when cold. But when hot the engine should be in a closed loop managed largely by the lambda sensors which are not used when cold..
I removed the pump and cleaned the filter with carb cleaner.

The engine ticks over on idle without using the accelerator

If I floor the accelerator it stalls but if I give it gentle on/off touches it will pick up revs and will eventually get to high revs. While holding down the accelerator on high revs it will fade in and out.

I measured the fuel pump voltage not running

There is no EML
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

nrw1950 is offline Reply With Quote Quote 
Old 24-12-2018   #21
Join Date: Apr 2011
Location: Near the M4
Posts: 19,172
Thanks: 688
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Re: Rough Running

Have you managed to run long enough to see if HEAT makes it better - worse ?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Old 28-12-2018   #22
Join Date: Oct 2015
Posts: 38
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Rough Running

UPDATE:

Checked the EVAP valve.


Removed the blue hose and attached a vacuum gauge to the valve. It was showing no vacuum.

Checked the electrical connector with a light and it was pulsing with the engine speed

Removed the valve and checked it on a battery and it opened and I could blow through it.

Refitted the valve and still no vacuum

removed the connector and jumped the valve to the battery and got 20psi on idle

Cannot understand how I am getting power to the connector but not operating the valve.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

nrw1950 is offline Reply With Quote Quote 
Old 29-12-2018   #23
Join Date: Nov 2014
Location: suffolk
Posts: 625
Thanks: 22
Trader Rating: 0
United Kingdom 
Re: Rough Running

The evap valve does nothing. Disconnect the pipe from the inlet if you think it is causing an issue.

Have you check the fuel pressure whilst the car is running yet?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

dac69er is offline Reply With Quote Quote 
Old 29-12-2018   #24
Join Date: Oct 2015
Posts: 38
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Rough Running

Quote Originally Posted by dac69er View Post
The evap valve does nothing. Disconnect the pipe from the inlet if you think it is causing an issue.

Have you check the fuel pressure whilst the car is running yet?
I read that a faulty EVAP valve caused rough running.

The valve is not opening, so no need to disconnect it.


Waiting for a fuel pressure tester.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

nrw1950 is offline Reply With Quote Quote 
Old 29-12-2018   #25
Join Date: Nov 2014
Location: suffolk
Posts: 625
Thanks: 22
Trader Rating: 0
United Kingdom 
Re: Rough Running

If it stays open then it would cause what is essentially a vacuum leak, so it would most likely raise the idle a bit. If you disconnect it and vent the tank to atmosphere, that will eliminate that.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

dac69er is offline Reply With Quote Quote 
Old 02-01-2019   #26
Autotest Special
 
rallycinq's Avatar
Join Date: Mar 2002
Posts: 23,284
Thanks: 1140
Blog Entries: 3
Trader Rating: 1
rallycinq has donated!
British Indian Ocean Territories 
Re: Rough Running

Your evap will switch to earth, not live.

It does sound like a vacuum/air leak to me.

Incorrect mixture being corrected by the ECU.

D
__________________
rallycinq is offline Reply With Quote Quote 
Old 14-01-2019   #27
Join Date: Oct 2015
Posts: 38
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Rough Running

Quote Originally Posted by dac69er View Post

Have you check the fuel pressure whilst the car is running yet?
It looks like it is fuel pressure, Running at 18psi. Might need new pump.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

nrw1950 is offline Reply With Quote Quote 
Old 15-01-2019   #28
Join Date: Oct 2015
Posts: 38
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Rough Running

Disconnected the inlet pipe to the EVAP, made no difference. There are no codes showing. It runs worse when hot.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

nrw1950 is offline Reply With Quote Quote 
Old 11-02-2019   #29
Join Date: Oct 2015
Posts: 38
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Rough Running

UPDATE: Tested the fuel pressure and it was below 1 bar. Ordered a complete sender/pump online that said it was for my model....it wasn't - sent it back and found a 3.5 bar pump on it's own....fitted that....pressure worse....found a leak in the corrugated pipe ...fixed that.... still no pressure....took complete unit out of the car to test it.... tested it on my bench sbmersed in a container of petrol and the pressure release valve was faulty so found the complete correct sender/pump unit...fitted it, now have 3.5 bar and running perfectly. happy boy!
Likes Ralf S., rallycinq liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

nrw1950 is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Running rough peter33 Cinquecento / Seicento 12 28-09-2014 08:09
(T) Running rough ljubo700 Punto (Mk2/2b) 10 30-08-2014 10:51
(T) Newb seeks advice re 1.ie running rough. Very rough. Sef Uno 3 23-06-2013 07:50
(T) Rough running afroking Barchetta 50 02-02-2009 14:19
(T) 1.6 rough running - HELP sanja141 Stilo 53 16-11-2008 23:09