Register Login
Save up to 15% with Adrian Flux insurance!
Reply
 
Thread Tools
Old 16-08-2017   #16
Its Adventure Time!
 
blu73's Avatar
Join Date: Nov 2004
Location: Land of Ooo
Posts: 17,255
Thanks: 383
Trader Rating: 2
blu73 has donated!
Skate Boarder Champion
United Kingdom 
Re: Stuttering loss of power on acceleration

nope, not for a long time now.
Likes peter33 liked this post
__________________
Finn - Panda 100HP - thread
Oberyn - Suzuki Ignis Sport - thread
Some previous cars: Alfa 159, Bravo HGT, Cinq 16v, Sei Turbo, Punto GT, Panda Mania 1242 mpi
blu73 is offline Reply With Quote Quote 
Old 16-08-2017   #17
Lover of Mischief
 
DRSIK's Avatar
Join Date: May 2013
Location: Hemel Hempstead
Posts: 225
Thanks: 6
Trader Rating: 0
DRSIK has donated!
United Kingdom 
Re: Stuttering loss of power on acceleration

LAMDA on order
Likes peter33 liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

DRSIK is offline Reply With Quote Quote 
Old 03-03-2018   #18
Lover of Mischief
 
DRSIK's Avatar
Join Date: May 2013
Location: Hemel Hempstead
Posts: 225
Thanks: 6
Trader Rating: 0
DRSIK has donated!
United Kingdom 
Re: Stuttering loss of power on acceleration

Update - been busy with other things

Fitted new LAMDA sensor - no change

Car still gutless cold (feels like it is overfueling and firing on 3 cylinders) until it warms up then it gets smoother (still not quite 100%).

The tickover is 100% ALL the time though - even when cold.

It is only when I press the throttle it "bogs down" . As I lift off it goes back to normal briefly (then the power drops because I am no longer pressing the throttle). Sometimes if I am really gentle with the throttle I can get a smooth power delivery.

Also it is much smoother higher up the rev range.

Any ideas ??
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by DRSIK; 03-03-2018 at 07:55.
DRSIK is offline Reply With Quote Quote 
Old 07-03-2018   #19
Its Adventure Time!
 
blu73's Avatar
Join Date: Nov 2004
Location: Land of Ooo
Posts: 17,255
Thanks: 383
Trader Rating: 2
blu73 has donated!
Skate Boarder Champion
United Kingdom 
Re: Stuttering loss of power on acceleration

wow this is ongoing isnt it..

i think from memory you have changed map sensor and fuel filter.. I suggest you whip the throttle body off and give it a damn good clean, particularly the idle control valve.

After that I'd say just check the timing real quickly, i assume access is really good for this in the mischief machine... will idle fine one or 2 teeth out, under load is a different kettle of fish though.

So after that i'd be diggin into the ignition system, check all the plugs cause this could just be breaking down ceramic on one plug even. Check leads visually and then again in dark looking for blue sparks etc. Tbh if you dont find any issues i'd be inclined to change the leads anyway as they as so cheap. You can clean and regap the plugs if they appear fine.

Then I'd start thinking about replacing the actual coils.

Keep us posted buddy
__________________
Finn - Panda 100HP - thread
Oberyn - Suzuki Ignis Sport - thread
Some previous cars: Alfa 159, Bravo HGT, Cinq 16v, Sei Turbo, Punto GT, Panda Mania 1242 mpi
blu73 is offline Reply With Quote Quote 
Old 08-03-2018   #20
Lover of Mischief
 
DRSIK's Avatar
Join Date: May 2013
Location: Hemel Hempstead
Posts: 225
Thanks: 6
Trader Rating: 0
DRSIK has donated!
United Kingdom 
Re: Stuttering loss of power on acceleration

I have new fleabay coilpacks and brand new magnecor leads and the plug were changed last service.

Last week it ran brilliantly for a day ( just to wind me up) - then it went back to misbehaving
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

DRSIK is offline Reply With Quote Quote 
Old 13-03-2018   #21
Its Adventure Time!
 
blu73's Avatar
Join Date: Nov 2004
Location: Land of Ooo
Posts: 17,255
Thanks: 383
Trader Rating: 2
blu73 has donated!
Skate Boarder Champion
United Kingdom 
Re: Stuttering loss of power on acceleration

dirty idle control valve? or just throttle body in general?
__________________
Finn - Panda 100HP - thread
Oberyn - Suzuki Ignis Sport - thread
Some previous cars: Alfa 159, Bravo HGT, Cinq 16v, Sei Turbo, Punto GT, Panda Mania 1242 mpi
blu73 is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Loss of power under acceleration... Smokey22 Cinquecento / Seicento 6 11-11-2013 05:51
(G) Power loss on acceleration?... D8DEL Panda 3 23-07-2011 20:09
(T) Punto Stuttering \ Juddering \ Loss of Power Car nut Punto (Mk2/2b) 2 19-04-2009 12:22
(T) Loss of power during acceleration piggylou Punto (Mk2/2b) 19 17-09-2008 22:07
(T) stuttering and power loss Jayjj Bravo / Brava 7 02-10-2007 19:48