Register Login
The UK's No.1 Chrysler Owners Forum
Reply
 
Thread Tools
Old 04-01-2010   #1
Join Date: Jul 2009
Location: Stockton-on-Tees
Posts: 35
Thanks: 0
Trader Rating: 0
United Kingdom 
Cooling issues...

A few problems:

1. Heater works very rarely (wish is annoying as its winter)
2. Temp goes alot over 90 and occasionally up to the next dash
3. When it does get up and past the dash that's only when the fan comes on

Guessing it could be a head gasket in the worse case or i could have an airlock or water pump may have gone.

Just need to know how to find out wich is actually is, and how to do them.

Thanks.
__________________
Driving A Yellow Fiat Cinquecento Sporting.

Never Had More Fun.
booya257 is offline Reply With Quote Quote 
Old 04-01-2010   #2
Join Date: Aug 2009
Location: Telford
Posts: 2,380
Thanks: 135
Trader Rating: 3
whitz has donated!
Bomber Bob Champion
United Kingdom 
Re: Cooling issues...

there should be a bleed nipple by the heater at the back of the engine bay (central) ans one behind the drivers side right if i remember correctly, try those first

if no luck pressure test the cooling system if the head gasket s one the needle should fluctuate as some gasses are getting into the cooling system hope this is some help to you

Ash
__________________
if its cheap its generally cheap for a reason
whitz is offline Reply With Quote Quote 
Old 04-01-2010   #3
Autotest Special
 
rallycinq's Avatar
Join Date: Mar 2002
Posts: 23,469
Thanks: 1149
Blog Entries: 3
Trader Rating: 1
rallycinq has donated!
British Indian Ocean Territories 
Re: Cooling issues...

It is a coolant issue, so sort the bleeding issue and report back.

Cheers

SPD
__________________
rallycinq is offline Reply With Quote Quote 
Old 04-01-2010   #4
Join Date: Jan 2010
Posts: 10
Thanks: 0
Trader Rating: 0
Re: Cooling issues...

I had the same problem. Drained the whole system and then filled again with coolant. Works fine now
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Rosswalker is offline Reply With Quote Quote 
Old 04-01-2010   #5
Join Date: Dec 2009
Location: Liverpool
Posts: 62
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Cooling issues...

Quote Originally Posted by Rosswalker View Post
I had the same problem. Drained the whole system and then filled again with coolant. Works fine now
Add some water wetter aswell, helps a fair bit with cooling

http://www.demon-tweeks.co.uk/produc...pcode=RED80204
__________________
[SIZE=3]"If in doubt, flat out[/SIZE]" [SIZE=2]- Colin McRae MBE (1968 - 2005)[/SIZE]
James7 is offline Reply With Quote Quote 
Old 05-01-2010   #6
Join Date: Jul 2009
Location: Stockton-on-Tees
Posts: 35
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Cooling issues...

Sorted it, had not alot of water in it, so i bled the system, put some antifreeze in and works fine now.

Gonna keep an eye on my water levels and see if anything comes of it. (can't be arsed with a head gasket going)

Cheers for replies
__________________
Driving A Yellow Fiat Cinquecento Sporting.

Never Had More Fun.
booya257 is offline Reply With Quote Quote 
Old 05-01-2010   #7
Join Date: Nov 2008
Posts: 44
Thanks: 1
Trader Rating: 0
Re: Cooling issues...

more likely the rad leeking both my cinq and sei had leeks add a bottle of rad weld for the sake of 4 and see if you still loose water in a week .
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

cwc2128 is offline Reply With Quote Quote 
Old 05-01-2010   #8
Join Date: Mar 2006
Location: Liverpool
Posts: 27,676
Thanks: 1227
Blog Entries: 3
Trader Rating: 5
fingers99 has donated!
United Kingdom 
Re: Cooling issues...

Don't use rad weld. It's a dreadful bodge.
__________________
M12 fund 20
fingers99 is offline Reply With Quote Quote 
Old 05-01-2010   #9
Autotest Special
 
rallycinq's Avatar
Join Date: Mar 2002
Posts: 23,469
Thanks: 1149
Blog Entries: 3
Trader Rating: 1
rallycinq has donated!
British Indian Ocean Territories 
Re: Cooling issues...

Quote Originally Posted by booya257 View Post
Sorted it, had not alot of water in it, so i bled the system, put some antifreeze in and works fine now.

Gonna keep an eye on my water levels and see if anything comes of it. (can't be arsed with a head gasket going)

Cheers for replies
Yup, add 'checking the coolant level' to the other weekly checks you do. Should really have been there all the time.

Cheers

SPD
__________________
rallycinq is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Cooling, Ignition timing & starting issues...Uno 1372cc Barney vd Merwe Uno 5 22-06-2009 12:08
(T) 1.2 cooling system issues. symonh2000 Bravo / Brava 3 15-05-2009 19:04
(G) cooling issues arc Cinquecento / Seicento 8 03-10-2008 16:32
(T) Heting and cooling issues Mike St Helens Punto (Mk2/2b) 0 20-03-2007 15:18
(T) cooling punto man Punto (Mk2/2b) 10 02-06-2004 17:28