Register Login
Mr FIAT - Your #1 source for vintage car parts
Reply
 
Thread Tools
Old 07-06-2008   #1
Join Date: May 2008
Posts: 84
Thanks: 4
Trader Rating: 0
United Kingdom 
Both dead?!

Hey
Can u guys point me in the right direction. Basicity both front and rear window squirters don't work. They don't even make a noise when i turn em on, no whine or buzz or anything. I checked the connections on both ends on both the pumps and checked fuses. It seems like both of em have just died.
Any ideas appreciated
Cheers
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

mejdmejd is offline Reply With Quote Quote 
Old 07-06-2008   #2
Join Date: Mar 2006
Location: Liverpool
Posts: 27,676
Thanks: 1227
Blog Entries: 3
Trader Rating: 5
fingers99 has donated!
United Kingdom 
Re: Both dead?!

Check for 12v at the motors.
__________________
M12 fund 20
fingers99 is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) i am so dead dave Cinquecento / Seicento 43 17-10-2012 08:54
(G) Ah its dead! Singh! Punto (Mk2/2b) 11 03-06-2008 21:14
(T) dead fional Punto (Mk2/2b) 7 16-01-2008 11:46
Well, he's dead Dobby Leisure Lounge 43 02-11-2007 22:00
i could be dead!! alainax Leisure Lounge 56 13-01-2006 18:16