Register Login
FIAT Auto Specialist Team
Reply
 
Thread Tools
Old 4 Weeks Ago   #1
Join Date: Sep 2019
Posts: 1
Thanks: 0
Trader Rating: 0
United Kingdom 
Bravo problem

Hi guys i have a bravo 1.4 t150 and all of a sudden i hit a speed bump the other day pretty fast and hard and i think every one know the understays are low on these model cars but anyway it feels like it has lost alot of power like a misfire or turbo problems when i floor it or even when im driving normal and i twas driving very slow aswell and it still has loss of power.


When i opened the bonnet to look the engine was shaking but couldnt here any leakes i know my timing belt need changng but that surly cant cause the loss of power etc.

ps also after driving for about 40 mins i can smell what can only be descibed as burning or some sort of over heating but my engine dile stays in the centre.


i need help as its driving me up the wall


thanks

Adam
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

adamfilz is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
bravo problem! keval FIAT Boo Archives 0 19-10-2008 14:26
I think my bravo has a problem watkinsbravo FIAT Boo Archives 10 30-10-2004 23:31
Bravo Problem MarcB FIAT Boo Archives 2 23-07-2004 21:19