Register Login
The UK's No.1 Chrysler Owners Forum
Reply
 
Thread Tools
Old 01-06-2015   #1
Join Date: Jun 2015
Posts: 4
Thanks: 0
Trader Rating: 0
United Kingdom 
Cruise Control Problem - 1.9 MultiJet 120

Hi All,

Got a little cruise control problem. Long story short, i've just inherited my wifes Bravo as she has got a newer vehicle.

The car needs a little bit of work so basically I have been doing bits and bobs to the Bravo (cleaned EGR) general tidyup, checked fuses.

However one very annoying problem relating to the cruise control (which has apparently always been the case with this car since we got it second hand)

It will work in all gears absolutely fine. Apart from 5th gear (top gear on this model).

In 4th doing say 60mph - click cruise on, push leaver - engages straight away. Cut off cruise with clutch, press RES and resumes fine.

Change to 5th - press RES - nothing
Try to engage cruise when in 5th - nothing.

Works in 3rd gear, 4th gear just can't get it to engage in 5th, and to add a spanner to the works - I've linked it up to a friends diagnostic and it reads the vehicle is in 5th and cruise is on all parameters are the same.

So yeah, if anyone has any ideas whatsoever i'd be happy to try them out as when your doing a lonnnng motorway journey at 4am and nobodys around, cruise control is my friend
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

CHBravo86 is offline Reply With Quote Quote 
Old 02-06-2015   #2
Join Date: Aug 2008
Location: Peterborough
Posts: 1,317
Thanks: 84
Trader Rating: 0
neilshep has donated!
United Kingdom 
Re: Cruise Control Problem - 1.9 MultiJet 120

Quote Originally Posted by CHBravo86 View Post
Hi All,

Got a little cruise control problem. Long story short, i've just inherited my wifes Bravo as she has got a newer vehicle.

The car needs a little bit of work so basically I have been doing bits and bobs to the Bravo (cleaned EGR) general tidyup, checked fuses.

However one very annoying problem relating to the cruise control (which has apparently always been the case with this car since we got it second hand)

It will work in all gears absolutely fine. Apart from 5th gear (top gear on this model).

In 4th doing say 60mph - click cruise on, push leaver - engages straight away. Cut off cruise with clutch, press RES and resumes fine.

Change to 5th - press RES - nothing
Try to engage cruise when in 5th - nothing.

Works in 3rd gear, 4th gear just can't get it to engage in 5th, and to add a spanner to the works - I've linked it up to a friends diagnostic and it reads the vehicle is in 5th and cruise is on all parameters are the same.

So yeah, if anyone has any ideas whatsoever i'd be happy to try them out as when your doing a lonnnng motorway journey at 4am and nobodys around, cruise control is my friend
Cruise control uses the stalk on the steering column to turn on / set / restore, and that seems to be OK, as it works in 3rd and 4th gears. It uses the brake light switch to disengage cruise when you brake, and it uses a switch on the clutch pedal to detect gear changes.

What gear you are in is deduced from comparing road speed with engine revs, and the ECU gets stressy if you change gear without using the clutch. If road spped is constant, the revs change, but no clutch operation detected, it will disengage cruise control.

eLearn says there is a minimum speed of about 30mph for cruise to operate, and also a maximum. Do you have the speed warning beep set lower than the speed you change up to 5th?

If all works completely correctly in 3rd & 4th, then I might expect an ECU fault, or a software upgrade needed.

Was cruise factory fitted, or is it a user modification?
__________________
His: CL Jazz Blue Bravo 1.9 Mjet 120 Gone but not forgotten
Now Kia Ceed Sportswagon GT-Line 1.0 TurboGDi
Hers: C4 1.4SX -still looking for the Robot button - Gone - Now Kia Ceed hatch 1.6GDi
neilshep is offline Reply With Quote Quote 
Old 03-06-2015   #3
Join Date: Jun 2015
Posts: 4
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Cruise Control Problem - 1.9 MultiJet 120

Thanks NeilShep for your thoughts.

No speed warning is set higher than when I change up, for instance I can do 70in 4th and it works, change to 5th and it doesn't at same speed.

The cruise control is factory fitted as far as I am aware. We bought the vehicle with it, but the vehicle was second hand.

Is there a tell tale sign for an aftermarket system being fitted? If this isn't factory it's a good job

Chris
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

CHBravo86 is offline Reply With Quote Quote 
Old 03-06-2015   #4
Join Date: Aug 2008
Location: Peterborough
Posts: 1,317
Thanks: 84
Trader Rating: 0
neilshep has donated!
United Kingdom 
Re: Cruise Control Problem - 1.9 MultiJet 120

Quote Originally Posted by CHBravo86 View Post
Thanks NeilShep for your thoughts.

No speed warning is set higher than when I change up, for instance I can do 70in 4th and it works, change to 5th and it doesn't at same speed.

The cruise control is factory fitted as far as I am aware. We bought the vehicle with it, but the vehicle was second hand.

Is there a tell tale sign for an aftermarket system being fitted? If this isn't factory it's a good job

Chris
When I got my car, I had a choice of 3 cars, all 1.9multijet 120 Actives, two with cruise, one with steering controls. I chose the blue one, without cruise. The mod to add cruise is to fit a stalk from an Alfa 147, and if you are lucky the connector is there under the steering column shroud. The giveaway then may be that the original shroud is cut awy to goe round the cruise stalk. If I want to fit cruise, I need to run extra wiring from the stalk into connector 1 on the ECU. That would be obvious.
__________________
His: CL Jazz Blue Bravo 1.9 Mjet 120 Gone but not forgotten
Now Kia Ceed Sportswagon GT-Line 1.0 TurboGDi
Hers: C4 1.4SX -still looking for the Robot button - Gone - Now Kia Ceed hatch 1.6GDi
neilshep is offline Reply With Quote Quote 
Old 03-06-2015   #5
Join Date: Jun 2015
Posts: 4
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Cruise Control Problem - 1.9 MultiJet 120

Okay in that case this is defiantly factory fitted cruise. Which makes the issue even more bizarre. I think maybe a trip to the dealership is in order see what they find.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

CHBravo86 is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Weird Cruise Control Problem bravardo Bravo 2 19-03-2014 01:32
(T) Retrofit Cruise control in my stilo WITH cruise control light Daveystrings Stilo 30 25-09-2013 21:05
(T) Fiat Bravo 1.9 120 multijet NOISE PROBLEM suetelf Bravo 0 16-03-2013 20:55
(T) multijet 120 1.9 starting problem neilshep Bravo 3 17-09-2008 08:21
(G) speedo/cruise control problem papahotel Ulysse 1 14-04-2006 21:06