Register Login
Mr FIAT - Your #1 source for vintage car parts
Reply
 
Thread Tools
Old 05-11-2014   #1
Join Date: Jul 2012
Location: Wednesbury
Posts: 1,815
Thanks: 157
Trader Rating: 0
Matthewr1990 has donated!
United Kingdom 
Climate control. Mine is broken.

So I'm expecting a big bill here but the last few weeks things have gotten bad with my perfect climate control. I no longer get any air blowing through the windscreen vent. It just sounds like it's blocked. Also when it's off I'm getting a dodgy noice. For lack of a better way to explain it it goes "whirrrr click, whirrrr click" but it does it quietly. I only hear it if the radio is off. Another issue is it no longer goes up to full power anymore. The last 4 or 5 bars of power do nothing. And are no different when I turn them up or down. Reckon it's FUBAR'd? And how much are fiat likely to rob me of.
__________________

1.4 T-jet 150, Maserati Blue, Sport
JOIN "BRAVO ENTHUSIASTS" ON FACEBOOK
Matthewr1990 is offline Reply With Quote Quote 
Old 05-11-2014   #2
Join Date: Sep 2009
Location: Bucharest
Posts: 2,049
Thanks: 140
Trader Rating: 0
Romania 
Re: Climate control. Mine is broken.

It sounds like the common Bravo problem: broken plastic connector between flaps and the actuating motors.

Read the climate control faults use MES/FES.
1. Print-screen of the current errors (save it so you can spot permanent and intermittent errors).
2. Clear errors.
4. activate different options on the climate control panel.. up,down, front, hot cold..
(this will cause the permanent errors to show up)
You should see something like "windscreen actuator signal out of range"..or "signal high/low".
It sounds like the common Bravo problem: broken plastic connector between flaps and the actuating motors.
Your flaps are stuck in between positions, that would cause low blower power as the airways are partly blocked.

The parts are cheap.. but fiat will not replace the motors unless they are completely dead.. that means that the old motor will continue to force the new plastic connector until it brakes again... but replacing the motors isn't the cheapest option.... best thing would be to unclip the motors and clean the potentiometer before replacing the connectors.

As for the work.. that is another story.. it's really hard to get to them ( on the Stilo it was easily accessible ..but on the bravo there is a big metallic thing in the way).
In order to get to them Fiat specifies it needs to remove the doors, the seats , the center console, the steering column, the dash, drain the freon, drain the antifreeze. remove the AC/heat and blower along with the metallic bar in the car that stops you getting to the motors.

So yeah expect a big bill.
I can also be done without removing the dash.. but it's a back braking work because the awkward position.. and takes hours.. and involves drilling through the metal so you can get tools in, to remove the screws ( 3 on each motor)

Here are a few pictures to get a better understanding of the problem:
Click image for larger version

Name:	P04-03-10_13-13.jpg
Views:	368
Size:	130.0 KB
ID:	145738

Click image for larger version

Name:	P04-03-10_11-28.jpg
Views:	310
Size:	112.7 KB
ID:	145739

Click image for larger version

Name:	IMG_5403.jpg
Views:	239
Size:	2.51 MB
ID:	145740

Click image for larger version

Name:	P04-03-10_16-15.jpg
Views:	187
Size:	99.6 KB
ID:	145741
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by aurick86; 05-11-2014 at 10:02.
aurick86 is offline Reply With Quote Quote 
Old 05-11-2014   #3
Join Date: Jul 2012
Location: Wednesbury
Posts: 1,815
Thanks: 157
Trader Rating: 0
Matthewr1990 has donated!
United Kingdom 
Re: Climate control. Mine is broken.

Quote Originally Posted by aurick86 View Post
It sounds like the common Bravo problem: broken plastic connector between flaps and the actuating motors.

Read the climate control faults use MES/FES.
1. Print-screen of the current errors (save it so you can spot permanent and intermittent errors).
2. Clear errors.
4. activate different options on the climate control panel.. up,down, front, hot cold..
(this will cause the permanent errors to show up)
You should see something like "windscreen actuator signal out of range"..or "signal high/low".
It sounds like the common Bravo problem: broken plastic connector between flaps and the actuating motors.
Your flaps are stuck in between positions, that would cause low blower power as the airways are partly blocked.

The parts are cheap.. but fiat will not replace the motors unless they are completely dead.. that means that the old motor will continue to force the new plastic connector until it brakes again... but replacing the motors isn't the cheapest option.... best thing would be to unclip the motors and clean the potentiometer before replacing the connectors.

As for the work.. that is another story.. it's really hard to get to them ( on the Stilo it was easily accessible ..but on the bravo there is a big metallic thing in the way).
In order to get to them Fiat specifies it needs to remove the doors, the seats , the center console, the steering column, the dash, drain the freon, drain the antifreeze. remove the AC/heat and blower along with the metallic bar in the car that stops you getting to the motors.

So yeah expect a big bill.
I can also be done without removing the dash.. but it's a back braking work because the awkward position.. and takes hours.. and involves drilling through the metal so you can get tools in, to remove the screws ( 3 on each motor)

Here are a few pictures to get a better understanding of the problem:
Attachment 145738

Attachment 145739

Attachment 145740

Attachment 145741
Ahh crap!

Thanks for your reply dude.
__________________

1.4 T-jet 150, Maserati Blue, Sport
JOIN "BRAVO ENTHUSIASTS" ON FACEBOOK
Matthewr1990 is offline Reply With Quote Quote 
Old 05-11-2014   #4
Join Date: Nov 2014
Posts: 1
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Climate control. Mine is broken.

hi had same fault on my wifes tjet dynamic , cost was around 350 for new cogs and motor inc labour at jcs fiat at kegworth
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

johnny01966 is offline Reply With Quote Quote 
Old 30-10-2015   #5
Join Date: May 2014
Location: Cardiff, Wales
Posts: 24
Thanks: 1
Trader Rating: 0
United Kingdom 
Re: Climate control. Mine is broken.

Hey guys, did anyone get this fixed by a dealer/garage? Just wondering about the cost?

My Bravo T-Jet Sport 150 has the "wurrr click..." Coming from the glovebox area and the passenger side is stuck on cold, regardless of the control settings.

I don't think I have either skills nor time to do it myself, but gonna look into getting someone to do it soon... Winter is coming...
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

DomKane is offline Reply With Quote Quote 
Old 01-11-2015   #6
Join Date: Oct 2015
Posts: 11
Thanks: 0
Trader Rating: 0
United Kingdom 
guys would you know how much I can get this fixed for?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Raheelssj5 is offline Reply With Quote Quote 
Old 04-02-2016   #7
Join Date: Jan 2016
Posts: 5
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Climate control. Mine is broken.

Hi
I know this an old thread but hoping that someone is still able to help.
I have a 2007 Bravo with the Climate control problem. As its a right hand drive car I'm able to get to the two upper motors on the passenger side no problem and expected one and maybe both are faulty. My question is how many of those stepper motors are there on the heater unit as I cannot locate more than those two?
Steve
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Smac02 is offline Reply With Quote Quote 
Old 04-02-2016   #8
Join Date: Apr 2011
Location: Near the M4
Posts: 20,569
Thanks: 728
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Re: Climate control. Mine is broken.

Quote Originally Posted by Matthewr1990 View Post
So I'm expecting a big bill here but the last few weeks things have gotten bad with my perfect climate control. I no longer get any air blowing through the windscreen vent. It just sounds like it's blocked. Also when it's off I'm getting a dodgy noice. For lack of a better way to explain it it goes "whirrrr click, whirrrr click" but it does it quietly. I only hear it if the radio is off. Another issue is it no longer goes up to full power anymore. The last 4 or 5 bars of power do nothing. And are no different when I turn them up or down. Reckon it's FUBAR'd? And how much are fiat likely to rob me of.
is this now sorted..??
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Old 04-02-2016   #9
Join Date: Sep 2009
Location: Fife, Scotland
Posts: 4
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Climate control. Mine is broken.

Quote Originally Posted by Smac02 View Post
Hi
I know this an old thread but hoping that someone is still able to help.
I have a 2007 Bravo with the Climate control problem. As its a right hand drive car I'm able to get to the two upper motors on the passenger side no problem and expected one and maybe both are faulty. My question is how many of those stepper motors are there on the heater unit as I cannot locate more than those two?
Steve
There are 3 actuators on the passenger side. the highest of the 2 you see is likely the one that controls the windscreen vent. I've current got mines jammed open and the actuator disconnected until i can be bothered fixing it. The next one is the air flow for the foot well and dash vents and then further down towards the centre console there is the passenger temp mixer. At the front of the Unit there is an actuator for the recirculation vent which is not accessible without removing the dash so if this breaks best bet is to just manually open the recirc vent from under the scuttle panel where the window wipers are. The 5th actuator is in the drivers footwell and controls the drivers side air temp/mix.

If you search this forum there are plenty old threads about this, many including pictures and diagrams.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Shug06 is offline Reply With Quote Quote 
Old 07-02-2016   #10
Join Date: Jan 2016
Posts: 5
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Climate control. Mine is broken.

Hi thanks for that.
Hoping that the fault is with the two reasonably accessible ones.
Steve
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Smac02 is offline Reply With Quote Quote 
Old 07-02-2016   #11
Join Date: Sep 2009
Location: Fife, Scotland
Posts: 4
Thanks: 0
Trader Rating: 0
United Kingdom 
Quote Originally Posted by Smac02 View Post
Hi thanks for that.
Hoping that the fault is with the two reasonably accessible ones.
Steve
What issues are you having?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Shug06 is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Climate Control - airflow issue [broken actuator?] Andymacselespeed Stilo 58 27-03-2019 09:25
(T) install Climate Control into non-climate model Panda hollister Panda 4 17-05-2012 16:18
(G) Is my Climate Control crap or is it broken ? Koa Stilo 35 01-06-2005 19:17