Register Login
endrop - for all your online needs
Reply
 
Thread Tools
Old 01-06-2010   #1
Join Date: Jul 2009
Posts: 54
Thanks: 0
Trader Rating: 0
United Kingdom 
Losing Power

Hi,

I have a 1.9 120 Bravo. Was driving quite happily yesterday and all of a sudden it seemed to lose some power. Would move, just not very swiftly. No lights etc on the dash. Got to where I was going stopped the car, left it for about 45mins, started and still lack of power. Got going again and gave it a bit of a boot and all of a sudden it seemed to spring into life (almost like something was blocked and cleared itself) and then it seemed to run OK.

Seems to be running OK(ish) again now, but did lose some power when going up a a particularly big hill.

Any ideas on anything I can check or what it may be? Bit worried now!

Thanks for your help.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

venturer is offline Reply With Quote Quote 
Old 01-06-2010   #2
Join Date: Feb 2008
Location: Middlesbrough
Posts: 588
Thanks: 21
Trader Rating: 0
United Kingdom 
Re: Losing Power

Sounds very much like a blocked EGR valve. The symptoms are like massive turbo lag.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

PROV is offline Reply With Quote Quote 
Old 01-06-2010   #3
Join Date: Jul 2009
Posts: 54
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Losing Power

The car does quite a lot of miles. I thought they tended to block if you only did short miles, or have I got that wrong?

Thanks for your help.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

venturer is offline Reply With Quote Quote 
Old 01-06-2010   #4
Join Date: Feb 2008
Location: Middlesbrough
Posts: 588
Thanks: 21
Trader Rating: 0
United Kingdom 
Re: Losing Power

Not necessarily, ours has 75k on now and blocked!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

PROV is offline Reply With Quote Quote 
Old 01-06-2010   #5
Join Date: Jul 2009
Posts: 54
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Losing Power

Perhaps I should clarify when I say it does a lot of miles...it does a lot of long motorway journeys.

I guess if it can still block, that is the first point of call. Is there a guide anywhere? Hard a look at the how-to's, but there doesnt seem to be one!

Thanks
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

venturer is offline Reply With Quote Quote 
Old 01-06-2010   #6
Join Date: Feb 2008
Location: Middlesbrough
Posts: 588
Thanks: 21
Trader Rating: 0
United Kingdom 
Re: Losing Power

Long motorway journeys and gentle driving seem to block more. Ours was a warranty job so no idea myself
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

PROV is offline Reply With Quote Quote 
Old 01-06-2010   #7
Join Date: Jul 2009
Posts: 54
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Losing Power

Is it covered in the third year of warranty? Mine is a March 08 reg so well into the third year.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

venturer is offline Reply With Quote Quote 
Old 01-06-2010   #8
Join Date: Apr 2007
Posts: 1,010
Thanks: 21
Trader Rating: 0
United Kingdom 
Re: Losing Power

Quote Originally Posted by venturer View Post
Is it covered in the third year of warranty? Mine is a March 08 reg so well into the third year.
You got 5 years warranty? mine was replace couple months ago, cover under 5 yrs warranty.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

STILO NEWBIE is offline Reply With Quote Quote 
Old 01-06-2010   #9
Join Date: Jul 2009
Posts: 54
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Losing Power

I had it second hand and I think it only came with a 3 year job. How would I find out if it was a 5 year one?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

venturer is offline Reply With Quote Quote 
Old 01-06-2010   #10
Join Date: Dec 2006
Location: Sunny Fife
Posts: 83
Thanks: 1
Trader Rating: 0
United Kingdom 
Re: Losing Power

Hi Venturer.

Definitely sounds like the EGR valve. Mine went last November (1.9 MJet) - got replaced under 3rd year warranty. Same symptoms as you described. Has your Bravo been serviced regularly? Fiat probably won't entertain it unless its been properly serviced. Let us know how you get on.
__________________
Originally Stilo Stew, then Bravo Stew, now Evo Stew!!

Punto Evo 1.6MJet Sporting in Jazz Blue - No mods just a great, very underrated machine
Stilo Stew is offline Reply With Quote Quote 
Old 02-06-2010   #11
Join Date: Jul 2009
Posts: 54
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Losing Power

Hasnt quite been service to schedule, think I will take it to my local friendly garage.

Do you think they will be able to give it a clean and it will be fine or should i be looking at getting a new one?

How much are we talking for a new part? Any other bits they should be changing whilst I am at it to avoid problems in future?

Thanks for all your help everyone.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

venturer is offline Reply With Quote Quote 
Old 02-06-2010   #12
Join Date: Dec 2006
Location: Sunny Fife
Posts: 83
Thanks: 1
Trader Rating: 0
United Kingdom 
Re: Losing Power

Hi Venturer.

Apparently EGR (Exhaust Gas Recirculation)valves can be cleaned out, they get coked up with diesel soot through time. There are plenty of threads in the forum on the EGR valve. I think one actually tells you how to do it.
__________________
Originally Stilo Stew, then Bravo Stew, now Evo Stew!!

Punto Evo 1.6MJet Sporting in Jazz Blue - No mods just a great, very underrated machine
Stilo Stew is offline Reply With Quote Quote 
Old 03-06-2010   #13
Join Date: Jun 2010
Location: Stourbridge
Posts: 13
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Losing Power

I've had the same problem with a 6 month old 1.9 165 Diesel - it's going back under warranty next week. I'll point out the EGR possibility when it goes in as I'm not at all confident about the capabilities of my local Fiat dealer (used them when they did Alfas too, pretty useless then). However, I've also got the change engine oil warning appear. The car's only done 9.5K miles - isn't this a bit premature? Driving is mainly town driving with a (fairly) light right foot
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

dcdewick is offline Reply With Quote Quote 
Old 03-06-2010   #14
Join Date: Aug 2008
Location: Peterborough
Posts: 1,317
Thanks: 84
Trader Rating: 0
neilshep has donated!
United Kingdom 
Re: Losing Power

Quote Originally Posted by dcdewick View Post
I've had the same problem with a 6 month old 1.9 165 Diesel - it's going back under warranty next week. I'll point out the EGR possibility when it goes in as I'm not at all confident about the capabilities of my local Fiat dealer (used them when they did Alfas too, pretty useless then). However, I've also got the change engine oil warning appear. The car's only done 9.5K miles - isn't this a bit premature? Driving is mainly town driving with a (fairly) light right foot
Yours is more likely to be a DPF problem. ***** footing round town and DPF regeneration will cause problems I believe. Wrong car for the job IMHO.

BTW its 1.9/150 or 2.0/165 The 1.9's dont have a DPF
__________________
His: CL Jazz Blue Bravo 1.9 Mjet 120 Gone but not forgotten
Now Kia Ceed Sportswagon GT-Line 1.0 TurboGDi
Hers: C4 1.4SX -still looking for the Robot button - Gone - Now Kia Ceed hatch 1.6GDi
neilshep is offline Reply With Quote Quote 
Old 03-06-2010   #15
Join Date: May 2006
Location: Dorset
Posts: 276
Thanks: 6
Trader Rating: 0
United Kingdom 
Re: Losing Power

Not really sure what's going on with mine now!

A couple of weeks ago on a long motorway journey - like 5 hours, noticed that whilst driving around 70mph mark, the engine seems to gently stutter, but if put under a little more pressure the stutter stops. I 'think' (because you become naturally more alert) it's getting worse. Basically I don't lose much power and it's fine under pressure, but when the engine is hot and driving on the balance between acceleration and deceleration, it seems to stutter.

It's the 2.0 165 Mjet, about 14.5k miles which are mainly rural quick road commuting (35mile runs, twice a day). EGR? DPF?

Cheers
__________________
09' Fiat Bravo 2.0Mjet Sport
Now a one car family!

Last edited by rambyuk; 03-06-2010 at 18:55.
rambyuk is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) Losing Power Rob uk Ulysse 0 26-03-2010 13:44
(G) Losing power swansea2007 Stilo 15 24-06-2008 13:51
(G) Losing power! tashman Panda (Classic) 12 09-01-2008 22:34
(G) losing power obi1123 Punto (Mk2/2b) 6 30-10-2007 22:30
(T) Losing Power dahig2002 Stilo 10 19-08-2007 22:30