Register Login
iNETFX Domain Registration - COM/NET/ORG £6.50 a year!
Reply
 
Thread Tools
Old 15-09-2006   #1
Join Date: Sep 2006
Posts: 1
Thanks: 0
Trader Rating: 0
Starting Trouble

Hi,

I recently bought Fiat Brava 1.4S N reg and got it full serviced a month back. I got the plugs, filters, oils changes as part of service. I use it daily.
Suddenly yesterday morning it refused to start. Not sure what could have gone wrong.

I am the first time driver and hence not sure of what to check really. I read WD40 would help. What it is? Your help would be much appreciated.

Many Thanks.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

sdokku is offline Reply With Quote Quote 
Old 18-09-2006   #2
jug
blessed are the apostates
 
jug's Avatar
Join Date: Nov 2005
Location: Durham
Posts: 13,806
Thanks: 554
Trader Rating: 1
jug has donated!
United Kingdom 
Re: Starting Trouble

when you try to start does the engine turn?
(if it doesnt i'd think a flat bettery may be the problem, or a dead/seized starter motor, or a wiring fault in the starting/charging circuit, or the alternator stopped chargin battery during last trip)

if it does turn over does it turn at the same speed as it normally does?
(if it doesnt it may mean there is a wiring poblem concering sterter motor, or a slightly flat bettery)

does the key code light go off on the dash or remain illuminated?
(if it remains on the immobiliser isnt turning off, meaning the red key is needed)

have you tried checking for sparks on the plugs? its worth a quick check.

the list really goes on and on as to what it could be.
__________________
2.0 twinspark veloce
jug is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) Mulitpla not starting masmit Multipla 2 09-11-2005 08:24
(T) Marea 1.9td 1998 starting problem paul33 Marea 5 20-09-2005 22:29
(T) Punto starting problem TerryH59 Punto (Mk2/2b) 2 26-01-2005 17:26
(T) Crap economy, lousy starting - ideas? JonnyBoy Punto (Mk2/2b) 6 22-12-2004 22:52
(T) STILO - Starting / Battery / ASR etc faults big-al Stilo 14 22-12-2003 19:03