Register Login
FIAT Auto Specialist Team
Reply
 
Thread Tools
Old 13-01-2004   #1
Join Date: Oct 2003
Location: Norway.
Posts: 8
Thanks: 0
Trader Rating: 0
WIPERS Problem

I was on a long travel and my Fiat Brava 1.6x was outside. When I came back the wipers and everything belong to that did not work and I found because of the fuse is gone. I changed the fuse and everything is fine in exception the front wipers just turn some degree and stopped again. I do not know it is freezing or some othe defects. I used hot water on it but still do not work. Please, any help or suggestion.

Kami
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

kami is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Tip timing problem? Akeldama Tipo (Classic) 4 01-08-2004 06:54
(G) Mid-throttle injection problem in Lancia Y10 FatNote Panda (Classic) 26 30-07-2004 19:58
(T) Problem with windscreen washer/wipers gill Punto (Mk2/2b) 3 20-11-2003 00:22
Brava lockup problem Kensho Lets Talk FIAT 1 11-11-2003 03:05
(T) Punto 75 SX '98 battery & electronic check problem zokipet Punto (Mk1) 3 22-02-2003 04:37