Register Login
Shop4Parts - UK's largest online superstore for FIAT and Alfa Romeo parts
Reply
 
Thread Tools
Old 05-10-2017   #1
Join Date: Oct 2017
Posts: 1
Thanks: 0
Trader Rating: 0
United Kingdom 
Poor Idling but running fine when accelerating

Hello All, I am looking for some advice on a problem with my 2000 brava 1.2

When i drive my Brava to work in the morning's it runs fine and idles fine at the end of my journey etc ( except when first started in the morning the engine does idle high then instantly drops )

However when I say drive home then leave the car for a short while and then decide to drive some were I am finding when the car is idling ( ie in traffic ) it coughs a lot and idles poorly until it eventually stalls, but when accelerating the car runs fine.

Your advice would be appreciated

Any idea on where to start sensors etc ?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Damobrava is offline Reply With Quote Quote 
Old 09-10-2017   #2
Join Date: Aug 2004
Location: Wirral
Posts: 1,575
Thanks: 70
Trader Rating: 0
bluejohn125 has donated!
United Kingdom 
Re: Poor Idling but running fine when accelerating

It could be a temp sensor problem or low coolant, hence the issues around the cold running, It may be worth a careful coolant flush and change anyway.

If your car is the later engine type there will be a combined manifold / cat on the engine with two lambda sensors - pre-cat and post-cat. Pre-cat has the most influence on engine mixture and running, both have a heater circuit that should get them operating correctly with a cold engine. Exhaust leaks / cracks around the lambdas will screw up their readings and confuse the ECU.

In any case get the car ODB diagnosed by a garage or autoelectrician, this should reveal any logged faults. I assume you haven't had a dashboard fault light but there could be intermittent faults. You could also have an emissions check.

But don't forget the obvious classics like plugs and plug leads, it's easy to assume that modern stuff lasts for ages and the problem is somewhere else.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

bluejohn125 is offline Reply With Quote Quote 
Old 09-10-2017   #3
Moderator
 
Peter Pick-Up's Avatar
Join Date: Mar 2008
Posts: 4,301
Thanks: 192
Trader Rating: 0
Peter Pick-Up has donated!
Netherlands 
Re: Poor Idling but running fine when accelerating

Bad IAC= Idle Air Control (valve).

A 2000 M.Y. Fiat has just one O2 sensor in front of the catalyst.
Welcome at FiatForum, btw!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by Peter Pick-Up; 09-10-2017 at 21:11.
Peter Pick-Up is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(Tu) Poor idling Darth Odious Punto (Mk1) 4 11-07-2016 09:34
(T) 2.2 idling rough on start up, fine when warm Tribby Ducato 0 07-09-2015 23:06
(T) poor idling when cold mal6186 Punto (Mk2/2b) 2 18-02-2009 22:41
(T) Poor idling and acceleration when cold davewichmann Coupe 8 09-01-2009 17:32
Poor Idling Mike Horton FIAT Boo Archives 6 08-06-2002 23:27