Register Login
endrop - for all your online needs
Reply
 
Thread Tools
Old 03-05-2011   #1
Join Date: Apr 2009
Location: Chatteris
Posts: 2,004
Thanks: 47
Trader Rating: 0
Rigby has donated!
United Kingdom 
Quick question needs quick answer/help!

A week ago my car failed to start, which ofcourse drained the battery but I got a bump start, got it home and checked out the battery and if the alternater was doing anything, gave it a charge overnight and it started straight away and has been as normal since then untill today after work. Try to start it and it does one pathetic attempt at turning over and then the fuel gauge and temp gauge fly to the top and back down and the trip resets, although the radio doesnt. Got home, 30ish miles, got the multi meter out again and its showing 12.6V with everything on and then 12.4V with the car off, the last time it was showing 13.2 with everything running once I charged it for a bit.

My hunch is that the alternator is charging the battery but the battery cant hold its charge?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Rigby is offline Reply With Quote Quote 
Old 03-05-2011   #2
Join Date: Jan 2010
Posts: 176
Thanks: 6
Trader Rating: 0
United Kingdom 
Re: Quick question needs quick answer/help!

Quote Originally Posted by Rigby View Post
A week ago my car failed to start, which ofcourse drained the battery but I got a bump start, got it home and checked out the battery and if the alternater was doing anything, gave it a charge overnight and it started straight away and has been as normal since then untill today after work. Try to start it and it does one pathetic attempt at turning over and then the fuel gauge and temp gauge fly to the top and back down and the trip resets, although the radio doesnt. Got home, 30ish miles, got the multi meter out again and its showing 12.6V with everything on and then 12.4V with the car off, the last time it was showing 13.2 with everything running once I charged it for a bit.

My hunch is that the alternator is charging the battery but the battery cant hold its charge?
Hard to tell... I would start by cleaning the contacts.
And how old is the battery?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

nunesaf is offline Reply With Quote Quote 
Old 04-05-2011   #3
Join Date: Apr 2009
Location: Chatteris
Posts: 2,004
Thanks: 47
Trader Rating: 0
Rigby has donated!
United Kingdom 
Re: Quick question needs quick answer/help!

New problem.

Started this morning on the way to work, car would jolt badly as if it was mis firing but it still had all the power and accelerated smoothley when it was jolting, it got so bad I had to turn off the motorway and limp home. Just went to start it again and when I turn the ignition on the injector light flashes and there's a very noticeable and rhytmic click from the injector area
I'm guessing duff injectors?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Rigby is offline Reply With Quote Quote 
Old 04-05-2011   #4
Join Date: Apr 2009
Location: Chatteris
Posts: 2,004
Thanks: 47
Trader Rating: 0
Rigby has donated!
United Kingdom 
Re: Quick question needs quick answer/help!

Think there was some crap in the fuel, just started it up fine, took it for a blast down the by pass and it was fine.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Rigby is offline Reply With Quote Quote 
Old 05-05-2011   #5
Join Date: Jun 2006
Posts: 788
Thanks: 48
Trader Rating: 0
reddy4bed has donated!
United Kingdom 
Re: Quick question needs quick answer/help!

Battery's are not expensive and only have a limited life, just change it, I only give mine 2 chances if ever it goes flat, charge it once, if it reccurs change it.
Tony.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

reddy4bed is offline Reply With Quote Quote 
Old 05-05-2011   #6
Join Date: Oct 2009
Location: Alba Iulia
Posts: 107
Thanks: 4
Trader Rating: 0
Romania 
Re: Quick question needs quick answer/help!

i think you should check the alternator's live wire, it should read about 13.6 v with the engine running, no matter how duff is the battery. You're reading is the normal voltage at the battery when engine off. I had the same problem runned fine one day, that evening battery fully discharged, stuck away from home, the next day runned fine until later in the day then again flat. The live wire from the alternator was broken a bit the first day, then snaped off completley. Put it togheter and from then no problem.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Corvinus is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) quick question, quick answer (hopefully) Todger182 Cinquecento / Seicento 2 16-03-2010 20:48
(T) Will this gearbox fit?? need quick answer blu73 Stilo 26 18-02-2010 21:16
(S) have huge question. need quick answer bravohgtlad Bravo / Brava 1 09-07-2009 20:43
(G) Need a quick answer about ECU No. Richie_81mk Punto (Mk2/2b) 1 14-07-2008 17:49
(S) skirts need quick answer please The Sultan Punto (Mk2/2b) 4 19-11-2007 21:15