Register Login
Shop4Parts - UK's largest online superstore for FIAT and Alfa Romeo parts
Reply
 
Thread Tools
Old 03-08-2015   #1
Join Date: Apr 2008
Posts: 132
Thanks: 9
Trader Rating: 0
Map Test Champion
United Kingdom 
Blue and Me weird behaviour and wont connect to TomTom Live 2

Hi Guys!

I'm back after about a 6 year absence and I'm sad to say that the white mk2 in the signature is long gone However, I am very happy to say that I just got a new Punto (2015) 15 Plate Easy+ in white with B&M and TomTom etc.

A few years ago I had a 2013 Punto with Blue and Me (no TomTom) which worked as I expected. As soon as the ignition was switched on, the bluetooth would connect and you could use the steering wheel buttons to make or take calls and browse the menu on the cluster display.

This new model doesn't allow the phone to connect, or any of the steering wheel buttons to work, unless the actual radio/stereo head unit is switched on. This seems like incorrect behaviour to me, and it doesn't make sense since the old one didn't do that.

However, the main issue, and I am thinking that it may be related, is that it will not connect to my TomTom. The B&M system will not pair with the TomTom, even though it does pair with my phone (only when stereo is on).

I have tried disconnecting the battery for 15 mins - no change. I have tried following the procedure for updating B&M firmware through the USB port and it simply does nothing when the stick is inserted. The port itself works because it can play music via media player, but when i insert the stick with the update (or rather, the assisted set up files to download the version type etc from the car before downloading the actual update), absolutely nothing happens when i switch on the ignition. I believe it is supposed to say UPDATE STARTED or something to that effect.

Can anyone confirm if the system only working with the stereo unit on is expected normal behaviour for a very new version of the system? (mine has built in A2DP streaming capability, so I know it's significantly different to my 2013 model.)

Also, any idea why it won't pair with TomTom?

The dealer is confused because they showed me that their Pop+ demonstrator behaves in exactly the same way (albeit it doesnt have the TomTom).

Any help much appreciated!

Thanks
Daniel
__________________

15" Sporting Alloys, Colour coded mirrors, 5000000 Edition Mats, Active clocks, Rear soundproofing, 6000k H.I.D dipped beams.
drm08 is offline Reply With Quote Quote 
Old 03-09-2015   #2
Join Date: Oct 2003
Location: United Kingdom.
Posts: 498
Thanks: 1
Trader Rating: 0
United Kingdom 
Re: Blue and Me weird behaviour and wont connect to TomTom Live 2

New Punto's do not have Blue & me. The Bluetooth function is provided by the radio unit itself, and is not compatible with the tomtom units for the blue & Me pairing. Hope this helps.
__________________
F.I.A.T. -- Flipping , Italian , Automobile , Tat . :)
FiatExpert is offline Reply With Quote Quote 
Old 03-09-2015   #3
Join Date: Apr 2008
Posts: 132
Thanks: 9
Trader Rating: 0
Map Test Champion
United Kingdom 
Re: Blue and Me weird behaviour and wont connect to TomTom Live 2

Hey,

Thanks for the response. This is what i have come to realise from my dealer, much to my disappointment.

My problem is, the car was advertised with Blue&Me and the TomTom Sat nav. The brochure and the website even show pictures of the tomtom working when paired.

The question now is, have i been mis sold the car and should i be seeking compensation? The Blue&Me tomtom was one of the reasons i purchased the car and is worth 300. But i am now being told that it cant do virtually anything it is supposed to, making it worth only around 70.

I feel FIAT have sold me this car on misleading information.

What does everyone think?
__________________

15" Sporting Alloys, Colour coded mirrors, 5000000 Edition Mats, Active clocks, Rear soundproofing, 6000k H.I.D dipped beams.
drm08 is offline Reply With Quote Quote 
Old 03-09-2015   #4
Join Date: Oct 2003
Location: United Kingdom.
Posts: 498
Thanks: 1
Trader Rating: 0
United Kingdom 
Re: Blue and Me weird behaviour and wont connect to TomTom Live 2

I think if that's the case then, and you have hard copy's of brochure, then take it with up with Fiat Uk. Its not really the dealers fault, as they can only go off the information given to them. Cars change all the time, and sometimes the books provided even with new cars, do not match up with the cars spec inside.
__________________
F.I.A.T. -- Flipping , Italian , Automobile , Tat . :)
FiatExpert is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
Map updating TomTom Blue&Me 2 Live doblovert Satellite Navigation 0 26-04-2014 12:29
Blue&me TomTom 2 Live sswcheung Blue and Me 0 10-07-2012 17:16
Start up tips for Blue&Me TomTom 2 Live Paulfinlay29 Satellite Navigation 3 25-01-2012 00:11
Start up tips for Blue&Me TomTom 2 Live Paulfinlay29 Blue and Me 1 21-09-2011 16:29
Weird behaviour thomas FIAT Boo Archives 5 05-04-2004 15:09