Register Login
FIAT Auto Specialist Team
Reply
 
Thread Tools
Old 24-01-2009   #1
Join Date: Jul 2006
Posts: 1,421
Thanks: 31
Trader Rating: 0
United Kingdom 
Rough running

I currently have a problem whereby the engine coughs and splutters when I jab the accelerator or when accelerating at low revs. For example less than 2000rpm in second gear in traffic. When idling you can hear every now and again a misfire. I have checked and cleaned the Idle control valve and still have the same issue.
Could it be;

A faulty injector?
A faulty coil pack?
A faulty variator solenoid?
My back box seriously needs changing?

Thanks,

Ad.
__________________
Current cars: Maserati Ghibli, Lancia Fulvia, Fiat Coupe 20VT, Fiat Stilo JTD, Fiat Panda Mjet.

Last edited by afroking; 24-01-2009 at 18:26.
afroking is offline Reply With Quote Quote 
Old 25-01-2009   #2
Join Date: Nov 2008
Posts: 159
Thanks: 1
Trader Rating: 0
Re: Rough running

Ad,

I guess it could be a faulty injector or coil pack. At work I have written down the resistance measurements for both so can check for you tomorrow. I may not tell you for sure but it may just indicate something wrong somewhere!

As for the variator solenoid, I guess if it was stuck and the inlet valve timing was advanced all the time then yes that may cause it but I cant see it happening. Having had the solenoid in and out of mine about 30 times yesterday it only takes 30 seconds to take it out and check it. It doesnt do anything below 3000rpm so if it isnt stuck then it wont be that.

Chris
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

topher is offline Reply With Quote Quote 
Old 26-01-2009   #3
HP
I was only doing 80...
 
HP's Avatar
Join Date: Mar 2002
Location: North East
Posts: 9,864
Thanks: 116
Trader Rating: 0
HP has donated!
United Kingdom 
Re: Rough running

Daft question, but is it due a service? Has it recently had plugs and filters etc.?
__________________
Pete.


"Make something idiot proof and someone will just go and build a better idiot".
HP is offline Reply With Quote Quote 
Old 26-01-2009   #4
Join Date: Jul 2006
Posts: 1,421
Thanks: 31
Trader Rating: 0
United Kingdom 
Re: Rough running

@ Tropher, thank you for your input, if you could get those resistant values I would really appreciate it. With regards to the variator solenoid I was just shooting off ideas trying to cover ever posibility.

@ HP its not a daft question, before I put it into the garage about 6 months ago I had changed all filters, plugs and oil. It is due an oil change now which I will do this week. The problem is it had these symptoms before the previous service so I doubt its related.

Any other input is welcome, I really appreciate it guys thank you.

Ad.
__________________
Current cars: Maserati Ghibli, Lancia Fulvia, Fiat Coupe 20VT, Fiat Stilo JTD, Fiat Panda Mjet.
afroking is offline Reply With Quote Quote 
Old 26-01-2009   #5
Join Date: Nov 2008
Posts: 159
Thanks: 1
Trader Rating: 0
Re: Rough running

Ad,

OK data is from the Auto data CD so it should be correct but is for my car (1996-1998), I have written down anything that may help

Coil - primary resistance 0.54 - 0.66 ohms
Spark plug gap 0.9mm
Engine coolant temperature - 320 ohms at 80degC
Injectors 10.8 - 13.2 ohms
Lambda Sensor 4 - 5 ohms

Hope it helps.....

Chris
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

topher is offline Reply With Quote Quote 
Old 26-01-2009   #6
Join Date: Jan 2007
Location: Brussels
Posts: 891
Thanks: 7
Trader Rating: 0
Belgium 
Re: Rough running

Quick check list, but I imagine you've already covered it:

1. Clean throttle body.
2. Clean idle valve.
3. Check plugs are not damp.
4. Take plugs out and check colouring.
5. Clean mass air sensor.
6. Check for leaks in air intake system, especially after the mass air sensor.
7. Check battery condition.

I doubt it's any of the above, but number 4 may show if one of the injectors is faulty.

Good luck!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Mad Matt is offline Reply With Quote Quote 
Old 26-01-2009   #7
Join Date: Jul 2006
Posts: 1,421
Thanks: 31
Trader Rating: 0
United Kingdom 
Re: Rough running

Just drove my girlfriend back to University (130 miles each way) and the misfire seemed to be more noticeable than before especially when I accelerate full throttle at 2500RPM.

I cleaned my throttle body and idle valve yesterday and although they needed it, there was no change. I need to check the plugs. Where is the air mass sensor? My car is 2000 'X' reg and it is not part of the intake pipes. I also need to check the battery condition.

Thanks Mad Matt, at least that will give me something to think about until I get home.
__________________
Current cars: Maserati Ghibli, Lancia Fulvia, Fiat Coupe 20VT, Fiat Stilo JTD, Fiat Panda Mjet.
afroking is offline Reply With Quote Quote 
Old 26-01-2009   #8
Join Date: Jan 2007
Location: Brussels
Posts: 891
Thanks: 7
Trader Rating: 0
Belgium 
Re: Rough running

I had an older one, I think on the newer ones it's built into the throttle body, but exactly where I do not know!.

LRB?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Mad Matt is offline Reply With Quote Quote 
Old 26-01-2009   #9
Join Date: Mar 2007
Location: Trondheim
Posts: 1,937
Thanks: 16
Trader Rating: 0
Norway 
Re: Rough running

LRB seems to have gone missing. Probably something to do with a combination of wife, hatchet, and unfinished hall
__________________
In storage until 2014 :
1996 Silver Barchetta, OZ Racing F1 16", Lesj÷fors 40/40 springs, InoxCar ESD102, debadged front & rear, K&N filter, white side repeaters, red calipers, alu mats, black leather seats, HID, Italiatec rear bumper, OMP strut brace
Robot is offline Reply With Quote Quote 
Old 26-01-2009   #10
Join Date: Jun 2008
Location: Gers
Posts: 342
Thanks: 6
Trader Rating: 0
Richpea has donated!
France 
Re: Rough running

Quote Originally Posted by Robot View Post
LRB seems to have gone missing. Probably something to do with a combination of wife, hatchet, and unfinished hall
LRB is working 200 miles away from his home.

Is the attached a picture of what you call the air mass sensor? Had a new one fitted to my '97 B 2 years ago when it kept cutting out but it only made a little difference and after a lot of testing, and massive labour costs, it turned out to be the timing that needed adjustment.
Attached Thumbnails
Click image for larger version

Name:	Capture.JPG
Views:	81
Size:	103.8 KB
ID:	56986  
__________________
Beloved Blue B
Richpea is offline Reply With Quote Quote 
Old 26-01-2009   #11
Join Date: Jul 2006
Posts: 1,421
Thanks: 31
Trader Rating: 0
United Kingdom 
Re: Rough running

Thanks Richpea but that is the idle control valve.
__________________
Current cars: Maserati Ghibli, Lancia Fulvia, Fiat Coupe 20VT, Fiat Stilo JTD, Fiat Panda Mjet.
afroking is offline Reply With Quote Quote 
Old 26-01-2009   #12
Join Date: Jun 2008
Location: Gers
Posts: 342
Thanks: 6
Trader Rating: 0
Richpea has donated!
France 
Re: Rough running

Quote Originally Posted by afroking View Post
Thanks Richpea but that is the idle control valve.
Most grateful for you putting me right - I am not that good with things mechanical.
__________________
Beloved Blue B
Richpea is offline Reply With Quote Quote 
Old 26-01-2009   #13
Join Date: Jul 2006
Posts: 1,421
Thanks: 31
Trader Rating: 0
United Kingdom 
Re: Rough running

That's ok, thank you for your input.
__________________
Current cars: Maserati Ghibli, Lancia Fulvia, Fiat Coupe 20VT, Fiat Stilo JTD, Fiat Panda Mjet.
afroking is offline Reply With Quote Quote 
Old 28-01-2009   #14
Join Date: Nov 2008
Posts: 159
Thanks: 1
Trader Rating: 0
Re: Rough running

Have you got any further forward Ad?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

topher is offline Reply With Quote Quote 
Old 28-01-2009   #15
Join Date: Jul 2006
Posts: 1,421
Thanks: 31
Trader Rating: 0
United Kingdom 
Lightbulb Re: Rough running

Yes, yes I have. Got back late last night so couldn't do anything, however this morning I set about checking the plugs, took the top cover off and would you believe it I have left my allen keys round a mates! Pretty annoyed to say the least.
So anyway, I had a look around the engine bay and got out my trusty extension bar (to use as a stethoscope) and listened to different components.
In the end, I don't know why but I pulled out a connection in the throttle body (the one marked in the picture). At first the rev's died but quickly picked up again, I kept it unplugged until I heard a misfire. I didn't hear any misfires within 5 minutes of it being unplugged so I turned off the engine, plugged it back in, turned it back on and what do you know? Misfiring again! When the sensor was unplugged the engine ran a lot smoother and the injector light came up on the dashboard. It didn't rev as freely as before but it certainly cured the misfire.
Obviously I can't run it without the sensor plugged in without knowing what it does. So what does it do?

Thanks,

Ad.
Attached Thumbnails
Click image for larger version

Name:	jim.jpg
Views:	63
Size:	501.7 KB
ID:	57071  
__________________
Current cars: Maserati Ghibli, Lancia Fulvia, Fiat Coupe 20VT, Fiat Stilo JTD, Fiat Panda Mjet.

Last edited by afroking; 28-01-2009 at 16:53.
afroking is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) 1.9jtd running rough! gelataio Bravo / Brava 17 19-04-2011 20:53
(T) 1.6 rough running - HELP sanja141 Stilo 53 17-11-2008 00:09
(T) Rough running Sei Hallsy200sx Cinquecento / Seicento 4 20-07-2006 18:10
(T) Rough running Booster Punto (Mk2/2b) 8 24-04-2006 22:22
(T) running rough mad4it Punto (Mk2/2b) 2 10-07-2005 21:01