Register Login
Mr FIAT - Your #1 source for vintage car parts
Reply
 
Thread Tools Search this Thread
Old 3 Weeks Ago   #1
Join Date: Sep 2015
Posts: 16
Thanks: 0
Trader Rating: 0
Portugal 
Coolant woes on 2013 Supersport

Not sure if anyone has had this issue but here it goes.

I've noticed everytime the coolant reservoir is topped up to MAX, it always ends up overflowing some coolant through the cap, resulting in red residue all over the expansion tank.

So it ends up overflowing tiny amounts of coolant every trip till it reaches the MIN and stabilizes.
No issues with temps, never exceeding 90ļC or anything that hints to a blown HG. No milkshake in the oil cap, no oil residue in the expansion tank, no white smoke from the exhaust, no bubbling in the expansion tank whilst idling, the hoses never get rock hard and the system depressurizes naturally as the engine cools down... Nothing at all.
I'm all out of ideas.

I've replaced the cap when it first happened, almost 2 years ago and forgot about it, since it always ran on MIN without spilling anything after that.

The issue reappeared as of lately since it blew an IC hose and the dealership kindly topped up the reservoir.

I'm thinking I'll need to get a compression check on the engine and maybe a pressure test on the cooling system.

Any ideas?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

brokencr0ss is offline Reply With Quote Quote 
Old 2 Weeks Ago   #2
Join Date: Oct 2012
Posts: 313
Thanks: 19
Trader Rating: 0
Officina red has donated!
United Kingdom 
Re: Coolant woes on 2013 Supersport

Can’t help you, but my Mini Cooper is exactly the same, coolant is always on minimum, runs flawlessly no problems at all, but top it up to max, go for a drive let it cool then check it, back on minimum, tried topping it several times, always back on minimum, so gave up trying and left it on minimum, been like that from new.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Officina red is offline Reply With Quote Quote 
Old 2 Weeks Ago   #3
Join Date: Apr 2011
Location: Near the M4
Posts: 29,247
Thanks: 1152
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Quote Originally Posted by brokencr0ss View Post
Not sure if anyone has had this issue but here it goes.

I've noticed everytime the coolant reservoir is topped up to MAX, it always ends up overflowing some coolant through the cap, resulting in red residue all over the expansion tank.

I'm thinking I'll need to get a compression check on the engine and maybe a pressure test on the cooling system.

Any ideas?
Getting the coolant reservoir 'sniffed' for exhaust gases should do the trick

Remember that Multiair systems can give odd 'compression test' results too
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) 2013 fiat 500 engine coolant temp sensor cherosno 500 (USA) 5 17-03-2021 21:36
(G) Coolant woes acfunduro 500L 2 30-06-2020 20:18
(T) 2000 Punto 1.2 coolant woes kerry_punto Punto (Mk2/2b) 8 23-09-2007 13:27