Register Login
iNETFX Domain Registration - COM/NET/ORG £6.50 a year!
Reply
 
Thread Tools
Old 02-01-2017   #1
Join Date: Feb 2014
Posts: 3
Thanks: 0
Trader Rating: 0
United Kingdom 
Question Heater not working properly

Hey guys,

So my heater has stopped working, Well it is working, but its really not getting very warm at all. I have to wear a thick coat in the car and demisting the windscreen takes 20 mins.

Its gradually got worse but its not got to the point where it needs fixing. How do I go about doing this?

I took it to the garage and they "flushed it through" it got a bit better after this but it still needs fixing. I have checked that the 2 pipes that go from in the engine bay through the firewall into the car, they are warm. But i dont really know whats next.

Thanks

Ed


*EDIT*
Its a fiat grande punto 1.2 08.

coolant level is fine
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by edbay; 02-01-2017 at 19:40.
edbay is offline Reply With Quote Quote 
Old 02-01-2017   #2
Join Date: Sep 2012
Posts: 197
Thanks: 31
Trader Rating: 0
United Kingdom 
Re: Heater not working properly

Where abouts are you in the country? Do you have a standard heater or climate control?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

burrowsdeano is offline Reply With Quote Quote 
Old 02-01-2017   #3
Join Date: Feb 2014
Posts: 3
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Heater not working properly

Quote Originally Posted by burrowsdeano View Post
Where abouts are you in the country? Do you have a standard heater or climate control?
In Cambridgeshire and a standard one
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

edbay is offline Reply With Quote Quote 
Old 02-01-2017   #4
Join Date: Apr 2011
Location: Oxford - UK
Posts: 16,079
Thanks: 558
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Re: Heater not working properly

Quote Originally Posted by edbay View Post
In Cambridgeshire and a standard one
Hi,
what colour is /was the coolant ?, nice bright RED ,, or a brown sludge..??

could well be that it's had radweld of other such debris put in the system to clog it up.

hence the flushing.

there is always the chance they haven't bled it of air properly though.

Charlie
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Old 03-01-2017   #5
Join Date: Apr 2016
Posts: 114
Thanks: 4
Trader Rating: 0
Romania 
Re: Heater not working properly

When's the last time you changed your cabin filter?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Snails is offline Reply With Quote Quote 
Old 05-01-2017   #6
Join Date: Feb 2014
Posts: 3
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Heater not working properly

Quote Originally Posted by varesecrazy View Post
Hi,
what colour is /was the coolant ?, nice bright RED ,, or a brown sludge..??

could well be that it's had radweld of other such debris put in the system to clog it up.

hence the flushing.

there is always the chance they haven't bled it of air properly though.

Charlie
Its bright red, but i think it needs bleeding because the coolant was a bit low. Where are the bleeding nipps?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

edbay is offline Reply With Quote Quote 
Old 05-01-2017   #7
Join Date: Apr 2011
Location: Oxford - UK
Posts: 16,079
Thanks: 558
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Quote Originally Posted by edbay View Post
Its bright red, but i think it needs bleeding because the coolant was a bit low. Where are the bleeding nipps?
Hi. If below min...

It could draw in air..also ..where has the coolant gone.

See punto 2 GUIDES for basic bleeding advice and pics

Charlie
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Old 05-01-2017   #8
Join Date: Jan 2013
Posts: 448
Thanks: 30
Trader Rating: 0
DGPunto has donated!
United Kingdom 
Re: Heater not working properly

Quote Originally Posted by Snails View Post
When's the last time you changed your cabin filter?
1. Definitely look at the cabin/pollen filter: https://www.fiatforum.com/grande-pun...in-filter.html


2. Is the fan working properly?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

DGPunto is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) AC Not working properly JMatos Grande Punto 5 28-06-2014 20:03
(T) Heater Fan only working properly Adrian Howard Doblo 2 10-08-2013 12:41
(T) Brakes not working properly russellwatson17 500 21 24-04-2011 10:44
(T) Door not working properly narked Grande Punto 6 30-04-2009 21:04
(T) Punto Mk1 punto Heater not working properly Anstey Punto (Mk1) 4 24-12-2006 00:39