Register Login
Mr FIAT - Your #1 source for vintage car parts
Reply
 
Thread Tools
Old 23-03-2016   #16
Join Date: Mar 2008
Location: Fleet, Hampshire
Posts: 1,444
Thanks: 87
Trader Rating: 0
Melanabb has donated!
United Kingdom 
Re: 3 weeks later...ANOTHER issue...

I had that issue and after spending so much money on fault repairs I've decided I had enough and sold the car... This thread might be relevant for GPA owners although it concerns Fiat 500s... Looks like somebody found the solution (brake switch)

https://www.fiatforum.com/500/434578...lt-thread.html
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by Melanabb; 23-03-2016 at 11:01.
Melanabb is offline Reply With Quote Quote 
Old 23-03-2016   #17
Join Date: Jan 2011
Posts: 53
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: 3 weeks later...ANOTHER issue...

Yes - I'm currently chasing the same problem with my 2009 Grande.

Warning lights for ASR/hill start not available, and power steering also occasionally come on. They all seem to be connected to the brake light switch in some way.

I've disassembled a brake light switch ( see here) https://www.fiatforum.com/grande-pun...tch-blues.html and can report that it has two switches inside, and an odd plunger.

The brake light switch has a bayonet fitting onto its mount just above the brake pedal. The internal workings of the plunger are locked in place when the switch is removed from its mount, and the plunger can move freely without affecting the internal switching. When the brake light switch is locked into its mount, the internal workings are automatically unlocked and the plunger is attached to them. There must be a requirement to insert the switch while holding the brake pedal down, or some other special thing to do, which we don't know about. Unless anyone has a FIAT manual explaining the steps for inserting a new brake light switch...?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Dodgy Geezer is offline Reply With Quote Quote 
Old 30-08-2016   #18
Join Date: Nov 2014
Posts: 67
Thanks: 2
Trader Rating: 0
United Kingdom 
Re: 3 weeks later...ANOTHER issue...

I got the original fault sorted,it was a wet fuse which is a result of letting the numpty in the backstreet where i used to live do some repairs on my AGP..
Likes varesecrazy liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

daryl88 is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
fiat stilo reverse gear issue any issue arcadejay Newbie Central 0 08-07-2015 09:43
(T) AIR BAG ISSUE mot issue brianW1979 Punto (Mk2/2b) 12 01-07-2014 22:46
(T) Stereo issue and new issue that probably the result of me trying to fix issue 1... jmccaig Punto (Mk2/2b) 18 05-06-2014 13:15