Register Login
Save up to 15% with Adrian Flux insurance!
Reply
 
Thread Tools Search this Thread
Old 16-12-2015   #1
Join Date: Dec 2015
Posts: 10
Thanks: 0
Trader Rating: 0
Greece 
Angry Uconnect 5 Navigation problem

Hi, two months ago I bought a new FIAT 500 X with Uconnect 5 Navigation Radio. Navigation as far as I noticed was working fine till last week that serious problems came-up.
So navigation started to frequently stall either during cruising (loose GPS signal and freezes my position on map trying eternally to recover my position), either after puting a new destination and trying eternally... to find my current position so it can draw the route.
After i.e. 30 minutes of trying to find my valid position, sometimes it suddenly recovers. However, not always. At the same time my Iphone's navigation application works perfectly (I have two navi apps, one powered by tomtom and other by google), so definitaly there is no signal loss from satelites.
When that problem happens the compass application on Uconnect almost always becomes blind as well and can show wether I am moving north, south etc.
Another strange sympton is that when sometimes works ok keeping correctly my position on the map/route, if I change my destination, it may looses my position and can't find it anynore.

I have installed through "tomtom home" software the new european map version but didn't cured it.

the details of my device are:
Device is TP6325B00404/3600
APP. 11.815.1902796.107 (4346. 17/4/2015)
MAP EUROPE v942.6150, release date 12/2014

Yesterday I went the car to the authorised dealer, put it in the computer and found that a softaware update for the whole care was available from Fiat. They did the update but nothing changed to my navigation problems.

Thanks for your attention and replies

Stelios
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Stelios Loumakis is offline Reply With Quote Quote 
Old 16-12-2015   #2
Join Date: Oct 2015
Location: In my car
Posts: 109
Thanks: 17
Trader Rating: 0
Greece 
Re: Uconnect 5 Navigation problem

Maybe the GPS sensor has been disconnected or hanging loose?

I think its located at the top of the windscreen, behind the rear view mirror. You can ask them to open it and see if its in the correct position looking "upwards", otherwise it won't be able to get a "lock" on the GPS satellites.

It doesn't sound like a problem with the uconnect itself.
__________________
--
500X Lounge - 1.6 diesel - Venezia Blue
VeneziaBlue500x is offline Reply With Quote Quote 
Old 16-12-2015   #3
Join Date: Dec 2015
Posts: 10
Thanks: 0
Trader Rating: 0
Greece 
Re: Uconnect 5 Navigation problem

Thanks for your answer but unfortunately there are no sensors behind the mirror and there is nothing to open there I think, as I see it. My Fiat 500 X 1.4 Multiair is a lounge version with no extra rain sensor/electrochromic mirror. Rain sensor as far as I know is located behind the mirror.

The space behind my mirror is empty.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Stelios Loumakis is offline Reply With Quote Quote 
Old 16-12-2015   #4
Join Date: Jul 2015
Posts: 27
Thanks: 6
Trader Rating: 0
USA 
Re: Uconnect 5 Navigation problem

Its very likely a bad or loose GPS antenna. It may be behind the dash or somewhere up in the roof, but its likely something you want the dealer to look at.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

datasage is offline Reply With Quote Quote 
Old 28-12-2015   #5
Join Date: Dec 2015
Posts: 10
Thanks: 0
Trader Rating: 0
Greece 
Re: Uconnect 5 Navigation problem

Working navigation extensively the last 10 days, I discovered /realized the following, which I would like to share with you all in order to increase if possible our knowledge and experience with the system:

- Navigation works fine at least 8 out of 10 times, when waiting about 1-2 minutes when starting the car and before moving it. The system needs this 1-2 minutes in order to load the map and locate / lock the position of car through satellites.

- Going to GPS status you can see exactly how many satellites are locked each time by the system in order to locate your car and also the signal strength. Usually the system in my car uses 9-11 satellites with a total signal strength of about 90%.

- Even if during a route, it suddenly loses your position, it is better to do nothing but wait for it to relocate you. Pressing buttons or switching to menus to clear route in order to re-program it, is only adding workload that will increase the delay for the system to relocate you.

- I have the impression that if the system is used everyday, it is becoming better as far as its response is concerned.

- Through unconnect live a made and update and now I can also have traffic information in the navigation with red or yellow colors and time delay estimation or alternative routes.

- I have the impression that trees are affecting negatively the operation of the system. I am also curious to see how cloudiness affects the system. In Athens the last 10 days we have continuously clear sky, so I haven't made up my mind.

- Having checked all the above I really don't thing that there is an antenna problem. It is all about how the system works, its sensitivity and its limitations.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Stelios Loumakis is offline Reply With Quote Quote 
Old 29-12-2015   #6
Join Date: Jul 2015
Posts: 27
Thanks: 6
Trader Rating: 0
USA 
Re: Uconnect 5 Navigation problem

Tunnels, mountains, tall buildings can all affect how many satellites you lock on to. Generally you at least 3 points to get a position in 3d space. More points make positioning more precise.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

datasage is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Uconnect bluetooth joshuamartin1 500X 3 17-11-2015 20:43
(G) uConnect Navigation maps Dennis NL 500L 3 24-06-2015 21:52