Register Login
FIAT Auto Specialist Team
Reply
 
Thread Tools
Old 4 Weeks Ago   #1
Join Date: Aug 2019
Posts: 4
Thanks: 0
Trader Rating: 0
United Kingdom 
Help

So I have had my Fiat 500L for just over 2.5 years now and it randomly showed a check transmission warning light. A couple of days later I went to start the car the engine turned on fine however when I put it into Drive the car just revved and started to roll down the hill, my immediate reaction was to put it into reverse and move it back however this didnít work either again just revved when I accelerated.
You can hear the gearbox engaging with the gears when moving them into drive and reverse however it just wonít move.

Had a mechanic come out and look he plugged his diagnostic machine into the car and it told him
the clutch speed sensor needs replacing?!
Has anyone else had this issue and is the clutch speed sensor the thing that is causing this issue???? HELP with 4 kids and a baby on due in the next 2 weeks life is becoming so hard without our car
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Rjwynne is offline Reply With Quote Quote 
Old 4 Weeks Ago   #2
Join Date: Aug 2019
Posts: 4
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Help

Anyone ?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Rjwynne is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump