Register Login
im Axle Specialists
Reply
 
Thread Tools Search this Thread
Old 2 Weeks Ago   #1
Join Date: Sep 2021
Posts: 11
Thanks: 0
Trader Rating: 0
United Kingdom 
Fiat 500 Indicator issues

Hi,


I have a 2010 1.2 Pop and the left hand indicators are not working at all. I have checked the bulbs and all are fine so I am guessing it is a fuse or relay issue?


Could anyone advise on the fuse/relay location for the LH indicators or suggest what the fault may be? I have some issues with the loom at the top of the boot lid, could it be linked to this?


Many thanks in advance.


Stevie
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Drozich is offline Reply With Quote Quote 
Old 2 Weeks Ago   #2
Join Date: Sep 2007
Location: Alkmaar, Netherlands
Posts: 2,004
Thanks: 131
Trader Rating: 0
Netherlands 
Re: Fiat 500 Indicator issues

What happens when you turn on the hazardlights? Stalk is a usual suspect. Or bodycomputer, but that's expensive.

gr J
__________________
"Look for the ridiculous in everything and you will find it". - Jules Renard
A3jeroen is offline Reply With Quote Quote 
Old 2 Weeks Ago   #3
It's always more involved
 
John202020's Avatar
Join Date: Feb 2016
Location: Tynemouth
Posts: 4,136
Thanks: 203
Trader Rating: 0
John202020 has donated!
United Kingdom 
Re: Fiat 500 Indicator issues

Does EVERYTHING work correctly on the rear hatch? whilst the indicators are not on it its a possibility?
__________________
30 years of Honda Accords, now Mazda 6 and a Fiat 500
John202020 is online now Reply With Quote Quote 
Old 2 Weeks Ago   #4
Join Date: Dec 2014
Location: Orpington, Kent UK
Posts: 3,959
Thanks: 342
Trader Rating: 0
typecastboy has donated!
United Kingdom 
Re: Fiat 500 Indicator issues

You said you have some issues with your hatch wiring so I think youíve answered your own question. There isnít a fuse for the left indicator itís a fuse for the indicators.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

typecastboy is offline Reply With Quote Quote 
Old 2 Weeks Ago   #5
Join Date: Oct 2017
Location: West Yorkshire
Posts: 3,743
Thanks: 212
Trader Rating: 0
chris3234 has donated!
United Kingdom 
Re: Fiat 500 Indicator issues

Do they work if you press the Hazard's
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

chris3234 is offline Reply With Quote Quote 
Old 2 Weeks Ago   #6
Join Date: Sep 2021
Posts: 11
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Fiat 500 Indicator issues

Quote Originally Posted by A3jeroen View Post
What happens when you turn on the hazardlights? Stalk is a usual suspect. Or bodycomputer, but that's expensive.

gr J

Apologies mate, didn't realise I had responses.


Same issue when I put the hazards on.


Thanks.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Drozich is offline Reply With Quote Quote 
Old 2 Weeks Ago   #7
Join Date: Sep 2021
Posts: 11
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Fiat 500 Indicator issues

Quote Originally Posted by typecastboy View Post
You said you have some issues with your hatch wiring so I think youíve answered your own question. There isnít a fuse for the left indicator itís a fuse for the indicators.

None of the LH indicators work. Are they all wired though the hatch?


Thanks you.


Stevie
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Drozich is offline Reply With Quote Quote 
Old 2 Weeks Ago   #8
Join Date: Sep 2021
Posts: 11
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Fiat 500 Indicator issues

Quote Originally Posted by John202020 View Post
Does EVERYTHING work correctly on the rear hatch? whilst the indicators are not on it its a possibility?

Hi there,


High level brake light isn't working at present. Does the wiring for the indicators go through there too?


Thanks,
Stevie
Likes Baglady1990 liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Drozich is offline Reply With Quote Quote 
Old 2 Weeks Ago   #9
Join Date: Sep 2021
Posts: 11
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Fiat 500 Indicator issues

Quote Originally Posted by chris3234 View Post
Do they work if you press the Hazard's
No mate, they don't work when the hazards are on either.


Thanks,
Stevie
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Drozich is offline Reply With Quote Quote 
Old 2 Weeks Ago   #10
I can do stuff!
 
Baglady1990's Avatar
Join Date: Jun 2019
Location: west yorks
Posts: 1,312
Thanks: 81
Trader Rating: 0
Baglady1990 has donated!
United Kingdom 
Quote Originally Posted by Drozich View Post
No mate, they don't work when the hazards are on either.


Thanks,
Stevie
If itís not a fuse issue then Iíd say hatch wiring! I repaired mine with soldier and heat wraps .. that repair lasted a year
I had to repair it properly with the kit off eBay as my rear brake light wasnít working!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Baglady1990 is offline Reply With Quote Quote 
Old 2 Weeks Ago   #11
It's always more involved
 
John202020's Avatar
Join Date: Feb 2016
Location: Tynemouth
Posts: 4,136
Thanks: 203
Trader Rating: 0
John202020 has donated!
United Kingdom 
Re: Fiat 500 Indicator issues

So for now ignore the hatch wiring, does the tell tale come on, on the dash for left?

All the wiring goes to the fuse box under the dash the body computer controls the lights
__________________
30 years of Honda Accords, now Mazda 6 and a Fiat 500

Last edited by John202020; 2 Weeks Ago at 19:22.
John202020 is online now Reply With Quote Quote 
Old 2 Weeks Ago   #12
Join Date: Sep 2021
Posts: 11
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Fiat 500 Indicator issues

Hi,

The tell tale comes on, yes. Flashes much faster than usual as you would expect.

Thanks,
Stevie
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Drozich is offline Reply With Quote Quote 
Old 2 Weeks Ago   #13
It's always more involved
 
John202020's Avatar
Join Date: Feb 2016
Location: Tynemouth
Posts: 4,136
Thanks: 203
Trader Rating: 0
John202020 has donated!
United Kingdom 
Re: Fiat 500 Indicator issues

Does the side repeater work
Have you tried new bulbs front and rear?

You could try, remove rear light cluster, swap the reversing bulb or brake and indicator, now see if it works, swap back afterwards
__________________
30 years of Honda Accords, now Mazda 6 and a Fiat 500

Last edited by John202020; 2 Weeks Ago at 09:03.
John202020 is online now Reply With Quote Quote 
Old 2 Weeks Ago   #14
Join Date: Sep 2021
Posts: 11
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Fiat 500 Indicator issues

Quote Originally Posted by John202020 View Post
Does the side repeater work
Have you tried new bulbs front and rear?

You could try, remove rear light cluster, swap the reversing bulb or brake and indicator, now see if it works, swap back afterwards


Hi there,


No side repeater either, none of them work on the LH side of the car.


Does the fact that the tell-tale on the dash works suggest that it is not the stalk or BCM?


I will try the swapping of lights though and see what happens. You never know.


I will be repairing the hatch wiring today anyway as I have my MOT soon. I don't know if that will help but it is worth a punt.


Thank you.


Stevie
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Drozich is offline Reply With Quote Quote 
Old 2 Weeks Ago   #15
Join Date: Oct 2017
Location: West Yorkshire
Posts: 3,743
Thanks: 212
Trader Rating: 0
chris3234 has donated!
United Kingdom 
Re: Fiat 500 Indicator issues

If you get the indicator on the dash you have a single from the bcm and the switch must be working
So it looks like a wiring fault some place
Likes John202020 liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

chris3234 is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Fiat 500 front indicator lenses eng622 500 (Classic) 2 12-10-2019 23:44
(T) Indicator issues again Chrismunn 500 (Classic) 14 26-08-2018 15:17
(T) Indicator Issues Cento186 Cinquecento / Seicento 10 12-08-2013 17:31