Register Login
Save up to 15% with Adrian Flux insurance!
Reply
 
Thread Tools
Old 02-01-2019   #1
Join Date: Mar 2018
Posts: 8
Thanks: 0
Trader Rating: 0
United Kingdom 
Please help

I've has this problem with my fiat 500 and i was wondering if anyone has had a similar issue.

I was on a dual carriageway and my car started to judder and went sluggish and lost speed. when i realised i pulled over immediately and as i was pulling over the start stop light and the engine light came on but no message. When pulled over i turned my car off as i was scared something bad was happening to it and when i turned it back on the lights have gone off. Since this no lights have been back on so no one can find out what it is and is a trail and error.

Had so many problems with my car feel like just getting it fixed and sell it now

Any help would be great, thank you in advance
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Ellie123 is offline Reply With Quote Quote 
Old 02-01-2019   #2
Join Date: Apr 2011
Location: Near the M4
Posts: 19,386
Thanks: 697
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Re: Please help

Hi Ellie. And welcome.

That sounds scary.. :/

What other engine problems have you had..??
Could be related..


Best bet it to get the car disgnosed .. takes 5 minutes to read the error codes stored after the lights came on.

Whereare you based ?
Charlie . Oxford
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Old 02-01-2019   #3
Join Date: Dec 2003
Location: The land that time forgot
Posts: 2,489
Thanks: 186
Trader Rating: 0
United Kingdom 
Re: Please help

It sounds like you've had an electrical failure but to be so sudden and complete, it is probably something fairly simple, although that might sound contradictory.

Assumimg by "no lights" you mean the dashboard is just dead when you turn the key, you could just have a detached battery cable, or a disconnected earth strap.

Check the battery. Make sure the cables are both attached and both are tight. The battery itself should have 12.6V if you can measure it. If you have 6 volts or less then the battery has failed.

If you have *anything* electrical still working (e.g. radio, courtesy lights etc.) then the battery cables are not the problem, although you may have a loose/poor contact on the earth strap. Follow the black lead from the battery... it should end up attached firmly to the car body.. about 8" away.

If you have any electrics at all, you could have blown a fuse to the ECU, although that's not so good. Check all the fuses in the engine compartment to confirm whether any have blown... but fuses don't blow for no reason though so "what caused it" might be one needing further investigation.

I presume the engine was still running after you pulled over/before you turned it off... and the "died" doesn't relate to the motore itself? If there's no outward sign or sound of engine damage (clonking, smoke, oil on the floor, holes in the block etc.) then that's good. It'll certainly be okay once the ^^ problem is sorted out.

If you have electrics and the engine turns over but it just doesn't start, that could be the fuel emergency shut-off. It's a little switch (possibly next to the passenger's left knee, or under their seat) and it'll click off to close down the fuel pump if you have an accident. It can also activate if you go over a very large bump. Press the switch in (it has a rubber cap with a button underneath it) for it to be "on".

If you have electrics and the fuel shut-off is not activated then the beast should start and run.


Ralf S.
Likes KungFooPanda liked this post
__________________
No bullets for chaingun
Ralf S. is offline Reply With Quote Quote 
Old 02-01-2019   #4
Join Date: Mar 2018
Posts: 8
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Please help

Well ive had a thermostat which was ages ago, had a wiring problem with my high beam light and other annoying little things such as my lights keep going. Just feel like we are always under the bonnet.

When i mean lights i mean warning lights my fiat 500 is a 1.2 engine. When it is plugged in it doesn't come up with anything because there is no warning lights. I had a mechanic look at it this morning and he was like yeah that's bad and was like this is a trail and error thing as no codes are coming up.

Im based in Cheltenham
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Ellie123 is offline Reply With Quote Quote 
Old 02-01-2019   #5
Join Date: Dec 2003
Location: The land that time forgot
Posts: 2,489
Thanks: 186
Trader Rating: 0
United Kingdom 
Re: Please help

If the warning lights are out then it's quite likely to be an earthing problem since I guess your mechanic would spot if a battery lead had come off.

There are a few earths. The battery negative/black lead is one... but there are usually one or two others. There's probably one near or under the battery for instance... and there may be one in more or less the same place on the other side of the car. It could just need a clean up and/or tightening up.

If you've had previous electrical works for lighting issues, then that might point to the same thing. Hopefully the repairer didn't lash up something that has caused this problem..


Ralf S.
__________________
No bullets for chaingun
Ralf S. is offline Reply With Quote Quote 
Old 02-01-2019   #6
Join Date: Apr 2011
Location: Near the M4
Posts: 19,386
Thanks: 697
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Quote Originally Posted by Ellie123 View Post
Well ive had a thermostat which was ages ago, had a wiring problem with my high beam light and other annoying little things such as my lights keep going. Just feel like we are always under the bonnet.

When i mean lights i mean warning lights my fiat 500 is a 1.2 engine. When it is plugged in it doesn't come up with anything because there is no warning lights. I had a mechanic look at it this morning and he was like yeah that's bad and was like this is a trail and error thing as no codes are coming up.

Im based in Cheltenham
Hi again

There are common issues with wiring to the rear hatch.. causes weird stuff like this.

And relatively easy to fix.

See other HATCH WIRING threads on here.

Charlie
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Old 02-01-2019   #7
Join Date: Dec 2014
Location: Orpington, Kent UK
Posts: 2,537
Thanks: 160
Trader Rating: 0
United Kingdom 
Re: Please help

Click image for larger version

Name:	IMG_2085.JPG
Views:	12
Size:	466.9 KB
ID:	196281this is where you will find the main earth points. Underneath the battery tray.
Likes varesecrazy liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

typecastboy is offline Reply With Quote Quote 
Old 05-01-2019   #8
Join Date: Mar 2018
Posts: 8
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Please help

So i have changed the spark plus and coil pack and it has made my engine sound better but its still juddering quite bad and i dont know how to fix it as its not coming up with any warning lights
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Ellie123 is offline Reply With Quote Quote 
Old 05-01-2019   #9
Join Date: Apr 2011
Location: Near the M4
Posts: 19,386
Thanks: 697
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Quote Originally Posted by Ellie123 View Post
So i have changed the spark plus and coil pack and it has made my engine sound better but its still juddering quite bad and i dont know how to fix it as its not coming up with any warning lights
So. Did the plugs look bad?

Strange this made a noticable difference.

Unplug battery power for a few hours.. now you have changed parts

Still get the hatch wiring checked.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump