Register Login
im Axle Specialists
Reply
 
Thread Tools Search this Thread
Old 20-12-2017   #1
Too many hobbies
 
Bookish's Avatar
Join Date: May 2011
Location: Harlington, Bedfordshire
Posts: 188
Thanks: 3
Trader Rating: 0
Bookish has donated!
United Kingdom 
Serviced my 500 2011 twinair plus yesterday.

Had a minor issue with a lumpy idle on these cold mornings and the car was due a service (55000 miles) my cheap ODB scanner not picking up any faults. Warning triangle on dash flashing.

Serviced with new iridium plugs, selenia c3 grade oil plus filter, new coil packs. Still lumpy but no warning light now.

The last time this happened it turned out to be a broken clutch pedal and switch! But the symptoms were far worse than they are now.

Battery was replaced last year with a new stop start item.

My thoughts are turning towards a MAF sensor but its not flagging up on the scanner.

Any thoughts chaps/chappesses?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Bookish is offline Reply With Quote Quote 
Old 20-12-2017   #2
It's always more involved
 
John202020's Avatar
Join Date: Feb 2016
Location: Tynemouth
Posts: 3,857
Thanks: 171
Trader Rating: 0
John202020 has donated!
United Kingdom 
Re: Serviced my 500 2011 twinair plus yesterday.

Unfortunately you need the right software on your computer and the correct leads to read the cars various computers your hand held won't work at all.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

John202020 is offline Reply With Quote Quote 
Old 20-12-2017   #3
Too many hobbies
 
Bookish's Avatar
Join Date: May 2011
Location: Harlington, Bedfordshire
Posts: 188
Thanks: 3
Trader Rating: 0
Bookish has donated!
United Kingdom 
Oh dear, thats what I thought someone would say. Was hoping for a blindingly obvious answer that I'd over looked.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Bookish is offline Reply With Quote Quote 
Old 21-12-2017   #4
Join Date: Apr 2013
Posts: 73
Thanks: 13
Trader Rating: 0
Germany 
Re: Serviced my 500 2011 twinair plus yesterday.

Since valve control in TA is strongly related to oil viskosity and oil pressure:
Did you use different type of oil (5W40 should be the right one) and oil filter than in the past?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

larslarsen is offline Reply With Quote Quote 
Old 21-12-2017   #5
It's always more involved
 
John202020's Avatar
Join Date: Feb 2016
Location: Tynemouth
Posts: 3,857
Thanks: 171
Trader Rating: 0
John202020 has donated!
United Kingdom 
Re: Serviced my 500 2011 twinair plus yesterday.

I could easily be wrong but did I see the twin air used 0w/30w?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

John202020 is offline Reply With Quote Quote 
Old 21-12-2017   #6
Moderator
 
g8rpi's Avatar
Join Date: Nov 2013
Location: Cambridge
Posts: 4,268
Thanks: 430
Trader Rating: 0
g8rpi has donated!
United Kingdom 
Re: Serviced my 500 2011 twinair plus yesterday.

Quote Originally Posted by Bookish View Post
Oh dear, thats what I thought someone would say. Was hoping for a blindingly obvious answer that I'd over looked.
Have you changed the oil filter (Fiat call it a strainer) in the valve actuator?
I think it's due at 30,000 but often missed.
see
https://www.fiatforum.com/panda-iii/...9=#post4298715


Robert G8RPI.
Likes Peter Pick-Up, Bookish liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

g8rpi is offline Reply With Quote Quote 
Old 21-12-2017   #7
Too many hobbies
 
Bookish's Avatar
Join Date: May 2011
Location: Harlington, Bedfordshire
Posts: 188
Thanks: 3
Trader Rating: 0
Bookish has donated!
United Kingdom 
Quote Originally Posted by g8rpi View Post
Have you changed the oil filter (Fiat call it a strainer) in the valve actuator?
I think it's due at 30,000 but often missed.
see
https://www.fiatforum.com/panda-iii/...9=#post4298715


Robert G8RPI.
I haven't, would fiat have done this on a previous service? Thats a very good link and I shall read it thoroughly when I get home tonight, thank you.
I'm using selenia K c3 grade 5w 40.
Likes John202020 liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Bookish is offline Reply With Quote Quote 
Old 21-12-2017   #8
Join Date: Aug 2015
Posts: 35
Thanks: 2
Trader Rating: 0
United Kingdom 
Re: Serviced my 500 2011 twinair plus yesterday.

Quote Originally Posted by Bookish View Post
The last time this happened it turned out to be a broken clutch pedal and switch! But the symptoms were far worse than they are now.
That's exactly what my wife's car has. Car jolts/judders really bad in 1st and 2nd gear like it is about to stall (kangaroo effect as some call it) and it's been in at Fiat for almost 3 weeks and they were unable to find any fault. Thanks to this forum I was able to diagnose the issue myself. How did you fix it? Did you replace the clutch pedal assembly or did you weld the broken linkage back to the pedal body?
Likes Bookish liked this post
__________________
2019 Renault Megane RS Trophy 300 EDC
2020 VW T-Cross SEL
2012 Fiat 500 Twinair
2007 Renault Megane 2
GeoBog is offline Reply With Quote Quote 
Old 21-12-2017   #9
Too many hobbies
 
Bookish's Avatar
Join Date: May 2011
Location: Harlington, Bedfordshire
Posts: 188
Thanks: 3
Trader Rating: 0
Bookish has donated!
United Kingdom 
Re: Serviced my 500 2011 twinair plus yesterday.

Hi, yep had it welded by an independent garage. Fiat couldnt diagnose mine either!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Bookish is offline Reply With Quote Quote 
Old 21-12-2017   #10
Join Date: Apr 2013
Posts: 73
Thanks: 13
Trader Rating: 0
Germany 
Re: Serviced my 500 2011 twinair plus yesterday.

Quote Originally Posted by John202020 View Post
I could easily be wrong but did I see the twin air used 0w/30w?


The newer ones yes, but not the 2011 models, like my TA plus
Likes John202020, foambullets liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

larslarsen is offline Reply With Quote Quote 
Old 21-12-2017   #11
Join Date: Aug 2010
Location: Dublin
Posts: 1,568
Thanks: 78
Trader Rating: 0
Mercky has donated!
Ireland 
Re: Serviced my 500 2011 twinair plus yesterday.

Quote Originally Posted by g8rpi View Post
Have you changed the oil filter (Fiat call it a strainer) in the valve actuator?
I think it's due at 30,000 but often missed.
see
https://www.fiatforum.com/panda-iii/...9=#post4298715


Robert G8RPI.
I was under the impression that the interesting thing about that filter is that it's not mentioned at all as a service item. Fairly sure it's not listed in my service book at 30k but i'll check it later, well worth checking out though and it may well be the cause of many uniair modules been binned needlessly
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Mercky is offline Reply With Quote Quote 
Old 21-12-2017   #12
Too many hobbies
 
Bookish's Avatar
Join Date: May 2011
Location: Harlington, Bedfordshire
Posts: 188
Thanks: 3
Trader Rating: 0
Bookish has donated!
United Kingdom 
Re: Serviced my 500 2011 twinair plus yesterday.

Just read through the entire thread supplied and I shall remove my filter at the weekend and report back. Seems such a simple little job. Thanks for all the helpful info, its much appreciated.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Bookish is offline Reply With Quote Quote 
Old 23-12-2017   #13
Too many hobbies
 
Bookish's Avatar
Join Date: May 2011
Location: Harlington, Bedfordshire
Posts: 188
Thanks: 3
Trader Rating: 0
Bookish has donated!
United Kingdom 
Right a quick update, my cover cap is removed using a 10mm hex key, now I'm off to buy a THIN walled 15mm socket doh!! As mentioned previously but I missed it. Write back soon.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Bookish is offline Reply With Quote Quote 
Old 23-12-2017   #14
Too many hobbies
 
Bookish's Avatar
Join Date: May 2011
Location: Harlington, Bedfordshire
Posts: 188
Thanks: 3
Trader Rating: 0
Bookish has donated!
United Kingdom 
Right filter is clean as a whistle and since driving the car today in warmer weather there has been no symptoms.
So I've ruled out the oil filter issue, I've ruled out any fault with the clutch pedal (previously welded broken link). Although there is a "wonky" part above the brake peddle with no adverse effects on driving.

Here is a link to my google photos album with some pictures of the filter removal (mine was a 10mm hex key to remove the metal cover cap and a small halfords 5.99 hand socket 15mm to remove the filter)

https://photos.app.goo.gl/l8EgusjfefIBC18w1

So it all seems cold weather related.
Diagnostic in the new year then
Likes varesecrazy liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Bookish is offline Reply With Quote Quote 
Old 23-12-2017   #15
Too many hobbies
 
Bookish's Avatar
Join Date: May 2011
Location: Harlington, Bedfordshire
Posts: 188
Thanks: 3
Trader Rating: 0
Bookish has donated!
United Kingdom 
Re: Serviced my 500 2011 twinair plus yesterday.

Another thing.....my service light seems to have reset itself? Its no longer warning me it's due a service, could this be because I disconnected the battery to change the coils and plugs? Seems odd.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Bookish is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Injection warning light 500 0.9 twinair 2011 thethink79 500 2 22-05-2017 09:05
(T) Serviced yesterday and.... Big Black Stilo Bravo 2 12-05-2009 21:42