Register Login
The UK's No.1 Chrysler Owners Forum
Reply
 
Thread Tools
Old 29-10-2016   #1
Join Date: Oct 2016
Posts: 4
Thanks: 0
Trader Rating: 0
USA 
Hill Start/ESC/Cluster dead

So today as I was driving and I got a HILL START disabled message and an ESC light. I stopped put it in park and shut off the car, I started it back up and it would not come out of park. So I turned off the key again and started it again and it wouldn't do anything, it started but the cluster was blank, tach didn't work and it wouldn't come out of park. I used the key to push the shift lock, I put it in neutral and started the car. It went into drive and it seemed to run fine but nothing was working. No brake lights, no dash light, not tach.

2012 500 Sport
Automatic
36000 miles

So what would cause this issue?

Everything works but it won't come out of park and as soon as you turn the key on it kills the cluster?

Blinkers don't work and brake lights don't work

No steering lock either

Fog lights don't work and rear defroster.

Wipers work, AC works, stereo works, blue and me works.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

bowen71 is offline Reply With Quote Quote 
Old 29-10-2016   #2
Join Date: Apr 2011
Location: Near the M4
Posts: 20,145
Thanks: 720
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Re: Hill Start/ESC/Cluster dead

Quote Originally Posted by bowen71 View Post
So today as I was driving and I got a HILL START disabled message and an ESC light. I stopped put it in park and shut off the car, I started it back up and it would not come out of park. So I turned off the key again and started it again and it wouldn't do anything, it started but the cluster was blank, tach didn't work and it wouldn't come out of park. I used the key to push the shift lock, I put it in neutral and started the car. It went into drive and it seemed to run fine but nothing was working. No brake lights, no dash light, not tach.

2012 500 Sport
Automatic
36000 miles

So what would cause this issue?

Everything works but it won't come out of park and as soon as you turn the key on it kills the cluster?

Blinkers don't work and brake lights don't work

No steering lock either

Fog lights don't work and rear defroster.

Wipers work, AC works, stereo works, blue and me works.
Hi, and welcome,
sounds like a basic electrical problem..,
have you had any work done lately?? ( possibility of something not being replaced properly)

another strong possibility is that the cables supplying power to the tailgate / rear hatch have frayed / broken.

both these have happened reasonably frequently in the EURO 500,
posts covering the fixes are here;
https://www.fiatforum.com/500/443163...connected.html

https://www.fiatforum.com/500/434578...-thread-2.html

https://www.fiatforum.com/500/437419...ssion-etc.html

Charlie - Oxford - England
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Old 31-10-2016   #3
Join Date: Oct 2016
Posts: 4
Thanks: 0
Trader Rating: 0
USA 
Re: Hill Start/ESC/Cluster dead

So I checked everything again
I posted earlier that the blinkers don't work, they do work they just don't show on the cluster.


So no steering lock, no shift lock and no brake lights and the cluster works when you open the door it shows the time, temp and mileage. As soon as you start the car the cluster goes blank, as soon as you bypass the shift lock it beeps and shows a "P" in the center of the cluster.


I have ordered the brake switch but, I don't really think its the problem. That is what turns on the brake lights and disengages the shift lock and it was a $9 part. As soon as it comes in I will install it and see what it does or at least start from there.


Does anyone have a wiring diagram for the car?
Likes varesecrazy liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

bowen71 is offline Reply With Quote Quote 
Old 31-10-2016   #4
Join Date: Apr 2011
Location: Near the M4
Posts: 20,145
Thanks: 720
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Re: Hill Start/ESC/Cluster dead

SEARCH on the forum in "advanced" will let you search specific sections quite easily.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Old 31-10-2016   #5
It's always more involved
Join Date: Feb 2016
Location: Tynemouth
Posts: 2,839
Thanks: 100
Trader Rating: 0
John202020 has donated!
United Kingdom 
Re: Hill Start/ESC/Cluster dead

Have you checked the boot wires yet, properly?
Likes Super Uwe liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

John202020 is offline Reply With Quote Quote 
Old 01-11-2016   #6
Join Date: Sep 2009
Location: Bit south in Devon like
Posts: 1,924
Thanks: 151
Trader Rating: 0
Super Uwe has donated!
United Kingdom 
Re: Hill Start/ESC/Cluster dead

I would agree with the post above, check the boot wiring and see if the wires are frayed.

https://www.fiatforum.com/500/423837...hissy-fit.html

See post 12 from @jrkitching, it has a lovely clear picture of what to look for.

Of course this might not be the problem, but it is so often the cause of random electrical gremlins in the 500 on this forum. Other than that, with your car being a 2012 model, it could well be down to the battery starting to fail.

But I would 100% start with the boot wiring first. Let us know how you get on.
Likes varesecrazy liked this post
__________________
Had a 500, then a Panda, then a Punto, wife had another 500...now a Fiesta
Super Uwe is offline Reply With Quote Quote 
Old 01-11-2016   #7
Join Date: Oct 2016
Posts: 4
Thanks: 0
Trader Rating: 0
USA 
Re: Hill Start/ESC/Cluster dead

So, my car broke down on the 28th my warranty is up on the 29th (Saturday) I called the dealer and they said they will work with me on it so I am towing it to the dealer on Wednesday, wish me luck.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

bowen71 is offline Reply With Quote Quote 
Old 02-11-2016   #8
Join Date: Sep 2009
Location: Bit south in Devon like
Posts: 1,924
Thanks: 151
Trader Rating: 0
Super Uwe has donated!
United Kingdom 
Re: Hill Start/ESC/Cluster dead

Quote Originally Posted by bowen71 View Post
So, my car broke down on the 28th my warranty is up on the 29th (Saturday) I called the dealer and they said they will work with me on it so I am towing it to the dealer on Wednesday, wish me luck.
Yes good luck with it. At least you have some ideas to go to your dealer with as well, do keep us updated of progress if you can.
__________________
Had a 500, then a Panda, then a Punto, wife had another 500...now a Fiesta
Super Uwe is offline Reply With Quote Quote 
Old 04-11-2016   #9
Join Date: Oct 2016
Posts: 4
Thanks: 0
Trader Rating: 0
USA 
Re: Hill Start/ESC/Cluster dead

Well, just got a call from the dealer and they say its the brake light switch and the cluster. I don't know how they both died at the exact same time. They are taking it to the warranty manager to see if they will cover it.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

bowen71 is offline Reply With Quote Quote 
Old 04-11-2016   #10
Join Date: Oct 2016
Posts: 46
Thanks: 2
Trader Rating: 0
United Kingdom 
Re: Hill Start/ESC/Cluster dead

It was broke while the car was under warranty, why wouldn't they cover it? They might need a gentle kick up the rear and reminder of what a warranty is.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

T Bay is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) Hill holder/start stop/esc error: one solution philboo Panda (2012+) 2 16-10-2016 13:29
(T) 2011 500c semi auto, electronic issues, hill start, esp, stop start transmission etc. chris red 500 9 18-04-2016 16:00
(T) Loss of power when esc/hillhold/stop/start/check engine message appears vickiw Barchetta 2 15-04-2016 21:45
(T) Instrument cluster dead... but an odd one this! V8burble 500 12 09-04-2016 21:41
(T) Help! Instrument Cluster dead+alive carlmiddleditch Stilo 5 13-12-2008 17:58