Register Login
Mr FIAT - Your #1 source for vintage car parts
Reply
 
Thread Tools
Old 29-07-2016   #1
Join Date: Jul 2016
Posts: 5
Thanks: 0
Trader Rating: 0
United Kingdom 
Engine problems!

Hi all,

new to the forum and looking for some advice...I have had my Fiat 500 just over 4 years and I love it. Never had any problems...until recently when coming up to a junction (slight incline), went into first gear ready to pull of and the 'Start stop unavailable' message popped up on screen briefly and the engine cut out? couldn't get the engine started again, it just turned over (after checking immobilizer etc). My father-in-law is a mechanic so he came and rescued me, replaced the spark plugs and all seemed okay...until a week later at the same junction it did exactly the same thing, showing the start stop message etc. I was able to restart it myself by shoving my foot on the accelerator! took back to my father-in-law's garage and it's saying 'uncoded error' on the diagnostic machine. He can't work out the problem, it done it again last (with me being able to restart again). Just don't know what to do, and my nearest Fiat dealership is over 40 miles away? It's a 0.8 turbo, 60 plate.

would much appreciate any help, I love my little car and really want to get it fixed rather than sell!

Thank you
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

ASTEPHANIE is offline Reply With Quote Quote 
Old 29-07-2016   #2
Full Circle
Join Date: Aug 2010
Location: Dublin
Posts: 1,557
Thanks: 78
Trader Rating: 0
Mercky has donated!
Ireland 
Re: Engine problems!

Quote Originally Posted by ASTEPHANIE View Post
Hi all,



new to the forum and looking for some advice...I have had my Fiat 500 just over 4 years and I love it. Never had any problems...until recently when coming up to a junction (slight incline), went into first gear ready to pull of and the 'Start stop unavailable' message popped up on screen briefly and the engine cut out? couldn't get the engine started again, it just turned over (after checking immobilizer etc). My father-in-law is a mechanic so he came and rescued me, replaced the spark plugs and all seemed okay...until a week later at the same junction it did exactly the same thing, showing the start stop message etc. I was able to restart it myself by shoving my foot on the accelerator! took back to my father-in-law's garage and it's saying 'uncoded error' on the diagnostic machine. He can't work out the problem, it done it again last (with me being able to restart again). Just don't know what to do, and my nearest Fiat dealership is over 40 miles away? It's a 0.8 turbo, 60 plate.



would much appreciate any help, I love my little car and really want to get it fixed rather than sell!



Thank you

Possibly your battery is the culprit. After 4 years in a stop start car it could well be knackered although it appears fine
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Mercky is offline Reply With Quote Quote 
Old 29-07-2016   #3
Moderator
 
g8rpi's Avatar
Join Date: Nov 2013
Location: Cambridge
Posts: 4,105
Thanks: 418
Trader Rating: 0
g8rpi has donated!
United Kingdom 
Re: Engine problems!

Quote Originally Posted by ASTEPHANIE View Post
Hi all,

new to the forum and looking for some advice...I have had my Fiat 500 just over 4 years and I love it. Never had any problems...until recently when coming up to a junction (slight incline), went into first gear ready to pull of and the 'Start stop unavailable' message popped up on screen briefly and the engine cut out? couldn't get the engine started again, it just turned over (after checking immobilizer etc). My father-in-law is a mechanic so he came and rescued me, replaced the spark plugs and all seemed okay...until a week later at the same junction it did exactly the same thing, showing the start stop message etc. I was able to restart it myself by shoving my foot on the accelerator! took back to my father-in-law's garage and it's saying 'uncoded error' on the diagnostic machine. He can't work out the problem, it done it again last (with me being able to restart again). Just don't know what to do, and my nearest Fiat dealership is over 40 miles away? It's a 0.8 turbo, 60 plate.

would much appreciate any help, I love my little car and really want to get it fixed rather than sell!

Thank you

Tend to agree with Merky, if the battery has not been changed during your ownership you should do that first, it's probably due anyway.
On the "uncoded" error consider getting (or your father-in-law getting) Multiecuscan software www.multiecuscan.com and a interface (ELM 327 USB, modified, about 20 on ebay. This will read the Fiat specific codes.


Robert G8RPI.
Likes Super Uwe liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

g8rpi is offline Reply With Quote Quote 
Old 29-07-2016   #4
Join Date: Jul 2016
Posts: 5
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Engine problems!

Okay, thank you both - battery has been checked though, it was one of the first things as I think he thought the same as you.
Thanks again
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

ASTEPHANIE is offline Reply With Quote Quote 
Old 29-07-2016   #5
Join Date: Apr 2011
Location: Near the M4
Posts: 20,571
Thanks: 729
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Re: Engine problems!

Quote Originally Posted by ASTEPHANIE View Post
Okay, thank you both - battery has been checked though, it was one of the first things as I think he thought the same as you.
Thanks again
Hi,

the battery is the main cause of the S/S unavailable on a twinair

how many miles on the car..?? replacing the sparkplugs points to it being in need of a service - however that may just have been an attempt at a fix..,
as it's obviously still doing it.

so - at the bottom of this hill...what's happening..??,

is the engine "bogging-down" - failing to build revs-
and almost stalling / stalling.

when it does it would be useful to see what the ECU - cars brain - detects the system voltage as..,
I suspect it's dipping..leading to the S/S message.

don't be put-off by being away from a FIAT dealer.. they are unlikely to know straight away..



Charlie - Oxford - 2012 Twinair
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Old 29-07-2016   #6
Join Date: Jul 2016
Posts: 5
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Engine problems!

Hi!
Thanks for that, service was done in January, no problems at all, the slight hill start is about half a mile from my house and its happened as I've left home and been on my way to work. No problem starting, no problems approaching the junction, just as i dip the clutch to go into first to pull off the 'start stop' message appears. Running fine other than that though! the second time it happened and i was able to re-start, the car managed absolutely fine on the rest of my 15 min journey to work. Just can't work out the problem and i feel like i can't rely on my poor little car!

Thanks

annika
Likes varesecrazy liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

ASTEPHANIE is offline Reply With Quote Quote 
Old 29-07-2016   #7
Join Date: Apr 2011
Location: Near the M4
Posts: 20,571
Thanks: 729
Trader Rating: 0
varesecrazy has donated!
United Kingdom 
Re: Engine problems!

so - did it PAUSE at the junction..and conk-out as you tried to pull away..?

or conk-out as you slowed approaching the junction..??

just trying to figure out what the engine was doing / being asked to do at the time..

so - where are you / the car based..?? somebody local to you may have the right kit to talk to the ECU properly.

Charlie
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

varesecrazy is offline Reply With Quote Quote 
Old 29-07-2016   #8
Join Date: Jul 2016
Posts: 5
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Engine problems!

Conked-out as I tried to pull off, just went dead! no power steering, managed to roll it back and onto the side of the road.

Based in south lincs, lots of local garages just not sure who would have the right kit without going direct to Fiat (something i'm not keen on...)

Thanks again,

Annika
Likes varesecrazy liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

ASTEPHANIE is offline Reply With Quote Quote 
Old 29-07-2016   #9
Full Circle
Join Date: Aug 2010
Location: Dublin
Posts: 1,557
Thanks: 78
Trader Rating: 0
Mercky has donated!
Ireland 
Re: Engine problems!

....and does the SS work OK during general driving?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Mercky is offline Reply With Quote Quote 
Old 29-07-2016   #10
Join Date: Jul 2016
Posts: 5
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Engine problems!

yes that's working absolutely fine!
Baffling!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

ASTEPHANIE is offline Reply With Quote Quote 
Old 29-07-2016   #11
Join Date: Sep 2009
Location: Bit south in Devon like
Posts: 1,926
Thanks: 151
Trader Rating: 0
Super Uwe has donated!
United Kingdom 
Re: Engine problems!

Very strange and frustrating I'm sure!

I wonder if it could be related to the hatch wiring? Not sure if that would necessarily cause the issue with failing to restart, but it could be the cause of the random "Stop Start Unavailable" message.

Here's a very useful thread started by our resident moderator jrkitching:
https://www.fiatforum.com/500/423837...hissy-fit.html

Post 12 has some pictures of what to look for in the boot. Again, may not be anything to do with it, but it's a check that either you or your father-in-law could do for free.

Other than that, I agree it is maybe worth taking another look at the battery if it is still the original one your car is running on (seeing as it is a 60 plate).
Likes varesecrazy liked this post
__________________
Had a 500, then a Panda, then a Punto, wife had another 500...now a Fiesta
Super Uwe is offline Reply With Quote Quote 
Old 29-07-2016   #12
Join Date: Feb 2008
Location: Sheffield
Posts: 179
Thanks: 10
Trader Rating: 0
pasotibbs has donated!
United Kingdom 
Re: Engine problems!

As it never happens on your way home only on your way to work then it could be simply a stall due to the cold start enrichment ("choke" in old language !) just happening to be backing off at that particular point where the engine is not yet hot enough to cope, possibly due to a faulty temp sensor or fast idle not working correctly?
If half a mile from work you are not at a junction then you would passing through this issue without noticing it ?
Easy enough to test by letting the car warm up slightly before leaving home and seeing if it either occurs closer to home or not at all.
The SS error may be simply be the ECU saying "wasn't me" when the engine stops unexpectedly, try stalling on purpose and seeing if the same error appears ?
The TwinAir is basically like a large 2 cylinder motorcycle and the gap between power pulses means a miss on one cylinder due to a weak mixture or slow idle at low revs could easily stall the engine where a 4 cylinder would stumble and recover, and larger single and twin cylinder bikes can be a pain to restart if neither hot or cold but somewhere in between which would also fit your description.
(at least you don't have to kick start it !!)
Likes varesecrazy liked this post
__________________
Have you tried turning it off and on again ?

Last edited by pasotibbs; 29-07-2016 at 20:12.
pasotibbs is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) major problems with losing engine oil and high engine temp neenor Stilo 20 22-03-2010 16:41
(T) Engine Problems dan818 Punto (Mk2/2b) 1 13-11-2009 10:05
(T) mk2 engine problems? other engine's? adamski1 Punto (Mk2/2b) 9 18-04-2009 17:40
engine problems roncoray FIAT Boo Archives 3 23-03-2006 14:17
engine problems stephen FIAT Boo Archives 1 03-11-2005 14:53