Register Login
FIAT Auto Specialist Team
Reply
 
Thread Tools
Old 14-06-2008   #1
Join Date: Jun 2008
Posts: 2
Thanks: 0
Trader Rating: 0
Spyder losing power at freeway speeds

I am considering buying a '79 Spyder. Owner says it sometimes loses power over 50 mph. Was wondering if anyone would give me best and worst case senarios, on the costs to repair.

Thanks
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Balt123 is offline Reply With Quote Quote 
Old 14-06-2008   #2
Join Date: Jun 2007
Location: Seneca, SC USA
Posts: 131
Thanks: 5
Trader Rating: 0
USA 
Re: Spyder losing power at freeway speeds

Best case: clogged fuel filter.
Worse case: trash (rust, etc.) in the gas tank requiring removal and cleaning or replacement.

Other: Bad fuel lines, dirty carb.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

GeorgeT is offline Reply With Quote Quote 
Old 30-06-2008   #3
Join Date: Feb 2008
Posts: 21
Thanks: 0
Trader Rating: 0
Re: Spyder losing power at freeway speeds

Also could be a dirty fuel pump or clogged fuel filter. Or maybe even just a condensor problem. Its most likely a cheap fix.

Jacob
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

jacob25119 is offline Reply With Quote Quote 
Old 17-02-2009   #4
Join Date: Oct 2005
Location: Earth!
Posts: 8
Thanks: 0
Trader Rating: 0
Re: Spyder losing power at freeway speeds

As others have said....most likely not getting fuel, change the filter! Cheapest place to start!

__________________
1977 124 Spider 1800cc
rusty124 is offline Reply With Quote Quote 
Old 24-02-2009   #5
Join Date: Feb 2008
Posts: 21
Thanks: 0
Trader Rating: 0
Re: Spyder losing power at freeway speeds

I had a 1979 Fiat Spider with the same EXACT problem.

What I did was replace the condenser and the fuel filter and it worked fine after this, never acted up again. Replace them both. Im not 100% sure which one it was that fixed it, but actually I believe it was the condenser. The fuel filter in mine was relatively new. Ive also had other cars with same symptoms and all it as was a condenser problem.

Let me know how this works for you. Its about $10-$20. Nothing big at all. Hopefully it works well.

Jacob
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

jacob25119 is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) Losing power! tashman Panda (Classic) 12 09-01-2008 23:34
(G) losing power obi1123 Punto (Mk2/2b) 6 30-10-2007 23:30
(T) Losing Power dahig2002 Stilo 10 19-08-2007 23:30
(T) Multipla keeps losing power laurie Multipla 8 18-05-2006 17:23
(T) Losing power when hot SuperUno Uno 5 14-06-2005 12:57