Register Login
Save up to 15% with Adrian Flux insurance!
Reply
 
Thread Tools
Old 17-04-2017   #1
Join Date: Oct 2016
Posts: 1
Thanks: 0
Trader Rating: 0
USA 
Turn Signal

Turn signal problem-Bertone X 1/9, 1979. When he right turn signal is engaged, the panel indicator light flashes 1 or 2 times, then it goes off. But the turn signal keeps clicking at a lower sound level and a slower frequency. However the actual turn signal light in the front does not work, only the back light works at a slower frequency. Does anyone have any experience and knowledge regarding this situation. Thank you
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Ciao Baby is offline Reply With Quote Quote 
Old 17-04-2017   #2
Join Date: Jan 2008
Location: Poole, Dorset
Posts: 1,336
Thanks: 53
Trader Rating: 0
United Kingdom 
Re: Turn Signal

It sounds like it will be a poor or missing earth wire at the light which is not functioning?

They are Black wires which connect to a little tree spade connectors under the headlight motor access doors.
__________________
purf is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Turn signal not working... MKoers Grande Punto 1 15-10-2012 09:48
(T) Turn Signal Issue usafstud 500 (Classic) 3 04-09-2012 04:42
(T) Turn signal not diengaging after turing g50245 Punto (Mk2/2b) 5 04-07-2011 12:55
(G) Scudo turn signal relay - where is it? baldeagle Scudo 2 29-10-2008 14:38
(G) Issue with turn signal diablo_NL Grande Punto 8 20-07-2006 18:08