Register Login
Shop4Parts - UK's largest online superstore for FIAT and Alfa Romeo parts
Reply
 
Thread Tools
Old 12-09-2003   #1
Join Date: Sep 2003
Location: United Kingdom.
Posts: 1
Thanks: 0
Trader Rating: 0
Uno ie 1.0 999cc fuel pump problem

Hi,

The fuel pump on my Uno is getting no power sent to it. I've tried the fuses and the relays and they seem fine. The car has just been serviced and was running perfectly. The problem seemed to happen all of a sudden just after I had parked (ignition off) for about 20mins. Everything else seems fine, but the car acts just like there's no petrol (plenty in the tank). Has anybody any idea of what might be causing the lack of power. By the way I've checked the fuel pump and all its connection already.

Thanx in advance, Jrrsteve
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

jrrsteve is offline Reply With Quote Quote 
Old 12-09-2003   #2
Join Date: Sep 2003
Location: United Kingdom.
Posts: 10
Thanks: 0
Trader Rating: 0
Have you actualy checked the leads to the fuel pump with a voltmeter? If you have then can you follow the leads back until you lose the voltage?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

burns_2k is offline Reply With Quote Quote 
Old 13-09-2003   #3
Join Date: Jan 2003
Location: Birmingham, United Kingdo
Posts: 1,644
Thanks: 2
Trader Rating: 0
United Kingdom 
I don't have the diagrams for the UNO, but on the Panda I have a feeling there's an "in line" fuse in the feed to the pump which isn't to be confused with all the other fuses.

Also the relay(s) on the suspension turret have their own on board fuses.

Finally, the ECU needs to be happy all is well - it has the last say in powering up the relay [:0]
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

John H is offline Reply With Quote Quote 
Old 04-08-2008   #4
Join Date: Aug 2008
Posts: 2
Thanks: 0
Trader Rating: 0
Re: Uno ie 1.0 999cc fuel pump problem

Hi

I have this problem with my uno too, however it seems to be intermitant. I have checked the connections on the fuel pump and found they are ok.
I can try to start the car and it will start one time, a few minutes later it will not start then if it is left for a while untouched it will start again.
Can anyone point me in the right direction as to what to do as I am lost now....

Thanks in advance
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

medicinewolf is offline Reply With Quote Quote 
Old 05-08-2008   #5
Join Date: Aug 2007
Posts: 117
Thanks: 3
Trader Rating: 0
Re: Uno ie 1.0 999cc fuel pump problem

Has the car got an immobiliser fitted?

Matt
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

stealthstylz is offline Reply With Quote Quote 
Old 06-08-2008   #6
Join Date: Aug 2008
Posts: 2
Thanks: 0
Trader Rating: 0
Re: Uno ie 1.0 999cc fuel pump problem

Hi
No it does not have an immobiliser fitted to it.

Phil
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

medicinewolf is offline Reply With Quote Quote 
Old 19-07-2017   #7
Join Date: Jul 2017
Posts: 2
Thanks: 0
Trader Rating: 0
Denmark 
Re: Uno ie 1.0 999cc fuel pump problem

Did you find the fault ?
My car have the same fault
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Kaerby is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Power loss - fule pump problem?? raduvacaru Punto (Mk1) 2 11-09-2005 16:37
(T) Weird fuel problem. baconbuttie Multipla 4 22-07-2005 23:51
(T) Fuel problem 130 jtd frans01 Marea 1 06-06-2004 23:48
(T) Cinq Fuel Pump delivery rate? brickfoot Cinquecento / Seicento 8 12-03-2004 19:33
(T) Fuel line problem? arc Cinquecento / Seicento 2 22-12-2003 05:45